Mencoder régi beállítások, újabb gép nincs hangeszköz (legalábbis nem találom

 ( Gael | 2016. február 6., szombat - 18:40 )

Sziasztok!
Elő kellett vegyem a mencodert mert videokazettát szeretnék digitalizálni.
A probléma ott kezdődik, hogy a mencoder opciók a régi gépemen működtek ezen már nem. Az audioeszközre panaszkodik.
MS-7721:~$ mencoder -tv driver=v4l2:norm=pal:input=3:audiorate=44100:amode=1:normid=1:quality=100:forceaudio=1:width=768:height=576:buffersize=1000:fps=25 tv:// -o Video.mpeg -ovc lavc -of mpeg -mpegopts format=dvd -vf scale=720:576,harddup -srate 48000 -af lavcresample=48000 -lavcopts vcodec=mpeg2video:vrc_buf_size=1835:vrc_maxrate=9800:vbitrate=5000:keyint=15:acodec=ac3:abitrate=192:aspect=16/9 -ofps 25 -oac mp3lame
MEncoder 1.1-4.8 (C) 2000-2012 MPlayer Team
success: format: 9 data: 0x0 - 0x0
TV file format detected.
Selected driver: v4l2
name: Video 4 Linux 2 input
author: Martin Olschewski
comment: first try, more to come ;-)
Selected device: Pinnacle PCTV 40i/50i/110i (saa
Tuner cap: STEREO LANG1 LANG2
Tuner rxs: MONO
Capabilities: video capture video overlay VBI capture device tuner read/write streaming
supported norms: 0 = NTSC; 1 = NTSC-M; 2 = NTSC-M-JP; 3 = NTSC-M-KR; 4 = PAL; 5 = PAL-BG; 6 = PAL-H; 7 = PAL-I; 8 = PAL-DK; 9 = PAL-M; 10 = PAL-N; 11 = PAL-Nc; 12 = PAL-60; 13 = SECAM; 14 = SECAM-B; 15 = SECAM-G; 16 = SECAM-H; 17 = SECAM-DK; 18 = SECAM-L; 19 = SECAM-Lc;
inputs: 0 = Television; 1 = Composite1; 2 = Composite2; 3 = S-Video;
Current input: 3
Current format: YUYV
v4l2: current audio mode is : STEREO
Unable to open '/dev/dsp': No such file or directory
Unable to open '/dev/dsp': No such file or directory
Unable to open '/dev/dsp': No such file or directory
v4l2: 0 frames successfully processed, 0 frames dropped.
============ Sorry, this file format is not recognized/supported =============
=== If this file is an AVI, ASF or MPEG stream, please contact the author! ===
Cannot open demuxer.

Exiting...

A dev alatt nemigazán találtam audioeszözt(vagy csak vak vagyok).
A dmesg kimenete:
-MS-7721:~$ dmesg |grep audio
[ 11.536243] sound hdaudioC1D0: autoconfig: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[ 11.536249] sound hdaudioC1D0: speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[ 11.536251] sound hdaudioC1D0: hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
[ 11.536253] sound hdaudioC1D0: mono: mono_out=0x0
[ 11.536255] sound hdaudioC1D0: inputs:
[ 11.536258] sound hdaudioC1D0: Front Mic=0x19
[ 11.536260] sound hdaudioC1D0: Rear Mic=0x18
[ 11.536262] sound hdaudioC1D0: Line=0x1a

Ettől nem lettem okosabb.
Az lspci kimenete:
00:01.1 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] Trinity HDMI Audio Controller

A videomagnó audio kimenet a line in-be van csatlakoztatva és onnan kéne felvenni a hangot a mencodernek.
Ebben kérek segítséget.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Semmi komoly. OSS-t vár, de neked, illetve minden újabb rendszeren ALSA van. /dev/snd alatt kell lennie. De neked ez nem is kell, mert tök máshogy kell rá hivatkozni. Egyébként jobb is mint az OSS. Tehát a manban, illetve neten erre felé keresgess.

---------------------------------------------------------------
Ritkán szólok hozzá dolgokhoz. Így ne várj tőlem interakciót.