mga_vid és 2.6.x kernel

 ( Fifi | 2004. augusztus 16., hétfő - 14:33 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

[quote:fb18bf6585="Fifi"]
Koszonom!
Most mar nekem is megy 2.6.8.1 vanilla kernel + matroxfb-2.6.8-rc3 patch es a mga-vid-source csomaggal az mga_vid , az SMP es a framebuffer is :)

Nem gondoltam volna, hogy a disztrib csomagjai kozott keressek mga_vid meghajtot, eddig abban a hitben eltem, hogy ez csak az mplayer fejlesztok altal irt es hasznalt meghajto.

Bye, Fifi[/quote:fb18bf6585]

valaki esetleg próbálta már az új 2.6.10 -es kernellel felrakni az mplayeres mga_vid -et mai cvs forrásból? esetleg nem debian csomaggal, hanem vmi mga-vid-2.6.x szerű peccsel? :) én amit találtam e fórum szerint és guglival azokkal mind errorral fordul :(((

Hát nekem 2.6.6-os kernellel remekül működik az mga-vid.
Debian alatt:
[code:1:10007a6556]apt-get install mga-vid-source[/code:1:10007a6556]
aztán kicsomagolod a /usr/src-ben levő tar.gz fájlt, belépsz a kernel forrásba, és bevágod, hogy
[code:1:10007a6556]make-kpkg modules-image[/code:1:10007a6556]
persze ha felraktad a kernel-package nevű csomagot.
Aztán a /usr/src-ben lévő mga-vid....deb csomagot felszórod (dpkg -i mga-vid...). Ha ezzel is megvagy, akkor a /usr/share/doc/mga-vid-source/README.Debian alapján legyártod a device-t betöltöd az mga_vid modulet (modprobe mga_vid) és megy frankón.

[quote:e280fec611="mb"]Hát nekem 2.6.6-os kernellel remekül működik az mga-vid.
Debian alatt:
[code:1:e280fec611]apt-get install mga-vid-source[/code:1:e280fec611]
aztán kicsomagolod a /usr/src-ben levő tar.gz fájlt, belépsz a kernel forrásba, és bevágod, hogy
[code:1:e280fec611]make-kpkg modules-image[/code:1:e280fec611]
persze ha felraktad a kernel-package nevű csomagot.
Aztán a /usr/src-ben lévő mga-vid....deb csomagot felszórod (dpkg -i mga-vid...). Ha ezzel is megvagy, akkor a /usr/share/doc/mga-vid-source/README.Debian alapján legyártod a device-t betöltöd az mga_vid modulet (modprobe mga_vid) és megy frankón.[/quote:e280fec611]

Koszonom!
Most mar nekem is megy 2.6.8.1 vanilla kernel + matroxfb-2.6.8-rc3 patch es a mga-vid-source csomaggal az mga_vid , az SMP es a framebuffer is :)

Nem gondoltam volna, hogy a disztrib csomagjai kozott keressek mga_vid meghajtot, eddig abban a hitben eltem, hogy ez csak az mplayer fejlesztok altal irt es hasznalt meghajto.

Bye, Fifi

Valaki azt árulja el nekem, mi a különbség, az mplayerben lévő mga_vid, és a deb csomag között.

[quote:c9e7a3ebdd="Sun"]Valaki azt árulja el nekem, mi a különbség, az mplayerben lévő mga_vid, és a deb csomag között.[/quote:c9e7a3ebdd]

rakd fel és nyomj egy diff-et rá ;)

[quote:b79dc8cbe6="suti"][quote:b79dc8cbe6="Sun"]Valaki azt árulja el nekem, mi a különbség, az mplayerben lévő mga_vid, és a deb csomag között.[/quote:b79dc8cbe6]

rakd fel és nyomj egy diff-et rá ;)[/quote:b79dc8cbe6]

OK főnök :wink: :wink: :wink:

Probálkozz innen letölteni:

[url]http://attila.kinali.ch/mga/[/url]

Ezt kicsomagolod ahova akarod, make && make install && depmod -a
modprobe ...

[/url]

Hi!

Ez meg akkor tortent, amikor nem volt a 2.6.11-hez, csak a 2.6.10-hez driver. Most mar van, es teljesen jol mukodik. Egyebkent a regi drivert is innen toltottem le.

By(t)e
TBS::Antiemes

[quote:ec3229529d="profBJ"]Probálkozz innen letölteni:

[url]http://attila.kinali.ch/mga/[/url]

Ezt kicsomagolod ahova akarod, make && make install && depmod -a
modprobe ...

[/quote:ec3229529d]
nezd meg a datumot :)

Bocs, ez nem derült ki eddig :wink:

De most már a többi HUP olvasó is megtalálja, ha beleszaladna ebbe a problémába...

BJ

Sziasztok!

Altalam ismeretlen okbol kifolyolag kedvenc debian sarge disztribemben (a gepen csak csomagfrissítés tortent) aprilis ota hasznalt 2.4.26-os kernelem nem akar hangot szolgaltatni kb. egy hete, de ugyanezen a gepen a 2.6.8-rc3 kernellel van hang :(

Fentiek miatt attertem volna a 2.6-os kernelre, de alatta meg nem fordul le az mga_vid driver, melyet MatroxG550 karytammal hasznalnek. :(
kernel: 2.6.7 vanilla + patch-2.6.8-rc3 + matroxfb-2.6.8-rc3 patch

Hibaüzenet utolsó sorai:
/opt/install/mplayer/main/drivers/mga_vid.c: In function `mga_vid_open':
/opt/install/mplayer/main/drivers/mga_vid.c:1511: error: request for member `value' in something not a structure or union
/opt/install/mplayer/main/drivers/mga_vid.c:1542: warning: `MOD_INC_USE_COUNT' is deprecated (declared at
include/linux/module.h:555)
make[3]: *** [/opt/install/mplayer/main/drivers/mga_vid.o] Error 1
make[2]: *** [_module_/opt/install/mplayer/main/drivers] Error 2
make[2]: Leaving directory `/usr/local/src/linux-2.6.7'
make[1]: *** [mga_vid.ko] Error 2
make[1]: Leaving directory `/opt/install/mplayer/main/drivers'
make: *** [all] Error 2

Az mplayer-felhasznalok listan kertem segitseget, de nem jott valasz :(

Tud valaki megoldast? Persze a 2.4-es kernelfabol valsztott kernellel most is fordul az mga_vid, de ott meg nincs hangja az alaplapi AD1985 chipnek.

Segitsegetek koszonom!

Bye, Fifi

Valaki próbálta már ezt:
http://georgi.unixsol.org/programs/mga_vid-2.6.diff/

Lefordulni lefordul szépen, de csak egy konstans zöld négyzet az erdemény :-( mga_vid_test is fut, de az első teszten (a már említett zöld négyzet) kívül más effekt nem működik...

Én is 2.6.10-zel próbálkozom...

Valakinek sikerült már belőni 2.6.10-re?

még korántsem mondható késznek az mga_vid 2.6.x alá
ld.: http://www.mplayerhq.hu/pipermail/mplayer-dev-eng/2004-August/027776.html

Hi!

Tud valaki olyan mga_vid drivert mondani, ami 2.6.11 alatt megy?

By(t)e
TBS::Antiemes

[quote:e4e955c851="vmiklos"]még korántsem mondható késznek az mga_vid 2.6.x alá
ld.: http://www.mplayerhq.hu/pipermail/mplayer-dev-eng/2004-August/027776.html[/quote:e4e955c851]

Hát ez nem biztató ... :(

A http://www.linuxops.net/~pw/mga_vid/ oldalon van egy patch a 2.6-os kernelhez, de a leírás szerint nem működik SMP kernellel. Most forgatok egy SMP nélkülit, hátha így jó lesz.

Ha ez a patch sem jön be, akkor lehet, hogy a hang "eltűnését" fogom tovább firtatni, de ott meg azt sem tudom, hogy melyik debian csomag frissítése után állt be ez az állapot :(

Köszönöm a segítséget!

Bye, Fifi

olvasd el [url=http://www.mplayerhq.hu/pipermail/mplayer-dev-eng/2005-February/033102.html]ezt[/url] a threadet es sztem minden vilagos lesz :wink:

[quote:b2a2f82087="Fifi"][quote:b2a2f82087="vmiklos"]még korántsem mondható késznek az mga_vid 2.6.x alá
ld.: http://www.mplayerhq.hu/pipermail/mplayer-dev-eng/2004-August/027776.html[/quote:b2a2f82087]

Hát ez nem biztató ... :(

A http://www.linuxops.net/~pw/mga_vid/ oldalon van egy patch a 2.6-os kernelhez, de a leírás szerint nem működik SMP kernellel. Most forgatok egy SMP nélkülit, hátha így jó lesz.

Ha ez a patch sem jön be, akkor lehet, hogy a hang "eltűnését" fogom tovább firtatni, de ott meg azt sem tudom, hogy melyik debian csomag frissítése után állt be ez az állapot :(

Köszönöm a segítséget!

Bye, Fifi[/quote:b2a2f82087]

Nekem ez volt az egyik ok, hogy az otthoni munkaállomásomon hagytam a 2.6-os kernelt a fenébe, és maradtam a 2.4-esnél. :x

Hi!

A debianosat feltettem, le is fordult, viszont mivel az uj kernelekben nincs remap_page_range(), nem megy. Rakerestem a forrasban, egy helyen hasznalja csak a driver.

[code:1:fbedd31f21]if(remap_page_range(vma, vma->vm_start, card->mem_base + card->src_base, vma->vm_end - vma->vm_start, vma->vm_page_prot)) printk(KERN_ERR "mga_vid: error mapping video memory\n");[/code:1:fbedd31f21]

Illetve talaltam egy masik, ujabb drivert is, ami szinten fordul, de az is hasznalja a remap_page_range()-t.

[code:1:fbedd31f21]if(remap_page_range(vma, vma->vm_start, card->mem_base + cardprintk(KERN_ERR "mga_vid: error mapping video memory\n");->src_base, vma->vm_end - vma->vm_start, vma->vm_page_prot));[/code:1:fbedd31f21]

Biztos ki lehet valahogy valtani ezt a fuggvenyt. Nincs valami otleted?

By(t)e
TBS::Antiemes

[quote:27e302ce33="Adi"]Nekem ez volt az egyik ok, hogy az otthoni munkaállomásomon hagytam a 2.6-os kernelt a fenébe, és maradtam a 2.4-esnél. :x[/quote:27e302ce33]

Nekem semmi gondom nem lenne a 2.4.x-kernelekkel, de valamely rejtélyes okból nem működik vele a hangkártyám kb. egy hete. Még árpilisban forgattam a kernelt, azóta ment rendesen, de ma csak 2.6-os kernellel akar szólni. :(
Az érdekes az, hogy csak csomagfrissítés volt a gépen semmi egyéb változás.

Bye, Fifi

[quote:bdcae439e5="Fifi"]
A http://www.linuxops.net/~pw/mga_vid/ oldalon van egy patch a 2.6-os kernelhez, de a leírás szerint nem működik SMP kernellel. Most forgatok egy SMP nélkülit, hátha így jó lesz.
[/quote:bdcae439e5]

És SMP-s kernellel valóban nem jó.

Kernelforgatás után így működik: van mga_vid, de nincs SMP. Jobb mint a csak kép vagy csak hang felállás.

Bye, Fifi