Ez mi? /etc/X11/dm/Sessions/drak3d.desktop

Fórumok

Csak magamnak. Ha valakit mégis érdekelne, lentebb ott a magyarázat.

Szerkesztettem a címet, mert ez alább már nem érdekes. De azért itt marad.Ez volt: "Glibc 2.15 +Nvidia 304.x vagy 310.x"

Tehát az a rész itt most történelem. Ha nagyon zavarni fog, majd törlöm.
Nos: var/log/Xorg.0.log


[   181.498] 
X.Org X Server 1.10.4
Release Date: 2011-08-19
[   181.498] X Protocol Version 11, Revision 0
[   181.498] Build Operating System: Linux_3.2.44-pclos1.bfs PCLinuxOS
[   181.498] Current Operating System: Linux localhost.localdomain 2.6.38.8-pclos3.pae #1 SMP Fri Jul 8 17:19:10 CDT 2011 i686
[   181.498] Kernel command line: BOOT_IMAGE=linux root=UUID=01f302f5-7e49-41e5-9258-955371f2a680 quiet vmalloc=256M acpi=on resume=UUID=47e48b29-efe0-431e-a186-79b44cfeb706 splash=silent vga=788
[   181.498] Build Date: 16 May 2013  04:04:04PM
[   181.498]  
[   181.498] Current version of pixman: 0.30.0
[   181.498] 	Before reporting problems, check http://pclinuxos.com
	to make sure that you have the latest version.
[   181.498] Markers: (--) probed, (**) from config file, (==) default setting,
	(++) from command line, (!!) notice, (II) informational,
	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[   181.499] (==) Log file: "/var/log/Xorg.0.log", Time: Mon Jun  3 01:46:29 2013
[   181.499] (==) Using config file: "/etc/X11/xorg.conf"
[   181.499] (==) Using config directory: "/etc/X11/xorg.conf.d"
[   181.500] (==) ServerLayout "layout1"
[   181.500] (**) |-->Screen "screen1" (0)
[   181.500] (**) |   |-->Monitor "monitor1"
[   181.500] (**) |   |-->Device "device1"
[   181.500] (**) Option "DontZap" "False"
[   181.500] (**) Option "AllowMouseOpenFail"
[   181.500] (==) Automatically adding devices
[   181.500] (==) Automatically enabling devices
[   181.500] (==) FontPath set to:
	catalogue:/etc/X11/fontpath.d
[   181.500] (==) ModulePath set to "/usr/lib/xorg/extra-modules,/usr/lib/xorg/modules"
[   181.500] (II) The server relies on udev to provide the list of input devices.
	If no devices become available, reconfigure udev or disable AutoAddDevices.
[   181.500] (II) Loader magic: 0x8227340
[   181.500] (II) Module ABI versions:
[   181.501] 	X.Org ANSI C Emulation: 0.4
[   181.501] 	X.Org Video Driver: 10.0
[   181.501] 	X.Org XInput driver : 12.2
[   181.501] 	X.Org Server Extension : 5.0
[   181.502] (--) PCI:*(0:1:0:0) 10de:00f2:10b0:0401 rev 162, Mem @ 0xf8000000/16777216, 0xe0000000/268435456, 0xf9000000/16777216, BIOS @ 0x????????/131072
[   181.502] (II) Open ACPI successful (/var/run/acpid.socket)
[   181.502] (II) "extmod" will be loaded by default.
[   181.502] (II) "dbe" will be loaded by default.
[   181.502] (II) "glx" will be loaded by default.
[   181.502] (II) "record" will be loaded by default.
[   181.502] (II) "dri" will be loaded by default.
[   181.503] (II) "dri2" will be loaded by default.
[   181.503] (II) LoadModule: "v4l"
[   181.504] (II) Loading /usr/lib/xorg/modules/drivers/v4l_drv.so
[   181.504] (II) Module v4l: vendor="X.Org Foundation"
[   181.504] 	compiled for 1.10.3, module version = 0.1.1
[   181.504] 	ABI class: X.Org Video Driver, version 10.0
[   181.504] (II) LoadModule: "extmod"
[   181.505] (II) Loading /usr/lib/xorg/modules/extensions/libextmod.so
[   181.505] (II) Module extmod: vendor="X.Org Foundation"
[   181.505] 	compiled for 1.10.4, module version = 1.0.0
[   181.505] 	Module class: X.Org Server Extension
[   181.505] 	ABI class: X.Org Server Extension, version 5.0
[   181.505] (II) Loading extension MIT-SCREEN-SAVER
[   181.505] (II) Loading extension XFree86-VidModeExtension
[   181.505] (II) Loading extension XFree86-DGA
[   181.505] (II) Loading extension DPMS
[   181.505] (II) Loading extension XVideo
[   181.505] (II) Loading extension XVideo-MotionCompensation
[   181.505] (II) Loading extension X-Resource
[   181.505] (II) LoadModule: "dbe"
[   181.506] (II) Loading /usr/lib/xorg/modules/extensions/libdbe.so
[   181.506] (II) Module dbe: vendor="X.Org Foundation"
[   181.506] 	compiled for 1.10.4, module version = 1.0.0
[   181.506] 	Module class: X.Org Server Extension
[   181.506] 	ABI class: X.Org Server Extension, version 5.0
[   181.506] (II) Loading extension DOUBLE-BUFFER
[   181.506] (II) LoadModule: "glx"
[   181.507] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[   181.507] (II) Module glx: vendor="X.Org Foundation"
[   181.507] 	compiled for 1.10.4, module version = 1.0.0
[   181.507] 	ABI class: X.Org Server Extension, version 5.0
[   181.507] (==) AIGLX enabled
[   181.507] (II) Loading extension GLX
[   181.507] (II) LoadModule: "record"
[   181.508] (II) Loading /usr/lib/xorg/modules/extensions/librecord.so
[   181.508] (II) Module record: vendor="X.Org Foundation"
[   181.508] 	compiled for 1.10.4, module version = 1.13.0
[   181.508] 	Module class: X.Org Server Extension
[   181.508] 	ABI class: X.Org Server Extension, version 5.0
[   181.508] (II) Loading extension RECORD
[   181.508] (II) LoadModule: "dri"
[   181.509] (II) Loading /usr/lib/xorg/modules/extensions/libdri.so
[   181.509] (II) Module dri: vendor="X.Org Foundation"
[   181.509] 	compiled for 1.10.4, module version = 1.0.0
[   181.509] 	ABI class: X.Org Server Extension, version 5.0
[   181.509] (II) Loading extension XFree86-DRI
[   181.509] (II) LoadModule: "dri2"
[   181.510] (II) Loading /usr/lib/xorg/modules/extensions/libdri2.so
[   181.510] (II) Module dri2: vendor="X.Org Foundation"
[   181.510] 	compiled for 1.10.4, module version = 1.2.0
[   181.510] 	ABI class: X.Org Server Extension, version 5.0
[   181.510] (II) Loading extension DRI2
[   181.510] (II) LoadModule: "nvidia"
[   181.513] (WW) Warning, couldn't open module nvidia
[   181.513] (II) UnloadModule: "nvidia"
[   181.513] (II) Unloading nvidia
[   181.513] (EE) Failed to load module "nvidia" (module does not exist, 0)
[   181.513] (II) v4l driver for Video4Linux
[   181.513] (++) using VT number 8

[   181.541] (WW) Falling back to old probe method for v4l
[   181.541] (EE) No devices detected.
[   181.541] 
Fatal server error:
[   181.541] no screens found
[   181.541] 
Please consult the The X.Org Foundation support 
	 at http://pclinuxos.com
 for help. 
[   181.541] Please also check the log file at "/var/log/Xorg.0.log" for additional information.
[   181.541] 

etc/X11/xorg.conf


# File generated by XFdrake (rev 262502)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
    Option "DontZap" "False" # disable <Ctrl><Alt><BS> (server abort)
    AllowMouseOpenFail # allows the server to start up even if the mouse does not work
    #DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
    Load "v4l" # Video for Linux
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Plug'n Play"
    ModelName "COMPAQ S710"
    HorizSync 30-70
    VertRefresh 50-160
    
    # TV fullscreen mode or DVD fullscreen output.
    # 768x576 @ 79 Hz, 50 kHz hsync
    ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630
    
    # 768x576 @ 100 Hz, 61.6 kHz hsync
    ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
    Identifier "device1"
    VendorName "NVIDIA Corporation"
    BoardName "NVIDIA GeForce 6100 to GeForce 7950"
    Driver "nouveau"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24
    
    Subsection "Display"
        Depth 8
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 15
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 16
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
    
    Subsection "Display"
        Depth 24
        Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    Screen "screen1"
EndSection

Az old ugyanez, kivéve a Driver "nouveau", ami ott Driver "nvidia".

A történet:
Tegnap észrevettem a PcLinuxOs repóban, hogy ott figyel az általam már nagyon várt glibc 2.15. No meg 304.x videó driver is van. Nosza, akkor még a többi elmaradt frissítést is rátolom. Kicsit elkúrta a tökéletesre csiszolt menümet (Xfce) de sebaj -gondoltam-, majd visszateszem. Láttam még egy Steam installert is, ez lett volna a következő. Még átfutott az agyamon, talán gyorsabb lesz végre a kedvenc 3D alkalmazásom, de ugye kérte a restartot. Legyen.

Restart. Nincs X. Javítsa-e? Persze. Nem tette. A fentebbi logban nem találtam meg mi a gond, gondolom ütközik a nouveauval, ami eleve nem volt fent, merthogy nem használtam sosem. Igaz csak átfutottam.
Elegem van ugyan ezekből az RPM-es szarokból, de az új gép vétele előtt nem akartam másik rendszert (Debiant) felpakolni. Ezt azért raktam ide, mert majd elcsámcsogok rajta később, és gyorsabb mint felhőből előbányászni. No meg más is röhöghet rajtam elmélkedhet rajta ha akar.

Azért van Mandriva topic alatt, mert nincs Pclos. Mageia sincs.
Ja igen, ez most egy live Mageia 3 KDE. Nem rossz, de nem találom a hot corner áthelyezést, és megőrjít a hülye task group, ezt sem találtam hogy szedhetném szét.

Folytatás:
Tehát, sikerült visszaraknom a kedvesen elkúrt Nvidia drivert
(kommentben írtam mi volt vele az official gáz), viszont most mindenképp elindul ez a drak3d cucc, ami kérdezi akarok-e compizt vagy sem. Mindegy akarok-e vagy nem, akkor is ezt kapom:
Drak3d conf please reboot if you changed the video driver or enabled/disabled Pulse audio. For all other settings log out and back again.

Hiába reboot, semmi sem történik. A login screennél sem tudok grafikus felületet választani, a last sessionre meg ez jön be.

Próbálkoztam már mindennel. Xdm nem akar indulni, gondolom a címben említett file lehet a ludas. Vagy nem. Nem tudom.
Ez a tartalma:


[Desktop Entry]
Encoding=UTF-8
Name=drak3d
Comment=drak3d
TryExec=/usr/sbin/drak3d
Exec=/etc/X11/xdm/Xsession drak3d
Icon=
Type=Application

Ha nem oldom meg pár napon belül, csinálok egy backupot valami felhőbe, aztán letörlöm az egészet. Már csak az Operás félrerakott oldalaimat sajnálom. Lehet azt még ki tudom szedni a home/opera alól.

(/°(oo)°\)

Hozzászólások

Az Xorg logjaban elso korben az EE-s sor(oka)t kell nezni:
[ 181.513] (EE) Failed to load module "nvidia" (module does not exist, 0)
le kene forditani a kernel modult

Meglehet. Pclosnak ugyan kevesebb köze van a manddrakedrivához, vagy a Mageiához mint Mintnek az ubuntuhoz. Sajnos, mert Mageia jobb alap lenne.
Közben eszembe jutott, hogy a PAE környékén volt már valami mókolás korábban, ott meg is állt picit töltéskor.
--
AGA@
Fork portal és az egyik logóm :)

Fantasztikus. Azt mondja kivették a régi kártyák támogatását. Fasza, mert ezt disztrót elvileg direkt régebbi gépekhez készítették. No meg NEM nyomtam volna rá a videódriver frissítésére ha ott 310 szerepel, mert tudom, az nem megy ezzel a régi cuccal. Ott biza 403 volt.
Pedig egyszer már megfogadtam anno az egyik Debianomon, hogy csak akkor frissítem az Nv drivert, ha az épp használt bugos vagy lyukas mint a 302 volt. Amúgy csak szívás van vele.
--
AGA@
Fork portal és az egyik logóm :)