Lenovo T470 és Ubuntu 18.04.4 hiba

Fórumok

Sziasztok!

Kijött az Ubuntu 18.04.4 5.3.x-es kernellel, de hiába frissítettem a HWE-vel, nem működik a Lenovo T470-es gépen. A frissítés simán felment, a gép elindul, csak nincs kép, sem grafikusan, sem szöveges konzolra váltva. Valamiért az input eszközök nem ugyanazt az eszközszámit kapják. Az 5.0.0-es kernellel nincs probléma.

A /var/log/Xorg.0.log-ban látszik eltérés, a bal oldali az 5.0.0-ás kernel, a jobb oldalon van az 5.3.0-28: https://imgur.com/a/CvoCEN4

Ha valakinek ilyen laptopja van, légyszi próbálja ki ezzel live-módban indítva: http://cdimage.ubuntu.com/lubuntu/releases/18.04.4/release/lubuntu-18.0… Nekem már ezzel sem működött, ugyanazt a hibát produkálja.

Köszi!

Ui.: a logok vége szövegesen, 5.0.0-ás kernel:

(**) TPPS/2 IBM TrackPoint: (accel) selected scheme none/0
(**) TPPS/2 IBM TrackPoint: (accel) acceleration factor: 2.000
(**) TPPS/2 IBM TrackPoint: (accel) acceleration threshold: 4
(II) event6  - TPPS/2 IBM TrackPoint: is tagged by udev as: Mouse Pointingstick
(II) event6  - TPPS/2 IBM TrackPoint: trackpoint device set to range 20
(II) event6  - TPPS/2 IBM TrackPoint: device is a pointer
(II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event7)
(**) ThinkPad Extra Buttons: Applying InputClass "libinput keyboard catchall"
(II) Using input driver 'libinput' for 'ThinkPad Extra Buttons'
(**) ThinkPad Extra Buttons: always reports core events
(**) Option "Device" "/dev/input/event7"
(**) Option "_source" "server/udev"
(II) event7  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
(II) event7  - ThinkPad Extra Buttons: device is a keyboard
(II) event7  - ThinkPad Extra Buttons: device removed
(**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input8/event7"
(II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 14)
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "hu"
(II) event7  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
(II) event7  - ThinkPad Extra Buttons: device is a keyboard
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) event4  - SynPS/2 Synaptics TouchPad: device removed

 

5.3.0-as kernel:

(II) event6  - TPPS/2 IBM TrackPoint: is tagged by udev as: Mouse Pointingstick
(II) event6  - TPPS/2 IBM TrackPoint: trackpoint device set to range 20
(II) event6  - TPPS/2 IBM TrackPoint: device is a pointer
(II) config/udev: Adding input device TPPS/2 IBM TrackPoint (/dev/input/mouse1)
(II) No input driver specified, ignoring this device.
(II) This device may have been added with another device file.
(II) config/udev: Adding input device ThinkPad Extra Buttons (/dev/input/event9)
(**) ThinkPad Extra Buttons: Applying InputClass "libinput keyboard catchall"
(II) Using input driver 'libinput' for 'ThinkPad Extra Buttons'
(**) ThinkPad Extra Buttons: always reports core events
(**) Option "Device" "/dev/input/event9"
(**) Option "_source" "server/udev"
(II) event9  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
(II) event9  - ThinkPad Extra Buttons: device is a keyboard
(II) event9  - ThinkPad Extra Buttons: device removed
(**) Option "config_info" "udev:/sys/devices/platform/thinkpad_acpi/input/input8/event9"
(II) XINPUT: Adding extended input device "ThinkPad Extra Buttons" (type: KEYBOARD, id 14)
(**) Option "xkb_model" "pc105"
(**) Option "xkb_layout" "hu"
(II) event9  - ThinkPad Extra Buttons: is tagged by udev as: Keyboard Switch
(II) event9  - ThinkPad Extra Buttons: device is a keyboard
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) modeset(0): EDID vendor "LGD", prod id 1133
(II) modeset(0): Printing DDC gathered Modelines:
(II) modeset(0): Modeline "1920x1080"x0.0  138.70  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (66.7 kHz eP)
(II) modeset(0): Modeline "1920x1080"x0.0  110.90  1920 1968 2000 2080  1080 1083 1088 1111 +hsync -vsync (53.3 kHz e)
(II) event2  - Power Button: device removed
(II) event7  - Video Bus: device removed
(II) event0  - Sleep Button: device removed
(II) event5  - Yubico Yubikey 4 OTP+U2F+CCID: device removed
(II) event8  - Integrated Camera: Integrated C: device removed
(II) event3  - AT Translated Set 2 keyboard: device removed
(II) event4  - SynPS/2 Synaptics TouchPad: device removed
(II) event6  - TPPS/2 IBM TrackPoint: device removed
(II) event9  - ThinkPad Extra Buttons: device removed
(II) AIGLX: Suspending AIGLX clients for VT switch
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) UnloadModule: "libinput"
(II) Server terminated successfully (0). Closing log file.

Hozzászólások

Szerkesztve: 2020. 02. 16., v - 00:28

Valami komolyabb hülyesége lehet. Gondoltam updatelem én is 18.04.4-re, alapból marad a régi kernelen, de 

sudo apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04

után frissíti.

Ezután nálam sem indul el. A syslogban ez a leggyanúsabb üzenet, mivel ez egy t430-as gép:
no firmware was defined for IVYBRIDGE
[drm:intel_wopcm_init [i915]] *ERROR* GuG FW (0Kib) is too big to fit in WOPCM.

viszont ez mas problema lehet, mert live usb eseten mukodik.

Szerk:
Nekem úgy tűnik az okozott bajt, hogy az /etc/modprobe.d/ alá tettem pár modul opciót a videodriverhez a korábbi verzióval és az okozhatott bajt az új driverrel. 

Most frissítettem a T470-esemet. Először megkapta a 18.04.4 -et, aztán kapta az apt-get install --install-recommends linux-generic-hwe-18.04 xserver-xorg-hwe-18.04 -t. És ugyan a wireguard dkms nyűglödött, de minden X-es hiba nélkül bebootolt, és működik. Most is arról írok.

A /var/log/Xorg.0.log  file-om  nekem 2018 -as volt, úgyhogy azt inkább nem hasonlítanám össze. Ellenben találtam egyet a $HOME/.local/share/xorg/Xorg.0.log -ban ami sokkal aktuálisabb. https://pastebin.com/bsNXPEVK

Valaki valamit még?

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

gondolom az elsődleges probléma az, hogy nincs kép. Szóval syslogban kéne visszakeresni az 5.3as kerneles bootot. Valami szaftos errornak kéne látszania. 

Számíthat az is esetleg, hogy uefi vagy legacy boot, friss bios e.

Esetleg másik pendrivera is feltenni official módon az újra letöltött isot, nem e a média sérült.

Szerkesztve: 2020. 02. 17., h - 17:43

Próbáld kézzel felrakni a tárolókból az 5.4.x-es vagy 5.5.x-es kernelt, lehet az megoldja, és amivel dolgod van, az egy 5.3.x specifikus bug, amit a későbbi kernelek javítottak. Akár még a linux-firmware-ből is megpróbálhasz frissebb verziót feltenni.

Nálam X220 + Archon az 5.5.x-es kernelekkel bootkor ezt a hibaüzit dobja:

DMAR: [Firmware Bug]: No firmware reserved region can cover this RMRR [0x00000000db800000-0x00000000df9fffff], contact BIOS vendor for fixes
DMAR: Parse DMAR table failure.

Látható tünetet nem okoz, minden működik, ahogy előtte, csak a szemem bántja, hogy minden bootkor kifossa ezt a möhöhőzést, dmesg logban is benne van.

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

Kipróbáltam a 20.04 napi snapshotot, ugyanaz. Hardvert nem piszkáltam a gépben és a 5.0.x-es kernellel működik. Az a gyanúm, hogy valamit az UEFI kever be, pedid SecureBoot kikapcsolva.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

T470p gépem van és mükszik rendesen.

Welcome to Ubuntu 18.04.4 LTS (GNU/Linux 5.3.0-28-generic x86_64)

Mivel ez azért annyira nem régi hardver, ezért a HWE (újabb kernel, x.org, driverek) hozhatnak új funkciókat vagy teljesítménynövekedést. 2-3 éven belül nem tervezek másik rendszerre váltani, így annyira nem marad elmaradott a rendszer.

Hardverhibára azért nem gondolnék, mert az 5.0-ás kernellel sokszor 15-20 napos uptime-ok vannak. Viszont az is fura, hogy nektek nincs hiba, míg nekem a letöltött live rendszer sem működik. Vajon a szöveges terminált hogyan tudnám életre kelteni? 5.0.x alatt az is működik, 5.3.x alatt az sem. De maga a gép nem fagy le, szabályosan le tudom állítani (Unity alatt: egérkurzor a jobb felső sarokba, kattintás, felfele nyíl, két enter).

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Milyen videovezérlőd van? Felteszem ebből a laposból is létezik többféle, és nekem gyanús, hogy video vezérlő okozza a bajt, és ezért nem mindenkinél (mondjuk csak intelen jelentkezik pl.).

Amúgy szerintem valami energiakezelési okosság lesz ez, ACPI tiltással próbáld meg talán elindítani, illetve nézz utána milyen kernel paraméterek vannak a témában még.

Szia!

00:00.0 Host bridge: Intel Corporation Xeon E3-1200 v6/7th Gen Core Processor Host Bridge/DRAM Registers (rev 02)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 620 (rev 02)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:16.3 Serial controller: Intel Corporation Device 9d3d (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #1 (rev f1)
00:1c.6 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #7 (rev f1)
00:1d.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port #9 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Intel(R) 100 Series Chipset Family LPC Controller/eSPI Controller - 9D4E (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection (4) I219-LM (rev 21)
04:00.0 Network controller: Intel Corporation Wireless 8265 / 8275 (rev 78)

Az ACPI jó ötlet, kipróbálom.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Köszi, a nomodeset paraméterrel (vagy rescue módot választva a grubban) elindul, igaz így meg normális 3D nincs. Viszont ad egy irányt, hogy merre érdemes kutakodni.

Ui.: Újra feltettem a legfrissebb BIOS frissítést, frissítettem a videókártya driverét, de semmi változás.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Viszont még mindig nem írtad, hogy milyen video van a gépben. Ebből létezik egy pár változat (https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_T470#PCI_and_USB_d… itt pl nincs is nvidiás említve), és ha nvidia+intel párosod van, akkor másfele kell kutakodni valszeg, mint ha csak sima inteles.

Valóban, ez elkerülte a figyelmem.

A fentebb linkelt archwikis cikkben van egy ilyen nem túl biztató mondat is: "As noted in Intel graphics, the xf86-video-intel driver seems to cause more issue than the builtin modesetting Xorg driver. " Mondjuk ezzel folytatódik: "Works fine without the intel driver (on a Skylake configuration). "

Mintha a problémád is ilyesmi lenne, nézz rá, hátha a megoldás nálad is az ott leírt.

Köszi! Kipróbáltam, de sajnos nem segített, nyomozok tovább. :(

Ui.: Kipróbáltam a Fedora 31 LXQt-t lve módban és ugyanaz. Megnyugtatna kissé, ha másnál is jelentkezne a hiba, elég frusztráló.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

No sorban, ami feltűnt, lehet nem minden:

- wow, induláskor már throttlingol a proci.. szép. Működik a ventilátora?

- talán fstab-ban van valami lubuntus, már nem létező bejegyzés 18.04.3-as rendszerre.
- a kernel paraméterezésében alapból benne van a vt.handoff=1 vagy te adtad hozzá? És az ro-t? Van valami plusz mágia? Titkosított lemez vagy más?
- EXT4-fs (sda2): re-mounted. Opts: errors=remount-ro, csak olvashatóban jött fel valamelyik fájlrendszer. 

- gpu-manager[1094]: Error: can't open /lib/modules/5.3.0-40-generic/updates/dkms  - van valami saját telepítésű driver, amit minden kernelhez újrafordítana?

Ezen kívül magyar nyelvű üzenetek is vannak, ami nem illik szerintem bele az egyébként angolnak tűnő környezetbe:
- colord[1408]: failed to get session [pid 1531]: Nincs elĂŠrhető adat
- org.freedesktop.Notifications[1764]: Unable to init server: Nem sikerĂźlt kapcsolĂłdni: Kapcsolat elutasĂ­tva

 

Egyébként mit takar az, hogy nincs se grafikus se konzolos felület? Sötét a képernyő?
Próbáltad a fényerőt állítani a billentyűzettel? Nem lehet, hogy a kijelzőt kapcsolja le valamiért? Fullhd tényleg a panel? Nem volt szervizben vagy használtan lett-e véve, esetleg nem gyári képernyővel?
Külső monitorral próbáltad már?

 

Ha esetleg waylanddel próbál feljönni, 

/etc/gdm3/custom.conf 
fájlban kivenni a kommentet a WaylandEnable=false elől.

 

Meg, ha volt is aktivált live patch, úgy tűnik már nem él  a gépedhez. Nem vágom az hogy műküdik, de hasonló hibát ír. Bár lehet csak a hálózatod nem áll fel.
https://bugs.launchpad.net/canonical-livepatch-client/+bug/1833304

 

A telepített rendszer lelakottsága egy dolog. De live usb-ről azért csak fel kéne jönnie. De mintha amúgy futna, csak lehet te nem látod valamiért. A logban ír olyat, hogy feljött a grafikus felület. Ezért is kérdeztem rá, hogy nincs-e esetleg valami trükk az lcd panel kapcsán.

a fényerő körül szétnézésre +1

KERNEL COMMAND LINE
       systemd-backlight understands the following kernel command line parameter:

       systemd.restore_state=
           Takes a boolean argument. Defaults to "1". If "0", does not restore the backlight settings on boot. However, settings will still be stored on shutdown.

 

Szia!

Néha indításkor megjelenik a LightDM bejelentkező ablak, esetleg be is tudok lépni, de utána elsötétül a kép és ennyi. A gép működik, szabályosan le tudom állítani, de se szöveges konzol, se grafikus kép, semmi. Az esetek kb. felében már rögtön az elsötétült kép fogad. Próbáltam a fényerőt növelni, de nem használt.

A fájlrendszer hibát szerintem egy szabálytalan leállítás okozhatta (bár a sima fsck nem is vette észre, az „fsck -f” dolgozott vele), az éjjel kétszer végigment a „badblocks -ns” és nem talált semmit. A „dkms” pedig az 5.0-ás kernel alatt is ott van, pedig azzal működik jól. Plusz ugye ott van az, hogy maga a live rendszer is elhal ugyanígy USB-ről indítva.

Viszont az 5.0-ás kernel syslogjában (és csak ott) van egy gyanús sor:

*ERROR* PSR Link CRC error, disabling PSR

Ui.: A nyomok errefelé vezetnek: „S0ix/S3 suspend stress”

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Szóval akkor valóban a kijelző háttér világítását kapcsolja le. 

https://unix.stackexchange.com/questions/137854/how-do-i-turn-off-the-backlight-but-leave-the-lcd-on

 

Ahogy már írtam, külső monitorral / tévével meg tudsz róla bizonyosodni, hogy rendesen fut a rendszer, csak a notebook kijelző sötét.

Be is ssh-zhatsz, akár telefonról is rá, hogy kipróbálj pár dolgot.

Régebbi gépeknél ez működik

cat /sys/class/backlight/acpi_video0/brightness
echo "7" | sudo tee /sys/class/backlight/acpi_video0/brightness

Az újabb eDP kijelzőknél lehet ez jobban működik
ez tán kikapcsolja a háttérvilágítást
echo 4 | sudo tee /sys/class/backlight/intel_backlight/bl_power
ez meg be
echo 0 | sudo tee /sys/class/backlight/intel_backlight/bl_power

 

Kipróbálhatod azt is, amit fsanyee írt, hogy ne állítsa vissza a háttérvilágítás korábbi állapotát.

systemctl status systemd-backlight@backlight:intel-backlight.service
systemctl status systemd-backlight@backlight:acpi_video0.service

megmutatja, hogy melyik mód aktív. Meg gurub konfigban lehet módosítani induláskor dolgokat
https://bbs.archlinux.org/viewtopic.php?id=222399

 

 

 

Szia!

Sajnos egyik sem segített, viszont találtam egy átmeneti workaroundot. Ha elindítom és nincs kép, akkor várok pár percet, amíg teljesen lekapcsolja a kijelző háttérvilágítását (az addigi szürke helyett fekete lesz). Ekkora ha megmozdítom az egeret, akkor visszajön a kép és be tudok jelentkezni. Utána megint inaktív lesz a kijelző, de ha megvárom azt a pár percet, amíg teljesen kikapcsolja, akkor utána használható. Sőt, ezután már elaltathatom a gépet, lesz kép az ébresztés után.

Remélem azért sikerül valami normális megoldást találni, mert oké, hogy 15-20 naponta indítom újra a gépet, de ez így elég macerás. Viszont addig is működik.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

bár nekem T460-on a variáns kubuntu 18.04.4 LTS, UEFI-módban telepítve [ BIOS: R06ET47W (1.21 ) ] , felraktam a kernel-hwe és az xorg-hwe frissítéseket és minden stabilan működik idestova órák óta aktív használat mellett.

Soha nem is hallottam még hasonló problémáról sem ThinkPad T széria esetén. Nálad vagy valami firmware hiba van, vagy hardver hiba, vagy valami hülye beállítás okozza.

Első körben bios-t frissítenék, ezt pl Ubuntu alól is meg lehet tenni.

Ha nem segít, reset-eld az UEFI BIOS beállításait, és úgy tégy próbát.

Esetleg az Intel Management Engine beállításait is nézd meg, ott lehet még gond.

Ha mindez megvolt, és még mindig hibás a működés, akkor valószínűleg hardver hiba van. A kernelek biztosan nem rosszak, mert rajtad kívül mindenkinek jó :)

Igen, elsőre én is hardverhibára gyanakodnék, de:

  • A rendszer az előző (5.0.0-37-generic) kernellel (érzékelhető) hiba nélkül fut.
  • Nem volt hardverváltozás és extrém igénybevétel (max. annyi, hogy SSD-ről kb. 15-20 napig működik, éjszakánként elaltatva), bár ez nem garancia semmire
  • Az 5.3.0-40-generic kernellel is elindul, ha megkapja a "nomodeset" paramétert, csak akkor nincs 3D

Kösz a tippeket, kipróbálom őket.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

A T530 nem UEFI BIOS-sal megy, ezért nem találsz csak ISO-t. UEFI-vel úgy frissül, mint bármelyik másik másik szoftver, csak utána újraindítást kér és akkor végzi el a telepítést.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Szerkesztve: 2020. 03. 01., v - 00:03

There are issues with using the i915 kernel module in 5.3.x and 5.4.x kernels. Avoid using those.

https://linuxreviews.org/Intel_graphics#Kernel_Driver
https://linuxreviews.org/Linux_Kernel_5.5_Will_Not_Fix_The_Frequent_Int…

Akkor maradok egyelőre az 5.0-nál.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Kipróbáltam pendrive-ról indítva a Lubuntu 20.04-et és az jónak tűnik. Szóval talán a következő HWE-vel nem lesz gond.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Most már biztos, hogy valami szoftveres gond volt. A 18.04.5 megjelenésekor fel is tettem a legfrissebb HWE-t (5.4.0-42 kernel + x.org), ami azóta is hiba nélkül működik.

„Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben.”
rand() a lelke mindennek! :)
Szerinted…

Fura egy történet az egész. A T470 nem annyira új gép, se az Intel HD620 nem olyan új GPU, hogy ne feleljen meg neki az 5.3-as kernel. Nálam X220-on, Intel HD3000 GPU val egyik kernellel sem volt gond, pedig i915 modeset drivert haszálok. Se X.org, se Wayland alatt nem volt vele gondom, igaz nem Ubuntut, hanem Archot használok, Testing tárolóval, mindig a legújabb (nem RC) kernellel, jelenleg 5.8.3-as verziót.

Amit érdemes betartani: nem kell feltenni X.org-hoz a xorg-video-intel csomagot, ami az inteles X.org driver. Anélkül is normálisan fut a X.org server, épp úgy lesz 3D gyorsítás is, és fura bugok kialakulását lehet vele megelőzni.

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧