KDE 4.9 Beta1

 ( trey | 2012. június 5., kedd - 4:14 )

A KDE fejlesztők bejelentették a Workspaces, Applications és Development Platform 4.9-es kiadásának első bétáját. Azzal, hogy életbe lépett az API, függőségi- és featurefagyasztás, a fejlesztők kiadási ciklus hátralevő részében a hibák javítására és a régi-új funkciók csiszolására koncentrálnak. A új fejlesztésekkel kapcsolatos információk megtalálhatók a 4.9_Feature_Plan dokumentációban. A bejelentés elolvasható itt.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

neked is jó reggelt :D

Nem vagytok normálisok.

Ezt nem értem, még este van, nem? :)

"DONE Import pim data ImportWizard allows to import settings/mails/filters/calendar/addressbook from thunderbird/evolution/etc. when exists. "

Na végre.

még senki?

[[dupla]]

Ez most már a KDE 4?

Nem bazmeg, ez egy zsíroskenyér.

----------------------------------------------------------
"One should strive to achieve; not sit in bitter regret."
www.xonotic.org

+1
Tökéletes válasz "Ez már a..." kérdésekre! :D

oké. a gnome3 csicsa nélkül meg 1 szelet abonett, aminek megmutattak egy margarinosdobozt messziről :d

+1 tökéletes válasz ;-)

Már lassan 5.

Azért én attól tartok valamelyest.
Ui. volt 2011 nyár/ősz környékén egy Linux konferencia a TIK-ben és ott - ha jól emlékszem - Kiszel Kristóf "adta elő" a KDE várható fejlesztési irányait.
A lényeg: lesz 5-ös széria, de már alapvetően közösségi alapokon (talán a Nokia teljesen kiszáll a Qt további "pátyolgatásából"?), valamint - erre nem vennék mérget - "...már bináris szinten sem fog egyezni a most meglévő 4.7, 4.8, 4.9 vonallal?!".
Ez utóbbit - lévén nem vagyok programozó - tessék némi fenntartással kezelni. Tehát az átállás nem lesz egy 1x1. A tévedés jogát fenntartom. :-)
Kíváncsi lévén - aki jobban tudja - javítson ki.

> a Nokia teljesen kiszáll a Qt további "pátyolgatásából"?

Levágják az aranytojást tojó tyúkot? Annyira érdekes számomra, hogy a most elérhető legnormálisabb GUI-val a Nokia nem tudott mit kezdeni.

Van dokumentáció, van forráskód, logikus, érthető,...

Mindez a többi UI-ról egyáltalán nem mondható el.

Forrás a jereváni rádió? :) A Nokia nem szállt ki a Qt fejlesztéséből, de létrehozta a Qt Projectet, amelyet a közösség irányít, de nem úgy hogy mindenki ész nélkül kommitol, öt szint van, lásd The Qt Governance Model.

A bináris kompatibilitás tényleg nem marad meg, mind a Qt, mind a KDE felbontja kisebb modulokra a forráskódot, de a forrásszintű kompatibilitást igyekeznek megőrizni. Aaron Seigo mondta, hogy a cél az, hogy elég legyen csak újrafordítani az alkalmazásokat, nem lesz szükség portolásra, de ha mégis, igyekeznek automatizálni.

A verziószámokból gy látom van némi kavarodás a hozzászólásban, Qt 4-ből a 4.8.x az utolsó, KDE-ből pedig most jelent meg a 4.9.0 első bétája, és a blogokat olvasva biztosra veszem, hogy még 4.10 is lesz. Egyelőre nem nagyon látom mozgást a KDE 5 körül, a legutóbbi dolog ami feltűnt, hogy a KUrl osztály helyett már a QUrl osztályt használják (Commit Digest legvége). De ezt is megmondták, hogy amiből lehet, a Qt által szállítottat használják, és visszaküldik azokat a módosításokat (feltéve, hogy elfogadják), amik a saját osztályokban vannak, így azoktól meg lehet szabadulni.

"A Nokia nem szállt ki a Qt fejlesztéséből"

Elobb-utobb kiszall, nincs jovoje, mar az MS is a HTML5+JS fele veszi az iranyt...

----------------------
"ONE OF THESE DAYS I'M GOING TO CUT YOU INTO LITTLE PIECES!!!$E$%#$#%^*^"

Az MS kényszer pályán van, mivel az Android és az iOS az ellenfele. Fejlesztők pedig sokan megoldják alkalmazásaikat html5+js-sel, így a portolás olcsó lesz, ezért talán még meg is ejtik.

En is ki akartam pont ugyanezekben javitani, csak feltem, hogy valamit rosszul irok, es akkor megvadoltal volna, hogy nem is figyeltem rendesen en sem ;)

De akkor jol vettem ki, hogy azota is nagyjabol az a szituacio all fent, amit akkoriban lefestettel :) (ja igen, masreszt nem tudtam, hogy mennyire out-of-date az infom ezugyben, de tudtam hogy ugyis megerkezel egy ilyenre, okosabbnak lattam megvarni) :)

Egy kis trollkodásra kiigazításra mindig ráérek.

Nagyon unalmas. Borzalmas, hogy némely embereknek mennyire nincs érzékük a poénokhoz és azok időzítéséhez. Ezzel természetesen nincs baj, csak akkor nem kellene erőltetni.

Honnan veszed, hogy poén volt?
Inkább egy gyors szociológiai kísérlet, ami sajnos a várt eredménnyel zárult. Ez van.

Tehát mostantól a "csak azért is ezredszerre ellövöm ugyan azt a szar poént, amin már senki se nevet, csak hogy megtudjam, tényleg fárasztja-e az embereket" (=trollkodás) szociológiai kísérlet.
Eddig azt hittem, ez egy főleg Unix és ahhoz köthető hírekkel és témákkal foglalkozó IT portál, de ezek szerint ez is csak egy nagy, szociológiai kísérlet álcája.

http://cdn.memegenerator.net/instances/400x/21573663.jpg

----------------------------------------------------------
"One should strive to achieve; not sit in bitter regret."
www.xonotic.org

Amit a KDE a 4.0-nál előadott, az tökéletesen beleillett volna a szanalmas.hu-ra. Megértem, hogy páran nem bírták azóta sem feldolgozni. Gondolom a GNOME már bölcsebb lesz és nem fogja kijelenteni a 3.0-ra, hogy ez azért még nem a 3-as.

- évekig semmi sem történt, csak KDE 4-re portoltak
- túl voltak a kismilliomodik alfán, bétán, pre-n, rc-n, semmi előrelépés...
- kiadták a 4.0-t
- letöltötte a nép és a hideg rázta a végeredménytől, annyira béna volt
- utána megszólaltak a főokosok, hogy ez még azért nem az igazi 4-es, de majd...
(és ez volt az a pillanat, amikor a dolgok tragikomikussá fajultak, ha egy szimpla "elk..tuk"-kal intézték volna el, tán kisebb lett volna a presztizsveszteség).

:)

+1

Lehet. Azóta viszont eltelt négy és fél év, nem kevés változással és javulással. A "poén" viszont elsőre is szar volt, azóta pedig csak még rosszabb lett.

----------------------------------------------------------
"One should strive to achieve; not sit in bitter regret."
www.xonotic.org

Itt a hupon nehezen felejtenek az emberek. Egyszer leírtam valami ökörséget és 1 év telt el, hogy ne kapjam nap mint nap újra az idióta primitív hozzászólásokat.

Azt gondolná az ember, hogy az itt jelenlévők 99%-a azt sem tudja, hogy a világon vagyok.

Nos ez nem így van. Nálam 1 év kellett, hogy a dolog megszűnjön. Nos képzeld el, hogy a KDE esetében ez meddig fog tartani...

:)

Sajnos sokkal kevesebb javulassal, mint kellett volna. Vagy legalbbis ahhoz kellett volna, hogy ez feledesbe meruljon.
A KDE4 meg mindig komoly kihivasokkal kuzd minoseg es funkcionalitas teren. Es minden verzional feleled a varakozas, hgoy talan ez mar jobb lesz. Ezert veszti egy ilyen "poen" eleg nehezen az aktualitasat.

Kérlek, említs pár példát ezekre a „komoly kihívásokra minőség és funkcionalitás terén”!

--
The Elder Scrolls V: Skyrim

- KDE PIM: mondjuk eppen csak az IMAP nem megy benne normalisan (a levelek nem erkeznek meg) iszonyat mennyisegu egyeb bug mellett. Ez nem tudom fontos funkcio-e. Mar nem melekszem....
- KMenuben nehol megjelennek nehol nem jelennek meg az elemek. Ez is ilyen mellekes szarsag. Senkinek nem tunik fel valoszinuleg.
Es ezek KDE 4.8.3-nal.Van meg szamos dolog, de nem gyujtom oket ezek eppen csak azok, amivel tegnap este is konfrontalodnom kellett.

De kicsit unom mar ezeket a provokativ visszakerdeseket. Ez nem tudom hanyadik alkalom, amikor konkret bugok utan kerdez valaki, majd amikor leirom, akkor utan hosszu csond van. Nem fogom fel, hogy 9 ev KDE hasznalat utan (amibol nagyjabol az utobbi kettot kinlodom vegig a KDE4-essel) miert en vagyok a hulye.
Ja es koszonom lemondok a "nalam mukodik" tipusu valaszokrol. Kb. nem erdekel, hogy kinel mi mukodik. Nem vagyok egyedul a negativ tapasztalataimmal, nem rajtam mulik, hogy nem mukodik, masok is talakoznak azokkal a bugokkal, amikkel en.

Sajnos ez az akonadi, meg KMail2 elég szar eddig, szerintem is. Kevés a developer sajnos, és kissé túlkomplikált is lett. De hátha jó lesz egyszer.

Nekem minden szép és jó, mert ugye a kmail-t a legsúlyosabb lázálmomban sem használnám. Bevallom, én sem értettem, hogy mi a problémád először a KDE-vel. Néha a GUI dob egy hátast és a login képernyő bejelentkezik (főleg wine után), de engem ez annyira nem zavar.

Meg vagyok vele elégedve, amennyi nekem kell, annyit tud. A Network Managerrel (WIFI-nél) sincs bajom, mióta mást használok helyette. :)

Egyszer évente felrakok egy új Linuxot, a szemetet kisöpröm belőle, utána elégedetten konstatálom, hogy minden szép és jó és stabilan működik. Te nem ez a fajta ember vagy, nem siklasz át az olyan apróságokon, minthogy a kmail/konqueror használhatatlan és fagy.

:)

NetworkManager alóban sok gondot tud okozni, igaz, amióta letettem arról, hogy a laptopomon linuxozzak, annyira nem is fáj (mondjuk az is igaz, hogy azóta be se kapcsoltam :D ~ 6-7 hónapja).
Konquerort meg konkrétan ki a franc használ? Értem én, hogy saját böngésző (meg irodai csomag, Koffice wtf), de ha ott a Firefox, meg a Chrome, meg az Opera...

----------------------------------------------------------
"One should strive to achieve; not sit in bitter regret."
www.xonotic.org

Szerencsére sem az akonadi, sem a kmail nem elválaszthatatlan részei a KDE-nek. Az akonadi server nálam alapból le van tiltva, egyetlen program igényli(sajnos), a KJots. Levelezőnek mióta létezik Thunderbirdet használok, naptárnak Google Calendar.
Mondjuk ez utóbbi fáj kicsit, hogy nincs valahogy integrálva a KDE-be. Gnome alatt ugye ment az evolution data server és ha egyébként az evolution-t nem is használtam, a tálcán akkor is megjelentek a napi események a google calendarból. KDE alatt meg van egy buta óra egy buta naptárral. Bezzeg értelmetlen hülye funkciókat sikerül belegyömöszölni, a kedvencem pl, hogy az órára jobbklikkelve vagy 50 formátumban a vágólapra másolhatom a mai dátumot.

Konqueror: nekem nincs is telepítve, minek? Nem is értem miért része a KDE4-nek. File kezelőnek ott a Dolphin (ami szerintem nagyon jó), böngészőnek meg úgyis mindenki vagy firefoxot vagy chrome-ot használ. De ha egy egyszerű qt-s böngésző kell, akkor ott a rekonq (a fejlesztők helyében inkább ezt tenném be default KDE böngészőnek, ha már muszáj valamit).

A Network managerrel semmi bajom. Wifi, lan, mobilnet - minden megy pöccre. Meg úgy általában a KDE többi részével sincs gondom, működik.

A Network Managerrel az a baj, hogy a WIFI eszközök közül sokat nem támogat (az én kártyámat sem).

Azt hittem, hogy Linusék sikeresen eltolták megint a kernelt, de miután a Wicd felcsatlakozott a hálózathoz, nem lehetett a kernel hibás.

Nem ismerem a NM működését, de azt hittem, hogy ha a kártya támogatott kernel szinten (tehát van hozzá driver), akkor már mindegy, hogy network managerrel vagy más programmal "kezelem". Mondjuk évek óta egy laptopot használok, szóval nincs tapasztalatom különböző wlan kártyákkal. Azt tudom, hogy ezt felismerte, működik, sok helyen használtam már, kapcsolódik mindenhez, megy rajta a vpn stb, teljesen problémamentes.

Egy bosszantó bugja van/volt a KDE-s network managernek, amivel találkoztam (nem tudom javították-e már), hogy a rejtett wifi hálózatokhoz nem tudott csatlakozni, hiába írtam be GUI-n az adatokat. Előbb valamit parancssorban kellett varázsolni (talán iwlist scan), hogy lássa az adott rejtett hálózatot.

Úgy tűnik, hogy ez utóbbi javítva lett 2009 májusában :) .

--
The Elder Scrolls V: Skyrim

Az akonadi pont ezeket a feladatokat látja el, a kde órába is beépül a napi agendád. Más kérdés, hogy még valóban nem túl megbízható/használható (pl mikor utoljára néztem, csak a fő google calendart hozta be)

Az a baj, hogy ezer sebből vérzik. Eleve valami külön varázslattal lehet csak egy google calendar source hozzáadni az akonadihoz (legalábbis mikor utoljára próbáltam így volt). Aztán kb semmit nem lehetett vele kezdeni azon kívül, hogy a korganizerbe (amit nem használok) behúzta a fő naptár eseményeit. Másik naptárat nem is lehet(ett), és a tálca naptárjában semmilyen formáéban nem jelentek meg az események.

Gnome2 alatt ez évekkel ezelőtt is úgy ment, mint a karikacsapás, két kattintással akárhány naptárat hozzá lehetett adni, azokba eseményeket felvinni/törölni, a tálca naptárjában megjelentek a napi események a egyes naptárakhoz hozzárendelt színekkel.

Ennek kb úgy kéne működni, hogy tálcán jobbklikk a naptárra, forrás hozzáadása -> google account, kész. Aztán jelenjenek meg a bejegyzéseim. Álmodik a nyomor.

Persze egyet értek, de valahol el kell kezdeni.

Én a Dolphinnal sem vagyok teljesen megelégedve. Ha ki van jelölve egy fájlod, és egy másikat akarsz kijelölni, egy kattintással nem lehet megcsinálni. Ez pedig működött Konqueror 3-ban. Először meg kell szüntetned a kijelölést. Ha egy fájlt egy könyvtárból átmásolok, az új helyen kijelölve marad.
Ilyen módon jó párszor letöröltem olyasmit, amit nem akartam :(.

Én a Konquerort használtam képnézegetésre és pdf nézegetésre is. Visszasírom ezt a funkcionalitást.
Az Okular nem jó, időnként nem mutatja az oldal alját (azt hittem, hogy az általam előállított pdf nem volt jó, mire kiderült, hogy az Okular nem jó), ezért kénytelen vagyok Adobe Readert is tartani.

Akkor nem csak én szenvedtem vele... FoxitReader viszont sokkal gyorsabb, mint az adobe.

Az első valóban fontosnak néz ki, a másodikra az Alt+F2 szerintem elég jó alternatíva.

Amúgy. Miért lenne provokatív a visszakérdezés? Amit írtál, az annyi volt, hogy a KDE komoly hibákkal küszködik.
Ne haragudj, hogy nem tartom fejben, mióta használod a rendszert, mennyien kérdeztek téged erről és mik voltak rá a válaszaid. De amit írtál, semmi konkrétumot nem tartalmazott, erre pedig rákérdeztem.

Mondjuk úgy, hogy néha én is unom, hogy egy, a fentihez hasonló semmilyen válaszban csak a hangulatot rontják.

--
The Elder Scrolls V: Skyrim

Bocs. A problema az, hogy barmi negativat mond az ember a KDE4-rol (nem rossz indulatbol es hangulatkeltesbol, hanem egyszeru csalodottsagbol, hogy a kedvenc programjai nem mukodnek normalisan) az valahogy megkordejelezodik. Rogton valaki el akarja vitatni a tapsztalatodat vagy a velemenyed megalapozottsagat.

En orulnek a legjobban ha a KDE vegra hozna azt, amit korabban hozott.

A KDE teljes mértékben azt hozza, amit idáig is. A te személyes tapasztalatod talán más lehet, de hidd el, hogy a dolgok sosem voltak túl rózsásak.

Rakd fel a KDE 3-at, magad is meglátod majd, hogy a KDE 4 sokkal jobb.

Stephen Kulow lazára veszi a dolgokat. A wine/qt projektek például mások, ott tesztelnek is rendesen, ami a minőségen is látszik.

A KDE-nél nem probléma, ha a lib egyik függvénye azonnal fagy, simán lesz belőle release, a nép úgyis panaszkodik, ha gáz van.

Teljesen elhiszem neked, tudom, hogy melyebben benne vagy/voltal a Krusader fejleszteseben. Egyszer en is beleneztem a Kate forrasaba es elszornyulkodtem. De alapvetoen a KDE3-as sorozat kiforrotta valt egy ido utan. Lehet, hogy csak az en felhasznalasomban, de vegso soron (mindegy, hogy milyen belsovel) egy stabil es jol hasznalahato desktopom volt. Most meg nincs. Nem tudom, hogy kene hasznaljam, hogy jo legyen. De valahogy semelyik masik DE-vel nem tudtam igazi baratsagot kotni, ezert meg mindig visszakerult a KDE4 es csak varom a jobb jovot. A KDE3-at meg mar csak osi rendszerre tudnek telepiteni, mert mar semelyik disztroban nincs benne. A Trinity nem eri el nepszerusegben azt, hogy lehessen belole valami. LXDE-t hasznaltam egy ideig, de akarhogyis valahogy hianyoznak bizonyos szolgaltatasok.

De vegyuk csak a KDE PIM-et. Valamikor egyszer beallitottam magamnak meg KDE3-as idokben. Rengeteg POP3, nehany IMAP, es egy local fiok. Szuper. Jol mukodott. Be lehetett rajta finoman allitani mindent. Nem kellett minden fiokhoz bazi struktura, tudta intelligensen pakolni a leveleket. Majd a KDE4-tol kezdve keresztet vethetem az egeszre. Kiprobaltam egy nagy csomo levelezot, de egyik sem jott be. A legnagyobb problema a lokalisan tarolt levelek importalasa volt. Egyszeruen mindegyik levelezo mas strukturat akar kialakitani, meg veletelnul sem mukodik az egyik maildir strukturaja a masikban. A Thunderbird volt az egyetlen, amivel odaig meg tudtam baratkozni, hogy az IMAP fiokjaimat azzal kezelem.

Egyszer en is beleneztem a Kate forrasaba es elszornyulkodtem.

Miért?

4-5-szoros orklesek, kesze kusza kod, sw designnak, atgondoltsagnak nyoma sem volt. Probaltam egy line mode copy/paste featurerel hozzajarulni, mert nem akartak maguktol implementalni, de remenytelen volt. Kerdeztem, hogy van-e vmi UML design, vagy szoveges doksi. Hat az nincs, ok csak kodolnak. Aztan megprobaltam nehany alap elkepzelest lekodolni, elkuldtem, de nem valszoltak, szoval annyiban maradt a dolog. Ez talan 2004 korul (KDE3) lehetett, szoval nem tegnap volt.

Szoktál hibákat reportolni?

Mert javítják őket, bár sajnos újak is keletkeznek. :)

Ahova erdemes oda igen :-)

Ja es nem volt akonadi, strigi, meg nepomuk, es nem volt a rendszer tolakodo.
Es sajnos elegge bosszanto, hogy a kmenu beteg a panel es az appletek betegek, tehat egyszeruen az alapveto dolgok sincsenek teljesen rendben.

Na hát már csak ezért sem volt haszontalan, jó a kép! :D

A Beta 1 örömére belapátoltam egy rakás fordítást SVN-be.

Fentebb egy hozzászólásban olvastam, hogy ez egy zsíros kenyér.
A kérdésem ezek után az, hogy le lehet-e valahogy fordítani a zsíros kenyeret oly módon, hogy minimális méretű legyen, azaz csupán egy KDEnlive
kedvéért akarom a rendszeremen látni a zsíros kenyeret? (rendszerem: slackware, salix, fluxbox, kernel: 3.4.1)

---
--- A gond akkor van, ha látszólag minden működik. ---
---

Itt van Slackware 13.37-hez csomag és függőségek. Forrásból még nem fordítottam, nem tudom mi minden kell neki.

Kösz szépen!
:)

Megnéztem, felpakolgattam, aztán elkezdtem pakolgatni hozzá a KDE-s cuccokat, melyeket hiányolt.
Darabonként.
Ezeket:

root[deb]# ls *.tgz
libattica0_0.1.4-1_i386.tgz liblzma2_5.0.0-2_i386.tgz
libkdecore5_4.4.5-2+squeeze3_i386.tgz libnepomuk4_4.4.5-2+squeeze3_i386.tgz
libkdeui5_4.4.5-2+squeeze3_i386.tgz libphonon4_4.6.0really4.4.2-1_i386.tgz
libkio5_4.4.5-2+squeeze3_i386.tgz libpulse-mainloop-glib0_0.9.21-3+squeeze1_i386.tgz
libknewstuff3-4_4.4.5-2+squeeze3_i386.tgz libqjson0_0.7.1-1_i386.tgz
libknotifyconfig4_4.4.5-2+squeeze3_i386.tgz libsolid4_4.4.5-2+squeeze3_i386.tgz
libkparts4_4.4.5-2+squeeze3_i386.tgz libsoprano4_2.5.0+dfsg.1-1_i386.tgz
libkrosscore4_4.4.5-2+squeeze3_i386.tgz libstreamanalyzer0_0.7.2-1+b1_i386.tgz
libkrossui4_4.4.5-2+squeeze3_i386.tgz libstreams0_0.7.2-1+b1_i386.tgz

A probléma az, hogy miután mindezeket felrámoltam, a kdenlive indulása leáll ezzel, miután egy pillanatra feltűnik valami dialógusdoboz:

a[~]$ kdenlive
kdenlive(4265)/kdeui (KIconLoader): Error: standard icon theme "oxygen" not found!

QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
Object::connect: No such signal NotesWidget::aboutToShowContextMenu(QMenu *)
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
QWidget::setMaximumSize: (/QToolButton) Negative sizes (2,-2) are not possible
detected format: YUV 4:2:2 (YUYV): YUYV
Size: 640x480: 1/30,
Size: 320x240: 1/30,
Size: 176x144: 1/30,
Size: 160x120: 1/30,
Size: 352x288: 1/30,
detected format: YUV 4:2:2 (UYVY): UYVY
Size: 640x480: 1/30,
Size: 320x240: 1/30,
Size: 176x144: 1/30,
Size: 160x120: 1/30,
Size: 352x288: 1/30,
KCrash: Application 'kdenlive' crashing...
sock_file=/home/a/.kde/socket-darkstar/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
KCrash failed to exec(), errno = 2
a[~]$

Gondolom ilyenkor már nem hiányol semmit ha már elindul, és máshol van a hiba.

---
--- A gond akkor van, ha látszólag minden működik. ---
---

Arch alatt elindítottam egy kdenlive telepítést, amire azt mondta, hogy ezeket fogja, mint függőségeket telepíteni:

dvgrab-3.5-4
frei0r-plugins-1.3-3
gavl-1.2.0-2
kdebase-runtime-4.8.4-1
libavc1394-0.5.4-1
libiec61883-1.2.0-3
mlt-0.7.8-2
opencv-2.4.1-1
oxygen-icons-4.8.4-1
qimageblitz-0.0.6-2
sdl_image-1.2.12-2
sox-14.4.0-2
xine-lib-1.2.1-2
kdenlive-0.9.2-1

Vesztettem.
A kdebase-runtime már nem fér el sehol.
Itt még ezt is javasolják hibaüzenetemre, de ez még több helyet foglalna:
http://www.salixos.org/forum/viewtopic.php?p=2162

Módszeresen végigmentem előbb a hiányzó fájlokon, linkeken, majd megpróbáltam egy működő kde-s gép home könyvtárában lévő ./kde könyvtár átmásolásával elhitetni a fluxboxos rendszeremmel, hogy igenis teljes értékű kde fut, de nem volt jó ez sem.

Azt hiszem, ezzel most itt megint feladom, visszaállítok mindent a tegnapira, aztán vagy megint elkezdem elölről a kdenlive-t, vagy megint későbbre halasztom.

--------------
Csak nem hagyom abba...

Elmélkedtem, hogy ha ikonhiány van, akkor a fenti fórumról szedett javaslat függőségeiből simán kihalászhatom az oxigénikont mint csomagot, és felrakhatom, ez elfér (Ráadásul te is javasoltad ezt így külön: oxygen-icons-4.8.4-1):

root[usr]# slapt-get -i oxigen-icons
Reading Package Lists...Done
...
Need to get 24,6MB of archives.
After unpacking 36,0MB of additional disk space will be used.
...
|
Done
root[usr]#

Jól sejtettem. Megváltozott a hibaüzenet, tehát jót tettem, de a KDE-anomáliája még áll:

a[bin]$ kdenlive
QFSFileEngine::open: No file name specified
QFSFileEngine::open: No file name specified
Object::connect: No such signal NotesWidget::aboutToShowContextMenu(QMenu *)
detected format: YUV 4:2:2 (YUYV): YUYV
Size: 640x480: 1/30,
Size: 320x240: 1/30,
Size: 176x144: 1/30,
Size: 160x120: 1/30,
Size: 352x288: 1/30,
detected format: YUV 4:2:2 (UYVY): UYVY
Size: 640x480: 1/30,
Size: 320x240: 1/30,
Size: 176x144: 1/30,
Size: 160x120: 1/30,
Size: 352x288: 1/30,
KCrash: Application 'kdenlive' crashing...
sock_file=/home/a/.kde/socket-darkstar/kdeinit4__0
Warning: connect() failed: : No such file or directory
KCrash cannot reach kdeinit, launching directly.
KCrash failed to exec(), errno = 2
a[bin]$