cpufreq hogyan?!

cpufreq hogyan?!

Hozzászólások

A hibernálás már megy, csak az altatás nem, az "echo 1 > /proc/acpi/sleep"-re leáll a hdd, és frankón lekapcsol, de ha utánna lecsukom majd kinyitom a tft, visszakapcsolna, de bekapcsol, kilép konzolra, kiírja, hogy shutdown hda, majd kikapcsol! Ezt miért csinálja?

Sziasztok

Itt olvastam a cpufreq-ról szóló cikket! Van egy Toshiba 500Mhz-es laptopom, és ezem szeretem volna megolda ezt a dolgot! Szal, UHU 1.1 van fenn, fordítottam egy 2.6.9-es kernelt hozzá a cikk alapsán, amit kelett engedélyeztem, semmit sem tettem mobulba, csak az ACPI Processor P-States driver-t, mert azt csak így lehetett, kiválasztottam a cpu-k közük az összes intelt (mert biztos ami biztos)! Kernel lefordult, minden ok, de a /sys/devices/system/cpu/cpu0/ alatt nekem nincs cpufreq könyvtár!, és így nem megy semmi! Mi lehet a gond?

Aki tud segítsen!

Köszi

detto csak p3 600-as laptoppal, úgyanígy végigcsináltam mindent
sőt van egy olyan progi hogy powernowd és az meg azt mondja hogy sysfs-em sincs...pedig van

[quote:5b67533813="PcZolee"]Sziasztok

Itt olvastam a cpufreq-ról szóló cikket! Van egy Toshiba 500Mhz-es laptopom, és ezem szeretem volna megolda ezt a dolgot! Szal, UHU 1.1 van fenn, fordítottam egy 2.6.9-es kernelt hozzá a cikk alapsán, amit kelett engedélyeztem, semmit sem tettem mobulba, csak az ACPI Processor P-States driver-t, mert azt csak így lehetett, kiválasztottam a cpu-k közük az összes intelt (mert biztos ami biztos)! Kernel lefordult, minden ok, de a /sys/devices/system/cpu/cpu0/ alatt nekem nincs cpufreq könyvtár!, és így nem megy semmi! Mi lehet a gond?

Aki tud segítsen!

Köszi

Milyen processzor van benne?

P3-as Celeron Coopermine!
A Laptop tuti tudja ezt, mert win alat ment (amíg win volt rajt kb 2 perc :) )
Engedélyeztem a toshiba_acpi-t, és szépen kiír a /proc alatt minden infót, mostmár csak ezt kellene megoldanom, meg azt, hogy ha becsukom a tft, akkor kapcsoljon sleep módba!

A gép típusa Toshiba 4290CDS
Egyébként UHU alatt a 2.6-os kernellel megy vkinek a pcmcia? Mert nekem azt írja a szolgáltatás indításakor, hogy a pcmcia_core már fut, nem tudom gond-e, de a régivel (2.4.24) kiírta, hogy 2 slot van!

Igen ilyen nekem is volt, rossz modullal próbálkoztam. Nézegess dmesg kimenetet, vagy próbáld őket modulba forgatni.

Megpróbálom, csak 500mhz-en kissé lassú egy kernel fordítás :(...

dehogy lassu:>

en a 300 MHz es laptopomon is forgatok kernelt.
amugy en a cpufreq hez a 2.6.7 es kernel ck6 os patchet hasznalom
egy ha nem csinal semmi extrat a gep akkor 10MHz en jar a proci:>

ventura

2.5 Ghz után lassú!

2.6.7-os kenellel csinálod?! Lehet, hogy kipróbálom én is azzal, mert jobban szeretem, mint a 2.6.9-et, meg több patch-et is fel tudok tenni hozzá! Te modulba vagy fixet tettex a kernelbe s cpufreq részeit?! Vmi más kell még hozzá (progi beállítás)?

fixen mivel allandoan megy :>
amugy ez kulon parch nem a cpufreq resze.
colin kovas ck6 os patche progi nem kell hozza
aztan a power management nem vagy talana cpunal
tudod kapcsolni az alapertelmezett MHz et
1000,500,200,100 :>

nekem igy muxik jol

ventura

[quote:8ede90c6f6="_ventura_"]fixen mivel allandoan megy :>
amugy ez kulon parch nem a cpufreq resze.
colin kovas ck6 os patche progi nem kell hozza
aztan a power management nem vagy talana cpunal
tudod kapcsolni az alapertelmezett MHz et
1000,500,200,100 :>

nekem igy muxik jol

ventura

ezt nem értem, hol tudom állítani az alapértelmezett mhz-eket?

Most forog a 2.6.7, a ck6 patch-el, fixen bele a cuccokkal!

Nézem a leírást, de az alapján kell vmi speedfreq is, másnak sem megy enélkül?

ezt nem értem, hol tudom állítani az alapértelmezett mhz-eket?

hat a menuconfig ban valahol fejbol mar en se tom pontosan
vagy a power managment nel, vagy a cpu resznel
nekem mas nem kellett hozza illetve meg a toshiba tamogatas a kernelben
igy maganak allitja a cpufrek et

ventura

Mindegy, a 2.6.7 sem jött be, mert az csak akkor indította az acpi támogatást, ha acpi=force kernelparaméterrel bootoltam, de ilyenkor a rendszer a pcmcia betöltésénél csontá fagyott! Ha a pcmcia-t kikapcsoltam, akkor elindult, de pl. a toshiba_acpi modult sem tudtam betölteni, meg semmi egyebet :(!
Apropó pcmcia, 2.6.9-el nem fagy meg, de hibát jelez induláskor, azt, hogy a pcmcia_core modul már be van töltve, ez nem is lenne gond, de nem írja ki, hogy hány slot van szabadon! Erre nem tud vki vmi megoldást?

Apropó, a 2.6.9-es kernelhez nem tudtam feltenni a supermount patch-et, mert hibák voltak, mára megoldottam mindent, és megy, ha vkinek kell, akkor elküldhetem!

Frissítettem a biost, gondoltam, hátha ez a gond, de semmi változás :(.
Az acpid nem indul, mert a /proc/acpi/event foglalt, mi lehet a baja? Az acpi_listen szépen listázza a történéseket!

Már teljesen tanácstalan vagyok :(. Legalább az menne, hogy ha becsukom a tft-t (lid: close), akkor lekapcsolja a hdd-t, meg mindent stand by-ba!

[quote:977011d2ae="PcZolee"]Frissítettem a biost, gondoltam, hátha ez a gond, de semmi változás :(.
Az acpid nem indul, mert a /proc/acpi/event foglalt, mi lehet a baja? Az acpi_listen szépen listázza a történéseket!

Már teljesen tanácstalan vagyok :(. Legalább az menne, hogy ha becsukom a tft-t (lid: close), akkor lekapcsolja a hdd-t, meg mindent stand by-ba!

Ha ennyire nem megy az is elkepzelheto, hogy szar az alaplapodban az ACPI implementacio. Ha igy van, akkor ha fejen allsz se fog menni...

Hát, remélem nincs igazad! Még próbálkozom! Az az érdekes, hogy win alatt tökéletes volt minden! Mindegy, remélem legaládd azt sikerül összehoznom, hogy standby-ba álljon!

Egyébként a /proc/acpi/event miért felelős? Mi kéne legyen benne? Nincs köze a /etc/scpi/events -hez? Mert ott csak egy delault van!

Trey nállad a cpufreq minden része fixen van a kernelben? Kelett még vmit állítani?