A Debian 2.2 Potato működik 2.4.x -es kernel -el ?

 ( trey | 2001. szeptember 13., csütörtök - 8:01 )

Kaptam több levelet, amelyben azt a kérdést tették fel, hogy a Debian Potato működik-e a 2.4 -es kernelverziókkal.

Nos, a válasz az, hogy használható, bár a Debain nem garantálja a működését. A Potato fejlesztésekor a 2.4 -es kernel még nem volt kész, így néhány olyan dolog kimaradt a csomagok konfigurációiból amelyek a 2.4 -es kernelt támogatták volna (modutils, pppd, stb.). Ennek ellenére Adrian Bunk Debian fejlesztő összefogta azokat a csomagokat amelyeknek a frissítése szükséges ha Potato -t akarsz 2.4 kernel -el használni. A csomagok legtöbbje egy újraforított (recompiled) verziója ezeknek a csomagoknak, amelyeket az unstable disztribúcióból vettek.

A Debian NEM garantálja ezeknek a csomagoknak a tökéletes működését!

Mielőtt upgrade -lnél feltétlenül olvasd el ezt az oldalt:

http://www.fs.tum.de/~bunk/kernel-24.html

Ha apt -ot használsz akkor a /etc/apt/sources.list -be állítsd be a következő sorokat:

deb http://people.debian.org/~bunk/debian potato main

deb-src http://people.debian.org/~bunk/debian potato main

és add ki a következő parancsokat:

apt-get update

apt-get -u dist-upgrade

Természetesen ez a hivatalos verzió, a megoldás többféle is lehet, az én tapasztalataim szerint gond nélkül működik a Potato a 2.4.x kernel -ekkel.