képernyő probléma - vagy flash inkább?

Fórumok

hali van egy kis probléma.

frugalware 0.9
nvidia fx5500 nvidia gyári driver pontosan nem tudom melyik, de 17x.x verzió. a 18x.x-es telepitő mondta, hogy az a verzio támogatja már csak ezt a kártyát.
flashplugin 9.0.124.0-1 telepitve.

a probléma böngészöben (bármelyikben) pl a youtube-on a videók, ha teljesképernyöre állitom szaggat, darabos a kép. picibe megy szépen.

néhány oldal érdekesen jelenik meg: http://kepfeltoltes.hu/view/090308/pillanatfelv_tel1_www.kepfeltoltes.h…

xorg.conf-on kellene valamit allitani vmit vagy más progit a régi helyébe? ugyanezekkel a progikkal másik gépen megy minden. fx5200-as kártyával szintén ment minden.

az xorg.conf:

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder57) Thu Jul 17 18:39:19 PDT 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
RgbPath "/usr/lib/X11/rgb"
FontPath "/usr/lib/X11/fonts/misc/:unscaled"
FontPath "/usr/lib/X11/fonts/100dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/75dpi/:unscaled"
FontPath "/usr/lib/X11/fonts/misc/"
FontPath "/usr/lib/X11/fonts/Type1/"
FontPath "/usr/lib/X11/fonts/Speedo/"
FontPath "/usr/lib/X11/fonts/100dpi/"
FontPath "/usr/lib/X11/fonts/75dpi/"
FontPath "/usr/lib/X11/fonts/cyrillic/"
FontPath "/usr/lib/X11/fonts/TTF/"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "InputDevice"

# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
Option "XkbLayout" "hu"
EndSection

Section "Monitor"

Option "DPMS"
Identifier "Monitor0"
VendorName "Philips"
ModelName "Philips 107S6"
HorizSync 30.0 - 72.0
VertRefresh 50.0 - 160.0
Modeline "1280x1024@60" 83.91 1280 1312 1624 1656 800 816 824 841 -hsync +vsync
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1280x1024"
EndSubSection
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Hozzászólások

A Flash Player legújabb verziója 2009. március 8-án:
10.0.22.87

a 9-es széria nem használ hardveres gyorsitást és több súlyos
biztonsági hibát is tartalmaz!
Nem a vid.kartya driver a probléma!
Ha frissítesz erre, az megoldja a gondodat.

Töltsd le innen a .tar.gz fájlt:
http://get.adobe.com/flashplayer/?promoid=BUIGP

tömörítsd ki az /usr/lib/mozilla/plugins -ba
(gondolom 32bites linuxra kell)

letöltöttem amit mondtál.
uninstaláltam a flashplugint. bemásoltam oda ahova mondtad.
eddig ugyanaz.

teljes képernyön szaggat a flashvideo, meg néhany oldal hulyén jeleneik meg minden bongészön, amint a képen is látszik, duplán adja be a menüjeit.

amúgy igen 32 bites linux.

nVidia drivernél az xorg.conf-ba elfér még néhány dolog:

Option "RenderAccel" "True"
Option "BackingStore" "True"
Option "MultiSampleCompatibility" "True"
Option "UseSSE" "Yes"
Option "Agpgart" "1"

Bróbáld még ezt (vagy ebből a konfigodnak megfelelő részt) beletenni a screen szekcióhoz.

beleraktam ezeket az xorg.confba, jobb is a full képernyős flash videó lejátszás. szinte folyamatos, néha-néha szaggat be, de jól van az.

viszont néhány oldal furcsa megjelenítése (http://kepfeltoltes.hu/view/090308/pillanatfelv_tel1_www.kepfeltoltes.h…) az megmaradt.

közben kipróbáltam operával is(hátha a böngésző motor a bibis), de azzal is ilyen.

kipróbáltam az "nv" driverrel X-et indítani, dettó, tehát gondolom, nem az nvidia driver a bajos. próbáltam 1024x768-ban is az X-et, úgy is marad a probléma.

így akkor már csak a flash plugin maradt. érdekes de másik gépen ugyanez a rendszer és progik, mégis jó. több másik gépen is, hogy pontos legyek.

olyan van hogy a flashplugin nem szeret egy hardvert?

Szerintem van. De mivel zárt forrású, soha sem tudjuk meg :S

Miközben ezt írtam, megnéztem egy youtube videót:
http://www.youtube.com/watch?v=qW3zHEtL0T4
Bár nem is ez a lényeg. Processzor terhelés 38% és nem szaggat (régebben tudom, hogy igen, mert az előzményekből szedtem) Kiraktam teljes képernyőre és a terhelés maradt, ráadásul nem szaggat.

Részemről a probléma megoldva.

8.10-es Ubunturól 9.04-re frissítettem. Gondolom az új X.org csinált valamit.

Mielőtt nagyon belemerülnél a kutatásba, szerintem nézz bele a kern.log/syslog ba van e NVRM: XiD kezdetű üzenet, ill. sokdarab gpu gart initialize a xorg logban, mert lehet hogy ugyanaz a hiba, mint nálam volt.

--------------

r=1 vagyok, de ugatok...

A flash nalam se a legjobb, igaz pont a youtube megy (fullscreen be is)

Eddig a TV2 tenyek oldala(http://tenyek.tv2.hu/Adasok) viszi a palmat, meg normal meretbe sem megy normalisan, 100% CPU, szaggat, meg jo hogy a csak a kep, de az nagyon. Ket kulonbozo gepen, ket kul kartyaval is. (nvidia vs intel hoki alaplapi), flash leguljabb.

Hello!

csináltam egy glxinfo-t, szerintem ki lehetne belőle következtetni, hogy mi nem megy az nvidia driverben, ha látnánk olyat is, amin jó a flash és bemásolnád a sajátodat is.

ENyém: http://pastebin.com/m6f7235e2