GtkRadiant kérdések

 ( nevergone | 2008. augusztus 12., kedd - 22:45 )

Csak két kérdésem lenne:

1.) Miután a fordítás nekem nem jött össze Hardy Heron alatt (vagyis lefordult, csak éppen nem volt használható a végeredmény), tud valaki olyan csomagot a GtkRadiant 1.5 -ös verziójából, amely feltelepíthető a fenti rendszerre, és lehetséges vele Quake3 alá pályát szerkeszteni?

2.) Hogyan lehetséges az, hogy Windows alatt GtkRadiant -tal megszerkesztek egy pályát Quake3 Arena alatt, és Linux alatt az 1.32b -s point release -t felhasználva nem jelennek meg egyes texturák, ilyen pl. a köd? Elvileg mind a két rendszer Quake3 Arena (nem Team Arena), ha a főmenüben a Team Arena -t választom, ki is lép a játék.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

2.
Lehetseges, hogy grafikai beallitasok szerint a kod nem jelenik meg ?
Lehetseges, hogy nem ugyan azok a textura fileok, esetleg kevesebb van ?


Amit nem lehet megirni assemblyben azt nem lehet megirni.
2.6.27-rc2-00389-g10fec20

Kis és nagybetű különbözőség nem játszhat be?
Textúrák neve és útvonala stb.

Elvileg mindent a baseq3 könyvtárhoz viszonyít, abban pedig már minden ugyanúgy található meg.

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Nos, elvileg tudok adni komolyabb leírást a Radiant nyűgjéről.
Szóval ez a leírás alapján lefordult szépen, az install is végigmegy, mégis indításkor ezt a hibát kapom, és itt bármelyiket választom, kilép a program.
Próbáltam keresni a hibaüzenetre, de érdemben nem segített.

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Itt van egy Hardy .deb.

Nekem mondjuk elszáll, de tény, hogy a videokártyám nem mai darab (g400).

A fórum szerint is arra érdemes ügyelni, hogy a compiz ki legyen kapcsolva.

Ez még jól működik is, csak éppen a Quake3 nincs benne. Amúgy érdekes, hogy nekem is ugyanolyan videókártyám van, mint neked, és nem száll el a program.

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Mostanság i815-ös chipsettel (HP vectra vl400-as alaplap), 256 mega rammal, 667Mhz p3-al nyomulok. Lehet hogy ebben a kombinációban van valami nem szerencsésm, és köszi hogy jelezted!

Lehet, h csak simán sz*r a matroxom.
Stormbaan Coureur is kifagy. :-) Esetleg nálad?

Esetleg próbálkozz a ZeroRadiant-al, vagy a DarkRadiant-al

Szerk: a DarkRadiant egy Doom3 modhoz van.

Szóval rohadtul nem ment a fordítás, mert mindig volt valami nyűgje, értelmes csomagot sem találtam. Már feladni készültem, mikor rátaláltam erre, az itt lévő bináris teljesen jól működik. Mondjuk a Zeroradiant valamiért nem fordít, de komolyabban nem is foglalkoztam vele, mert a másik bőven elég nekem.

Itt pedig pár info:
http://ingar.satgnu.net/gtkradiant/index.html

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Sikerült végre lefordítanom a Gtkradiant 1.5.0 -ás verzióját Ubuntu Hardy -n Quake 3 támogatással.
Alkalmaztam néhány patch -t (pl. böngészőnek ne a Netscape -t keresse, hanem a Firefox -ot), illetve belegyúrtam a Quake2World pár elemét.

A fájl elérhető itt, a mérete tömörítve 5.5 MB.

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Az előző változatból kimaradtak a példafájlok (pl. pályák), így azokat is beletettem most. Azt elfelejtettem leírni, hogy mindkét változat 32 bites rendszerekhez készült.
Az új változat elérhető itt: http://www.fileshack.us/get_file.php?id=675130&file=gtkradiant-1.5.0.tar.bz2

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Meg is nézem.

Ubuntu Hardy alatt készítettem egy 32 bites fordítást a Zeroradiant (1.6) frissen leszedett forrásából. Nekem teljesen jól megy, és több olyan probléma is elhárult vele, amelyek jelentkeztek nálam az eddigi verziókban (pl. köd, görbék kezelése). Csak a Quake 3 használatához szükséges fájlokat tartalmazza, az /usr/local/lib/gtkradiant-1.6.0/ könyvtárba érdemes kicsomagolni.
Elérhető itt:

http://www.fileshack.us/get_file.php?id=988653&file=gtkradiant-1.6.0.tar.bz2
http://www.megaupload.com/?d=T0POVRKO
-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Hali!

Rég foglalkoztam már gtkradiant-al. A 2. kérdésedre lehet az ad választ hogy hiányos a shader listád.

ha becsomagoltad a pályádat pk3-ba akkor kell benne lennie egy scripts könytárnak és abban egy shaderlist.txt filenak(scripts/shaderlist.txt). Ebben kell felsorolni a texturákat amiket használsz. Természetessen kell még hozzá a shader file is.
pl : a scripts ben : pályaneve.shader :

textures/palyaneve/palyaneve
{
	qer_editorimage textures/palyaneve/palyaneve.jpg
}

Itt egy példa: CubeMap

Esetleg nem tud valaki egy Intrepid Ibex deb csomagot valahol?
Az általam talált deb csomagok nem működnek.