Frissítettem Ubuntu Feisty Fawn-ről Gutsy Gibbon-ra

 ( trey | 2007. október 21., vasárnap - 10:00 )

(A Miért váltottam Debian Sarge-ról Ubuntu 5.10-re?, Frissítettem Ubuntu Breezy-ről Dapper-re, a Frissítettem Ubuntu Dapper-ről Edgy Eft-re és a Frissítettem Ubuntu Edgy Eft-ről Feisty Fawn-re kaland folytatódik...)

A Canonical és az Ubuntu fejlesztői október 18-án - az előre kiadott ütemtervnek megfelelően - kiadták az Ubuntu 7.10-es, kódnevén Gutsy Gibbon kiadását. Miután néhány apróbb problémától eltekintve már a szeptember eleji alpha is használhatónak tűnt, úgy gondoltam, hogy itt az ideje megnézni, hogy mit tud a "latest & greatest".

Elővettem a backup HDD-m, klónoztam az éles rendszerem, majd nekiláttam. A szokásos dist-upgrade folyamatot nem ismertetem részletesen, mert már annyiszor megtettem (lásd a cikk elején levő linkeket). Szóval a sources.list átírása után nekiláttam a frissítésnek. Kb. 20 perc alatt lecsorogtak a szükséges csomagok. A frissítés 100%-ban problémamentesen lezajlott. Talán 5 eldöntendő kérdést tett fel a csomagkezelő akkor, amikor afelől érdeklődött, hogy mi legyen az adott csomag konfigurációs file-jával (telepítse-e a csomag karbantartójának verzióját, megtartom-e a sajátot, megnézzük-e a kettő közti különbséget, ...). Miután a csomagok települtek és az apt konfigurálta az összeset, el is készült a frissítés.

A gépemben egy Radeon Mobility X700 (PCIE) chip lakik, ezért gondoltam megetetem egy fglrx driverrel:

# apt-get install linux-restricted-modules-2.6.22-14-generic

A VMware-nek kellenek a kernel header file-ok:

# apt-get install linux-headers-2.6.22-14-generic

Az evms csomagra nincs szükségem:

# apt-get remove --purge evms

A beagle-re sem:

# apt-get remove --purge beagle

Ok. Akkor nézzük meg, hogy mit csináltunk. Reboot.

A Reboot után az X csont nélkül indult és a megszokott gdm bejelentkezőablak fogadott. A korábban tapasztalt login hang hiány megszűnt. Javították a hibát. Bejelentkeztem és semmi változást nem tapasztaltam a legutolsó Feisty-s desktop felületemhez képest. Jobban megnézve összesen két ikon (Rhythmbox, Timer applet) változott.

Egyetlen apróbb problémát tapasztaltam a frissítés után. A Gutsy már nem használja a /etc/iftab file-t a hálózati csatolók perzisztens elnevezéséhez. A frissítés során a beállítások a "/etc/udev/rules.d/70-persistent-net.rules" file-ba vándorolnak át. Ez meg is történt, de nem teljesen jól, aminek a következménye az lett, hogy a korábban "eth0" és "eth1" névre hallgató csatolófelületeim "eth2" és "eth3" névre hallgattak. A file-ban a MAC address-ek megfelelő interface-hez rendelése után a rend helyreállt. Valószínű, hogy ezzel a problémával friss telepítés esetén nem találkozik senki és valószínűleg frissítés után is csak az, akinek több hálózati csatolója volt és korábban használta a /etc/iftab file-t.

A Gutsy kétségtelenül legnagyobb újdonsága az out-of-the-box 3D desktop. Gondoltam, hogy itt az ideje kipróbálni.

System -> Preferences -> Desktop Effects

Bejelöltem a "Workspaces on a Cube" pontot, majd az megnyomtam az "Enable Desktop Effects" gombócot. A desktop kettőt villant, megkérdezte, hogy szeretném-e az új beállításokat megtartani, vagy visszatérek-e az előzőhöz. Mondtam, hogy szeretném... Ezzel a 3D desktop használatra kész állapotba is került. Valóban csak egy gombnyomás (visszafelé is, ha az ember nem kívánja, akkor szintén egy gombnyomással lehet hatástalanítani).

A System -> Preferences -> Desktop Effects alatt sok beállítási lehetőség nincs, ezért érdemes a következőt elkövetni:

# apt-get install compizconfig-settings-manager

Ezután a System -> Preferences -> Advanced Desktop Effects Settings alatt aprólékosan szétkonfigurálhatjuk a 3D effekteket.

Hogy a "kocka pörögjön", néhány apróbb beállítást el kell végezni az "Advanced Desktop Effects Settings" alatt. Be kell kapcsolni a "Desktop Cube" és "Rotate Cube" menüpontokat, majd a "General Options -> Desktop Size -> Horizontal Virtual Size" alatt megadni legalább "2" (pörgő téglalaphoz :), de a "kockához" leginkább "4" értéket. Ha kész, akkor már lehet is pörgetni...

Ízesítésül szórtam hozzá egy kis "Cube Reflection"-t, hogy szépen tükröződjön:

Továbbá állítottam hozzá "0" "Transparent Cube" értéket, amitől átlátszó lett a "kocka"

Expo-val a munkaterületek közti váltás gyerekjáték:

A videolejátszás sem probléma:

És kis hack után fut a VMware 6 is:

A rendszert tesztelve minden szépen működik, komolyabb (kisebb konfigurációval el nem hárítható) problémával nem találkoztam. A rendszer működik, véleményem szerint rosszabb nem lett, mint a Feisty volt. Természetesen, mint minden rendszer komolyabb frissítés után, a Gutsy is igényel némi simogatást, de korántsem annyit, mintha 0-ról telepítené az ember. Legalábbis nekem, Debian-on felnőtt felhasználónak, sokkal egyszerűbb és kényelmesebb a dist-upgrade, mint a teljes reinstall.

Általában a rendszerfrissítések kívánnak az embertől kisebb kompromisszumokat. Mivel a Gutsy-ban a 3D desktop megjelenése nagy lépésnek számít, nem várhatja senki tőle, hogy teljesen úgy viselkedjen, mint a korábbi Ubuntu kiadások. Kicsit más, kicsit modernebb, kicsit tovább kell szokni. Azt sem tartom kizártnak, hogy egy kicsit még forrnia kell és csak a következő kiadásra lesz olyan, hogy a !technikai vénájú emberek is szívesen veszik majd. Én majd' két napi nyomkodás után úgy döntöttem, hogy nekem érdemes váltanom a kiválóan szuperáló Feisty-ről. Minden bizonnyal lesznek olyanok, akik nem akarnak kompromisszumokat kötni. Nekik talán nem érdemes azonnal nekiugraniuk a frissítésnek. Viszont akik nyitottak az újra, túl unalmasnak találják a régit, azoknak mindenképpen érdemes legalább a teszt erejéig kipróbálni az Ubuntu legfrissebb kiadását!

A Gutsy egy 1.7-es Intel(R) Pentium(R) M processzorral, 1GB RAM-mal, ATI Radeon Mobility x700 chip-pel szerelt gépen kiválóan teljesít (még takarékos 800 MHz-es "ondemand" CPU beállításon is). Mivel a korszerű gépek ezt a konfigurációt fényévekkel felülmúlják, azt hiszem, hogy nem lesz probléma a futtatással.

Akik netán még nem frissítettek volna és kedvet kaptak a Gutsy-hoz, azoknak jó frissítést! :)

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Én kubuntu-t frissítettem adept-tel minden különösebb probléma nélkül. Csak a GRUB új beállító fájlja nem volt megfelelő, az új kernel nem bootolt vele (ez mondjuk elég ciki), kicseréltem a régire és azóta megint minden ok. :) Összességében én is meg vagyok elégedve!

Nem tapasztaltam semmilyen új beállítófile-t(?) grub-nál. Na a /boot/grub/menu.lst-re gondolsz... Nekem a régi file-om van, abba szúrta be a csomagkezelő az új 2.6.22-es kernel két plusz sorát. Semmilyen indítási problémám nem volt :)

--
trey @ gépház

checkgmail magyarul utf8-cal?
Sz*r...
Ja és van róla bug: https://bugs.launchpad.net/ubuntu/+source/checkgmail/+bug/147610
No meg a sexy se ártana, bár ez csak luxus, de azért jó: https://bugs.launchpad.net/ubuntu/+source/checkgmail/+bug/151226
A compiz állítgatására, pedig nem ártana valami egyszerűbb program. Gondolok itt pl. a gombok beállítására.
Ja még valami: amikor cdről bebootol a gép, akkor a magyar nyelv választás után a 3. sorban talán bennemaradt egy "_".

Gentoo Karvaly

A checkgmail-ről nem tudok nyilatkozni, mivel nem használom a nevezett programot. Legalábbis a dpkg -l szerint :)

"A Compiz állítgatására, pedig nem ártana valami egyszerűbb program. Gondolok itt pl. a gombok beállítására."

Valóban, a laikusoknak elsőre talán nehezen átlátható lehet az "Advanced Desktop Effects Settings", de azoknak akik nem akarják magukat beleásni: jobb klikk az asztalon ->
"Change Desktop Background" -> "Visual Effects" -> "Normal" vagy "Extra" előre definiált, vagy a "Custom".

"Ja még valami: amikor cdről bebootol a gép, akkor a magyar nyelv választás után a 3. sorban talán bennemaradt egy "_"."

Nemtom, CD-ről két évvel ezelőtt boot-oltam utoljára ezen a gépen Ubuntu-t, amikot a Sarge-ról 5.10 "Breezy Badger"-re váltottam. Azóta csak dist-upgrade :)

--
trey @ gépház

A compiz állítgatására, pedig nem ártana valami egyszerűbb program. Gondolok itt pl. a gombok beállítására.

ccsm es minden funkcio vagy effekt beallitasanal beallithato a billentyukombo, illetve a general resz.

Megtetszett ez a Compiz, Debianra fel is mászott apt-get-tel, viszont sehol semmi... man page-ekben semmi érdemleges, egyáltalán hogy lehet elindítani?

Le kell cserélni az ablakkezelőt compizra:
compiz --replace &
Ne ijedj meg, nem lesznek ablakdekorációid, azokat külön kell beállitani. Ha mindent sikeresen belőttél, akkor a session indulásakor automatikusan is megteheted.
Lehet, hogy az xorg.conf-ban is kell majd hakkolni, nem tudom, milyen hardvered van.

--
Debian - The "What?!" starts not!

Suspend neked megy fglrx-szel?

Nem, az ismert hiba fglrx driverrel. Úgy gondoltam, hogy ezzel együtt tudok élni, amíg az ATI fejlesztők javítják a driver-t. Vagy pörgetek egy custom kernel-t és a SLUB-ot visszateszem SLAB-ra. Azzal állítólag megy a suspend. Még nem döntöttem el.

--
trey @ gépház

Forog a kernel.

Az még kevés lesz. Majd az fglrx kernel modult is pörgesd hozzá, mert nem fog betöltődni állítólag a SLAB kernelbe.

--
trey @ gépház

ha suspend előtt kiváltasz consolra úgy müködik, elég körülményes de legalább valami.

+1 ?
(Szerk. közben megjött a válasz is...)

A 3D desktop bekapcsolása után a terminal indításakor egy nagy fehér ablakom van kurzor, menüpontok, minden nélkül. Igaz a ctrl+d működik benne :)
Ha viszont a 3D bekapcsolása előtt indítom, akkor tökéletesen működik....

Más is tapasztalt hasonlót?

"A 3D desktop bekapcsolása után a terminal indításakor"

Nem tapasztalok ilyesmit.

--
trey @ gépház

Terminál átlátszóság? Mert ha megy a compiz a terminál indításakor, akkor valódi átlátszóság lesz! Sőt, ha hátteret állítasz be, akkor az alfa-channel szerint fogja átlátszóvá tenni.

Hasonló van nálam is. A 3D bekapcsolása után eltűnnek az ablak dekorációk (a fejlécek a nyomógombokkal), és pl. a terminál indítása egy üres fehér téglalapot ad.

Ezen középtájt van a gnome-terminal :-(

Más programok is vnnak, amik fehér téglalapot adnak. Már több mindent kipróbáltam, de nem javult meg. Leszedtem az összes compiz-t tartalmazó csomagot, az emeraldot majd úrja feltettem. Sajnos nem változott. Esetleg van valami ötlete valakinek?

én sem értem, közben másik gépen is frissítettem, azon minden ok. majd még agyalok :D

Xubuntu-t használok (inkább gyors legyen, mint szép), pár napja frissítettem. Nem sok különbség van, de minden programból jött új verzió. Semmi problémám nem volt eddig.

Egy másik topicnál sokan szidják, úgyhogy +1 a gond nélkül frissítő közé.

A frissítéssel nekem sem volt gond. Megvolt 40 perc alatt az egész, közben távoli asztalon dolgoztam egy windows-os gépen, ssh-val néhány linuxon, plusz ment még egy VirtualBox is.

Ha bekapcsolom az advanced desktop effekteket, akkor nem indul el a netbeans, így erről le kell mondanom. Bár nem nagy veszteség, eddig is megvoltam nélküle.

A kikapcsolod a NetBeans használatának idejére, az nem opció? BTW: most, hogy mondod, megnéztem az online póker kliensemet. Az is Java, de az működik a 3D desktopon. Cseresznyére.

--
trey @ gépház

Ja, vagy áttérek eclipse-re

mi a neve annak a kliensnek?

Nem tudom mi a neve. A kedvenc pókeroldalaimon (europoker.com, pokerroom.com) van egy "Instant Play" gomb. Megnyomom, elindul.

--
trey @ gépház

PokerTH-val nem szoktad tolni?


It doesn't matter if you like my song as long as you can hear me sing

Nem. Kizárólag a fent említett oldalakon vagy IRL.

--
trey @ gépház

nekem megy a netbeans alatta

Celeron-M 1400Mhz, 768M, Ubuntu 7.10, 2.6.22

Melyik jdk-t/jre-t használod?

Nekem is. Gentoo/JDK 1.6. Szerintem is a JRE/JDK lehet a bajság, a 1.5 asszem nem szeresse a compizt, a 1.4 még úgyse.

Kösz az infot. Nekem 1.5-ös van fenn, majd kipróbálom az 1.6-ossal akkor.

nekem 1.6 van, de a compizt nálam a SmartSVN kliens nem szereti.
Olyat csinál, hogy néha a megnyíló msg boxok, vagy ablakok üresek. Nincs rajtuk se gomb, se semmi, viszont működik minden. Tehát tényleg csak nem látszik. (pl tudom hogy az ablakon az OK gomb az aktív, egy Entert ütve viszont megy tovább a dolog)
Ha kikapcsolom a compizt, akkor minden ok.
Ez már a Compiz Fusion előtt is így volt nálam.
:(

1.6-ossal megy. Most viszont az a gondom, hogy - és ez független a desktop effectektől - hogy az urban terror alatt néhány perc játék után csontra fagy a gép. Nvidia driver probléma lehet?

"System -> Preferences -> Desktop Effects"...

Igaz, magyarul és Kubuntut használok, de egyszerűen nem jövök rá, hol keressem.

Nálam magyar ubin: Rendszer/Beállítások/Advanced Desktop Effects Settings

Ez egy másik menüpont.

--
trey @ gépház

Nekem az aptitude install compizconfig-settings-manager
ezt a menüpontot telepítette....

Lejjebb kitárgyaltuk, hogy miért van nekem kettő. A Feisty-ből még megmaradt a desktop-effects csomagom is, ami csak annyit tud, hogy ki/be kapcsolja a 3D desktop-ot.

--
trey @ gépház

Nekem Kubin nincs Rendszer->Beállítások

apt-get install desktop-effects

majd terminal-ból: desktop-effects (vagy csinálsz rá egy launcher-t)

--
trey @ gépház

Nincs ilyen csomag.

Hol keressem, ha ezek között nincs?

deb http://de.archive.ubuntu.com/ubuntu/ gutsy main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ gutsy-backports main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ gutsy-proposed main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ gutsy-security main restricted universe multiverse
deb http://de.archive.ubuntu.com/ubuntu/ gutsy-updates main restricted universe multiverse

Hmm, úgy tűnik, hogy ez közben megszűnt. Ezt még a feisty idején telepítettem, így maradhatott meg:

trey@alderaan:~$ apt-cache show desktop-effects 
Package: desktop-effects
Status: install ok installed
Priority: optional
Section: gnome
Installed-Size: 544
Maintainer: Ubuntu Core Developers <ubuntu-devel-discuss@lists.ubuntu.com>
Architecture: i386
Version: 0.7.1-0ubuntu4
Depends: [...]
Description: preferences applet for configuring desktop effects
 This package provides a preferences applet for configuring desktop effects
 using the compiz compositing and window manager
Original-Maintainer: Matthew Garrett <mjg59@srcf.ucam.org>

Akkor ez már nem játszik.

--
trey @ gépház

A Desktop Effects voltaképpen melyik program? Lehet, hogy csak átnevezték a csomagot. Meg tudod nézni, melyik lehet az?

Ahogy írtam a cikkben:

apt-get install compizconfig-settings-manager

Valószínűleg ez váltotta le.

--
trey @ gépház

Ezt feltettem, de tök üres a felületének jobboldali ablaka.

Hát, passzolom. Kubuntu-hoz nem nagyon tudok hozzászólni.

--
trey @ gépház

Beelőztél, nem tudtam javítani.

A compizconfig-settings-managert az apt feltette függőségek nélkül. (Tán szándékos, hogy nem fügőőségei a compiz csomagok, de illogikus). No, most már fennt van. Köszönöm.

Kubuntuban nincs default compiz, ha jól emlékszem.

Rendszer > Beállítások > Megjelenítés? Legalábbis gnome alatt.
Parancssorból ccsm vagy compizconfig-settings-manager.

Hogy csináltad, hogy ATI kártyával van kockád? fglrx + XGL vagy opensource ati driver + AIGLX? Nekem X200M van, az opensource driver elvileg nem támogatja ezt, a másik kombináció meg valahogy nem sikerült eddig... utoljára dapper alatt volt compizom

Semmit nem csináltam. Az fglrx driverrel megy. A linux-restricted-modules-2.6.22-14-generic csomag telepítése után 0 beállítással működik.

--
trey @ gépház

Az xorg.conf-ban van AIGLX támogatás?

Az xorg.conf-om kb. a Dapper óta ugyanaz. Nincs benne semmi extra. Az egyetlen kompozittal kapcsolatos opció, ami benne maradt:

Section "Extensions"
        Option  "Composite" "0"
EndSection

Ezt is csak most néztem meg, ha nem kérded, nem is tudom :) Lehet, hogy át is kéne néznem, mert már van vagy 1.5 - 2 éves...

Ennyi az egész: xorg.conf

--
trey @ gépház

Hmm... Érdekes, nekem nem sikerült "mozgásra" bírnom a compiz-fusiont. Pedig elvileg ua., mint neked. Az ATI Mobility X700-as pedig hardweres gyorsítással működik.

Trey gépét megszállta az év végére ígért szentlélek.

Nekem a frissítés kicsit hosszabbra nyúlt, mint terveztem. Ennek a fő oka, hogy miközben a gnome battery-applet frissült, nem mutatta az aksi töltöttséget, csak egy olyan ikont, ami a hálózatra csatlakoztatást szokta jelölni. Mivel nem voltam hálózaton, a frissítés közben - természetesen libc6, libc6-devel és társainak frissítésekor - kikapcsolt a gép. Ezután nem keveset harcoltam vele, mire újra formába hoztam, de sikerült.

Továbbá: Habár a desktop effektek alapból ki vannak kapcsolva, az én onboard Intel grafikus vezérlős, cerka notebookom még ilyenkor is csúnyán szaggatott, mikor megmozdítottam egy ablakot a desktopon.

Megoldás: aptitude remove/purge xserver-xgl => fallback Xorg-ra.

Végezetül: Nekem hiányzik a Gnome splash screen. :)

Rakd fel a gnome-art csomagot.

Gentoo Karvaly

azert az az iftab bug kicsit gazos, nem? pl ha valaki egy szervert frissit, es nemfigyel/nemtud rola, akkor nezeget, hogy a reboot utan miert elerhetetlen a gep

--
A vegtelen ciklus is vegeter egyszer, csak kelloen eros hardver kell hozza!

Ugyan menedzsment processzor, iLO, RAC vagy egyéb "backup" elérés nélkül csak a félbolond frissít távolról éles gépet, a bug nem szép. Már csak az a kérdés, hogy a) előjön-e másnál is (azaz reprodukálható-e) b) tudtak-e róla (bejelentette-e valaki). Az általam utoljára tesztelt RC-ben még nem volt ilyen probléma.

--
trey @ gépház

szerk.: rossz helyre postoltam.

Nincs valakinek véletlenül leírása, howto, url, bármi, hogy hogyan lesz nekem kde alatt (kubuntu) desktop effectem? Fglrx megy, fgl_glxgears szmolja az fps-eket. Innentől meg vagyok lőve, hogy mit is kellene pontosan csinálnom, milyen csomagok kellenek, stb.

+ még ilyenem van:
$ Checking for Xgl: not present.
No whitelisted driver found
aborting and using fallback: /usr/bin/metacity
no /usr/bin/metacity found, exiting

[1]+ Exit 1 compiz --replace

Thx!

--
http://internode.hu

Xgl kell hozzá.

ii xserver-xgl 1:1.1.99.1~git20070727-0ubuntu3 GL-based X server

--
trey @ gépház

Az fglrx nem támogatja az AIGLX-et, így Trey-nél csoda történt. Xgl-lel meg lehet oldani, de akkor meg nem lesz normális harveres gyorsításod.

Senki sem mondta, hogy AIGLX-szel megy. Ezt már korábban kitárgyaltuk. A Gutsy-ban Xgl van alapból.

--
trey @ gépház

Azzal tisztában voltam, hogy a TE configodban nem hivatkozol AIGLX-re, így az nem is játszhatott közre. Azt azonban nem tudtam, hogy a Xgllel párhuzamosan is futhat az fglrx... Ennek nekiesek este.

Mit jelent az, hogy párhuzamosan futhat? A fglrx egy driver. Az Xgl megy egy X szerver, ami az fglrx-en keresztül használja a hardvert. :)

--
trey @ gépház

Igen. A párhuzamosságot nem két driverre vonatkoztattam.

helló!

na én is most frissítettem, aztán gondoltam kipróbálom a compizt. felpakoltam minden csomagot, ami (elvileg) kellhet, és bár a rendszerbeállító ablakban nem találok semmi compizra történő utalást, megpróbáltam elindítani a dolgot:

compiz --replace &
...
Checking for texture_from_pixmap: not present.
aborting and using fallback: /usr/bin/metacity
no /usr/bin/metacity found, exiting

no hát persze h. nincs metacity, mert kde alatt vagyok.
tud vki erre vmi megoldást?

(ATI kártya, xorg.conf-ban ati driver van beállítva, fglrx driverrel vmiért nem indul el az x... :( )

még valami howtoban olvastam, hogy fel kell pakolni az Emerald-ot és utánna ezzel a paranccsal indítani:
compiz --replace -c emerald &

Nekem így megy KDE alatt, bár néha csinált érdekes dolgokat.

Nekem egy időbe beletelt, mire sikerült elindítani a KDE alatt. Az emerald-hoz az automata téma leszedés nem működik és a repókban sincs emerald-themes csomag. Le kell szedni a témákat a honlapjáról, beolvastatni az emerald-theme-manager-rel, aztán már megy sima compiz --replace segítségével. Két apróbb probléma merült csak fel: a switcher plugintól elszáll az emerald, tehát ezt le kellett kapcsolnom, de van helyette másik két plugin ami ugyanezt tudja. A másik az, hogy a KDE pager többnyire nem működik rendesen. Egyébként stabil(abb) és gyorsabb mint a Beryl.

Megszűnt a régi beryl-es svn forrás. Van helyette másik, csak még nem javították ki, hogy arra mutasson.

hat most kiprobaltam ugy, hogy telepitettem az Xgl-t, es atallitottam fglrx driverre , de valami nagyon szet lehet csuszva a cuccban, ugyanis ezutan az X.org 100%-ot vitt a procibol, barmit csinaltam...

ugyhogy most visszaaltam ati driverre, es leszedtem az Xgl-t. Ugyhogy meg varok egy kicsit ezzel a compiz-bulival... Pedig ugy vartam, hogy milyen jo lesz... :(

Egyáltalán a KDE-n támogatott a Compiz? A Kubuntu 7.10-re is ígértek a fejlesztők out-of-the-box 3D desktop-ot?

--
trey @ gépház

compiz.org főoldal:

"Compiz is compatible: Any X Window System based desktop environment, including (but not limited to) Gnome and KDE, is supported."

Egyébként én régebbről úgy emlékszem, hogy a KDE virtual desktop kezelésével nem volt kieggyezve a Compiz (vagy csak a Beryl?) a KDE és a Gnome különböző VD megvalósítása miatt. Valami felfogásbeli különbség volt benne, meg nem mondom, hogy pontosan mi.

Engedélyezted a zárt meghajtóknál az ati drivert? Nekem akkor nem ment a compiz+fglrx/XGL.

hat az a helyzet, hogy ha bepipálom a restricted drivers-nél a grafikus kártya meghajtóját, akkor is azt írja ki mellé, hogy nincs használatban. szóval nem egészen értem...

ha az xorg.conf-ban kicserélem az atit flxgr-re, akkor a restricted-ben nézve bepipálódik az engedélyezve dobozka, ám még mindig fel van tüntetve, hogy nincs használatban. és nem tudom, hogy hol lehetne használatra bírni...

(mert egyébként közben egy olyan bibi is van, hogy nem tudom a monitor beállításait piszkálni a Rendszerbeállításoknál, mivel magyarra van állítva a rendszer, és megint hibás valami fordítás. Természetesen ha visszaállítom a rendszer nyelvét angolra, úgy se megy a dolog... ááá...)

xserver-xgl csomag fennvan?

jaja, felraktam.

vhol korabban irtam, hogy ha felrakom az xgl-t, es fglrx-re valtok, akkor iszonyu lassu lesz az egesz grafikus felulet, 100%-ra tolja a procit. persze a compiz ettől nem javul meg :)

Opensource driver + aiglx?

Nekem volt pár gondom a frissítés után, egyrészét sikerült megoldanom, viszont van még egy, amit nem! Miután elindul az X (de ha nem indul, akkor sem), ctrl-alt- f1-f6 -ig, hiába akarok terminálba épni, csak villog a kurzor, nem kapok prompt-ot! Mi lehet a gond szerintetek? Mondjuk, én a sajnát 2.6.29-es kernelemmel használom, de már a 7.04 is ezzel ment gond nélkül!

köszi

<= PcZ On LinuxOS -- Powered By Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

FIX: 2.6.22.9 és nem 2.6.29? igaz!?


Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.
debian 4.0 - linux-2.6.22.9-pancs1-wifi2 - 2.6.22.9 kernel madwifivel itt

2.6.19-et akartam írni ;)

<= PcZ On LinuxOS -- Powered By Gentoo Linux =>

'Software is like sex: It's better when it's free!'
By Linus Torvalds

"Mondjuk, én a sajnát 2.6.29-es kernelemmel használom"

Innentől kezdve ezt nem neked kéne inkább tudni? :)

--
trey @ gépház

:)
szerintem a kernel.org-os srácok kérik a forrást :P


Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.
debian 4.0 - linux-2.6.22.9-pancs1-wifi2 - 2.6.22.9 kernel madwifivel itt

Kapcsold ki a spash-t a grub-ban.

Nekem egyátalán nem vált be... :-(
A HAL daemon nem hajlandó elindulni, a hálózat nem működik, gnome-settings nem indul.
Ebből install lesz. :-(
A HAL-t manuálisan el tudtam indítani, de a többire lövésem sincs.

Ugyan nincs Ubuntu-m, de a kollégáimnak azt szoktam ajánlani. Az egyiknek be is jött a Vista mellett a dual-boot-os laptopján.

Jó tippet adott a cikk viszont, mivel augusztusban cserélték a laptop-om alaplapját. Azóta nem tudtam rájönni, hogy miért csak eth2-ként tudom használni az integrált vezetékes hálókártyát (nemröhög). És most hasított belém: hát persze, a persistent-net szabályok miatt. Már át is állítottam és vidáman megy eth0-ként.

Thx,
Dw.

"Jegyezze fel a vádhoz - utasította Metcalf őrnagy a tizedest, aki tudott gyorsírni. - Tiszteletlenül beszélt a feljebbvalójával, amikor nem pofázott közbe."

Hi!

Valakinek sikerült Kubuntu és Intel GMA950 párost rábírni a Compiz-ra?
Két hete mikor az akkori bétán próbáltam nekem felezte a felbontást és így csak az asztal bal felső negyedét láttam a képernyőn.

Üdv: Tamaas

Nem elképzelhető, hogy a Ctrl + Alt + (+/-) kombinációkkal rá lehetett volna venni a helyes felbontásra? Volt nekem is ilyen anno, egy kis xorg.conf bütykölés után sikerült helyrázni, addig maradt a ctrl + alt + (+/-)-os megoldás.

Hát, ha valaki azt állítja, hogy ez a 3D kocka useless, az vagy nem használta, vagy nem tudja mit beszél, de nekem a 2 nap alatt úgy ráállt a kezem a billentyűkombinációkra, hogy fájna kikapcsolni. Kedvencem a (ctrl+alt) + nyíl le, ami kiteríti a kockát és a nyilakkal lehet a munkahelyek közt navigálni.

--
trey @ gépház

Tényleg jó, csak baromira nem vágom, hogyan üzemelem be kde alá...Ott nincs vmi hasonló lehetőség, mint gnome alatt, hogy be/kikapcsolom?
Mert nekem gnome alatt működik, de kde alatt nem találok semmit, amivel beállíthatnám...pedig nincs semmi amiért lemondanék a kde-ről, a gnoem irtó fapados ( nekem )! :)
üdv: pomm

Foglalmam sincs, életemben nem használtam KDE-t (2 percnél tovább), úgyhogy sorry. Google. Jobb ötletem nincs.

--
trey @ gépház

1x üljél neki és lehet találsz benne olyat ami bejön, lehet, hogy még át is állsz rá ..


Nekem mindig igazam van, ha nem, akkor nincs igazam, szoval megint igazam van hogy nincs igazam.
debian 4.0 - linux-2.6.22.9-pancs1-wifi2 - 2.6.22.9 kernel madwifivel itt

elég off, de egy évig gnome-ot használtam, mielőtt áttértem a kde-re. Nem kezdem el sorolni mi minden hiányzik nekem a gnome-ból, kezdve a testreszabhatóságtól egészen a fájlkezelő beállíthatatlanságán át. Ha nem akarok nagy erőforrású ablakozót, akkor fluxbox, ha van erőforrás, akkor kde...A problémám attól nem oldódik meg, hogy ablkozót váltok :)
Azért köszi ;)

trey:
A gúgli sok értelmeset nem dobott ki, illetve ezt a topicot :)
üdv: pomm

Repoban nincs, de ubuntuforums-rol toltottem le, mukodik a fusion-icon nevu prog/util, ezzel ki-be kapcsolhato, valszthato window-decor, újraindíthato stb..

http://rapidshare.com/files/64246300/fusion-icon_1.0-1.0_i386.deb.html

így néz ki

Köszi, megnézem :)
üdv: pomm

Köszönöm, megy vele...bár elég sokat kell finomítgatni...de használható, mégegyszer, köszi!üdv: pomm

Nincs mit. Ha egyszeru, gyors megoldás kell itt egy importálhato compiz profil. :P

http://rapidshare.com/files/64301697/compiz.profile.html

compiz settings manager - profile backend - import...

Teljesen egyetértek.
Hol vannak már ezek a VPS, meg egyéb fikázások? :)
2007-ben így kell kinéznie egy desktopnak és kész.
Kb 2 hete cseréltem a Debian sid-et, és azóta én vagyok a világ legelégedettebb usere.
Minden utolsó kis apróságot sikerült megoldani, még a Matlabom is repül, hála nektek, kedves HUP-perek:)

Mit használsz Matlab helyett?

Nem úgy repül, hogy kifelé repült, hanem szalad, fut, megy, azaz használható.
Kicsit összeakadt a Compizzal, de itt megoldotta nekem egy hozzáértő srác.
Arra akartam utalni, hogy minden jó.

"Nem úgy repül, hogy kifelé repült, hanem szalad, fut, megy, azaz használható."

LOL. Erről ez jutott szembe:

"-eg a doboz! eg a doboz!!!
-holgyem! miaproblema!? fustol? eg? tuzet fogott? meggyulladt? langol? PIROS?"

--
trey @ gépház

Megérte googlizni. :)
--
Degradálódjunk kicsit visszább!

Hol találtad meg? Keresem egy ideje, mert letöröltem, valaki meg kérte.

--
trey @ gépház

trey: eztet hogyan "apt-get remove --purge evms" ??
nekem nem talál evms-csomagot az apt-get és állandóan fagy a rendszer...
használhatatlan, pedig frissítenék Gutsy-ra

Nem tudjátok, milyen benne a "via unichrome pro"-driver? mert a feisty nem ismeri fel restrictedként, via-val nem megy, vesa ugye baromi lassú...

Azt én openchrome driverrel hajtottam meg, amíg olyanom volt...üdv: pomm

Haverom 2 napja vett laptopot.
Ezzel a driverel kellene mennie az X-nek rajta de nem megy.
A legroszabb, hogy a Gutsy vesa driverrel nem kezeli az X-et rendessen. Szetcsuszott, vibbralo kep van. Feisty alatt tokeletes volt vesa-val.

hásszépjóestét :] upgrade megvolt, utána pár hiba volt persze alap :] node. friss install...compiz meg radeon 9600 alatt ezjó. ati driver felcsúszik a rest. managerből. aztán compiz nemmegy. okkéokkéokké...hát mit ír ki? jahhogy kompozit extensön kell! áhá! megvolt 0-t átirtam enabledre. puff x csak low res módba indul semmit nem lehetett vele kezdeni...újrahúzás...okké megy...mostjó :] nem használok kompizt és nem bsztattam az xorg.confot :]valami 5let?
-----------------------------------------
Tom B1GGY

trey, te hogy varázsoltad fel az X700-ra a compiz-t?
Én is próbáltam, de nem ment... El se indult az x, vagy ha elindult akkor belefagyott már a bejelentkezésbe is... Nekem OpenSuSE 10.2 van, KDE-t használok.
Az asztalin meg tudtam csinálni az NVidia karival (akkor még azon is 10.2 volt), de a laptop nem akart összejönni...
--
OpenSuSE 10.3, Celeron 2,4Ghz, 768MB, 2*160GB IDE Raid0, FX5200, SBLive! E400
OpenSuSE 10.2, Acer Aspire 5020, AMD Turion 64bit @ 1,8Ghz, 1GB, 80GB Toshiba, Mobility Radeon X700 PCI-E 128MB/128bit

Mint írtam, semmit nem csináltam. A feisty /etc/apt/sources.list-jében átértam a "feisty" szót "gutsy"-ra, nyomtam egy dist-upgrade-et, feltettem a 2.6.22-14-generic kernelhez tartozó restricted-modules csomagot, amelyben benne van a fglrx kernelmodulja, bekapcsoltam a Desktop Effects-t és működik. Feltettem hozzá a konfiguráló programot és azzal _nagyon_ aprólékosan be tudom állítani. Szerintem 2 nap nem elég, hogy a sok-sok opciót átnézzem, így még egy nagy alap beállítással megy.

--
trey @ gépház

Na, meg akartam próbálni megint... De kicsit ellentmodásos:
http://en.opensuse.org/Beryl
Adjam hozzá a forrást, keressek rá a "beryl" szóra, majd rakjam fel a felsorolt csomagokat...
A beryl szóra két találat van. :(
Másrészt itt (http://download.opensuse.org/repositories/X11:/XGL/openSUSE_10.2/i586/) akárhogy is nézem, nincs beryl-core, beryl-manager csomag... :(

--
OpenSuSE 10.3, Celeron 2,4Ghz, 768MB, 2*160GB IDE Raid0, FX5200, SBLive! E400
OpenSuSE 10.2, Acer Aspire 5020, AMD Turion 64bit @ 1,8Ghz, 1GB, 80GB Toshiba, Mobility Radeon X700 PCI-E 128MB/128bit

Nem értem, hogy mit keres itt az openSUSE, meg a Beryl. Ez Ubuntu. :)

--
trey @ gépház

Csak gondoltam tudsz valami okosságot mondani.... :P
--
OpenSuSE 10.3, Celeron 2,4Ghz, 768MB, 2*160GB IDE Raid0, FX5200, SBLive! E400
OpenSuSE 10.2, Acer Aspire 5020, AMD Turion 64bit @ 1,8Ghz, 1GB, 80GB Toshiba, Mobility Radeon X700 PCI-E 128MB/128bit

"Egyáltalán a KDE-n támogatott a Compiz? A Kubuntu 7.10-re is ígértek a fejlesztők out-of-the-box 3D desktop-ot?"
Nekem is ez a bajom. Megy 7.10 Kubuntu alatt a Compiz van kocka meg minden effekt megy de nem találom sehol az out of the boxot:(((((
Nem igaz hogy kihagyták belőle bakkkeeer:)
Senki nem tud erről valamit akinek sikerült beizzítania a Compozitot?

llmao

--
trey @ gépház

llmao?
szóval sehol nem találok ilyet: Workspaces on a Cube
Advanced Desktop Settingben sem:(

"de nem találom sehol az out of the boxot:((((("

Ezen nevettem.

--
trey @ gépház

ja oks:)
már ott tartok hogy advanced desktop settingnél nem enged állítgatni semmit még pipálgatni sem lehet XD
konzolból ha megindítom ki írja hogy valami sexy-python csomag hiányzik, érdekes eddig megvolt...
Egyáltalán furcsálom a csomagnevet, na mind1 mostmár még jobban elrontottam....

Hát gentoo-n pl. valóban annak hívják, az ilyen lehetetlen disztrókra, ahol nem képesek az eredeti csomagnevet megtartani, nem gondol senki. Ubuntu alatt fordítva írandó a neve, python-sexy. És nem azért mondják ennek, mert a python szexy lesz tőle, hanem mert a libsexy csomag python bindingje.

üdv értem!
tomcsi1987@Matrix:~$ ccsm
Info: No sexy-python package found, don't worry it's optional.
Szóval így tájékoztat hogy valami nem oké és ezért nem tudok állítgatni:(
De eddig megvolt a csomag? Akkor hova a ..... ba lett?!
Magától csak úgy elveszett vagy megunta hogy állítgatom egész délután?:) - és mondja magába haggyon már engem a fenébe a hülyeségeivel:)

"Info: No sexy-python package found, don't worry it's optional."

Konkrétan ide az van írva, hogy nincs sexy-python csomag, ne aggódj, opcionális. Teszem fel, ha opcionális, akkor azt jelenti, hogy ettől még működnie kéne.

--
trey @ gépház

üdv értem.
Na azért felment a csomag ,a phython sexy. De még mindig nem enged semmit bepipálni meg semmiről levenni a pipát.
Nem is ír rá semmit olyan mintha valami Bug lenne.
Ötlet?
De pl a vízszintes virtuális méretet meg ilyeneket enged szabályozni.
De pipákat luxus fura

Nem lehet, hogy balra a nagy kéken kikapcsoltad az Enable ... felíratú pipát?

Üdv!
Megvan a hiba véletlen levette a pipát a preferences>plugin list> automatic plugin sort ról és ezért nem akarta hogy pipáljak...
Én meg már bugos stb, ejj de útálom az ilyen embereket:)
Most útálom magam, én nem figyeltem és az volt a hiba...

apt-get install outoftheboks-ot próbáltad már? ;)
--
Degradálódjunk kicsit visszább!

python-sexy.
felraktam neki ezt és már nem is írja a hibaüzit.
De állítgatni még mindig nem enged semmit.
Mit ronthattam el ennyire?:)

Gnome alatt a compizconfig-settings-manager csomag kell hozzá.
--
Degradálódjunk kicsit visszább!

Üdv értem.
Ez a csomag nálam fennt van.
Ez lenne az Advanced desktop effect setting igaz?
De itt hol található meg a workspaces on cube???
Mert én nem találom sehol pedig átnéztem már az egésszet:(

Az egy másik utility. Ebben nincs olyan, de nem is kell. Ha ezt használod, akkor Desktop Cube, Rotate Cube.

--
trey @ gépház

Üdv oksa köszy:)

A telepítés elég símán lement, bár voltam olyan bolond, hogy valószínűleg a legnagyobb csúcsidőben tettem ezt, így 2x neki kellett futni. Vannak azért komoly és kevésbé komoly gondjaim.
1) az Ubuntu 7.04-től nem ismeri meg bootolás után a billentyűzetet. a 6.10-es-nél semmi gond nem volt még, de a 7.04, és a pont ezen hiba miatt nagyon várt 7.10 is ezt teszi.
A helyzet érdekessége(!?), hogy amennyiben a billentyűzet dugaszát a bootolt rendszernél ki majd visszadugom a kapcsolat megjön... Egyébként más oprendszer (os/2) alatt a billentyűzetnek semmi baja, sőt Kubuntu alatt sem észlelhető ez a hiba. Állítottam már ACPI típusra, meg nemzetközi 102-re, 105-re, de semmi sem változott.
Ötlet, tipp?
2) a vizuális effektek nem igazán mennek Matrox G550 kártyával, pedig a hardverigény alapján ennek működnie kellene. Javaslat?
3) telepítés után lett az Alkalmazásokban egy Egyéb gyüjtő, ami tele van -kivétel nélkül- KDE-s részalkalmazásokkal. Erre szükség van? A Gnome gyakorlatban mindent tartalmaz, ami itt előfordul...

A tanácsokat előre is köszönöm,
_________
warp

"1) az Ubuntu 7.04-től nem ismeri meg bootolás után a billentyűzetet. a 6.10-es-nél semmi gond nem volt még, de a 7.04, és a pont ezen hiba miatt nagyon várt 7.10 is ezt teszi."

Ezt azért erős így kijelenteni, hiszen milliók használják az Ubuntu-t billentyűzettel. A helyes megfogalmazás: a te billentyűzeted nem ismeri. Esetleg elmondhatnád, hogy milyen billentyűzetről van szó.

"2) a vizuális effektek nem igazán mennek Matrox G550 kártyával, pedig a hardverigény alapján ennek működnie kellene. Javaslat?"

Google.

"3) telepítés után lett az Alkalmazásokban egy Egyéb gyüjtő, ami tele van -kivétel nélkül- KDE-s részalkalmazásokkal. Erre szükség van? A Gnome gyakorlatban mindent tartalmaz, ami itt előfordul..."

Jobb klikk az "Alkalmazásokon" -> "Edit menus" (magyarul nemtom mi) -> Egyéb-ből pipa kivesz

--
trey @ gépház

Idézet:
"Edit menus" (magyarul nemtom mi)

Kapaszkodj meg erősen: "menük szerkesztése". :)

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Nem mondod. Sejtettem, hogy ilyesmi, de mive a pontos fordítást nem tudtam, nem mondtam. Mert akkor az lesz a következő, hogy "de olyan nincs is nekem" ;)

--
trey @ gépház

"Ezt azért erős így kijelenteni, hiszen milliók használják az Ubuntu-t billentyűzettel. A helyes megfogalmazás: a te billentyűzeted nem ismeri. Esetleg elmondhatnád, hogy milyen billentyűzetről van szó."

Annyira már tájékozódtam -levlisták, sőt Ubuntu.hu-, hogy a probléma, ha nem is tömeges :-), de nem teljesen egyedi... és nekem nagyon kellemetlen...
A billentyűzet PS/2, Genius KB-06X

Köszönöm
_________
warp

Állítólag segít:

"So I think the solution is to disable USB legacy support, USB IRQ settings, or direct USB keyboard support, or whatever your flavor of BIOS calls this crap."

Valószínűleg bugos BIOS, vagy egyes hardverek rossz együttélése lehet az oka.

--
trey @ gépház

> ... vagy egyes hardverek rossz együttélése lehet az oka.

Akkor most keressen közvetítőt, aki kibékíti őket? :D

Első körben én megpróbálnám letiltani amit javasoltak, majd ha az sem vezet eredményre, akkor egy teszt erejéig más gyártó billentyűzetével próbálkoznék. Utána még mindig lehet szexuálpszichológushoz fordulni :)

--
trey @ gépház

Nem USB-s a billentyűzet. Ettől függetlenül az USB környékét kellene állítani?
Ráadásul a 6.10.-nél nem volt ez a hiba, azóta bugos lett volna a BIOS?...

Két másik gyártó billentyűzete A4, Samsung ugyanígy viselkedett (ezt természetesen még első alkalommal kipróbáltam), de a rendszer lelkivilágát érintő beavatkozások erősen visszatartó erejűek ;-)
_________
warp

Igen, mert valószínűleg a BIOS beállítások miatt USB-s billentyűt detektál a PS2 helyett.

"Ráadásul a 6.10.-nél nem volt ez a hiba, azóta bugos lett volna a BIOS?..."

Elnézésedet kérem, csak tippeket adok, és nem a múltba / gépedbe / bármibe akarok látni. Ha nem vagy kíváncsi a segítségre, be is fejezhetjük. A "valószínűleg" magyar szó jelentése: "lehet, de nem biztos".

--
trey @ gépház

Nem biztos, hogy a kérdésem sértő számdékú! Sőt, fakad abból, hogy nagyon kezdő vagyok a linuxban.
Ezek után tényleg naív és bátortalan kérdés: ha mondjuk más oprendszer alatt a bill. felsimerése korrekt, akkor most linuxban azért lehet hibás? És, ami a legjobban foglalkoztat: a bill. csatlakozójának ki-be dugdosása miért állít/hat/ja helyre a kapcsolatot?...
_________
warp

"ha mondjuk más oprendszer alatt a bill. felsimerése korrekt, akkor most linuxban azért lehet hibás?"

Természetesen lehet. Lehet a Linux kernel is hibás. De lehet bugos a hardver is és elképzelhető, hogy más OS-ben erre a problémára már készítettek áthidaló megoldást, workaround-ot és ezért nem találkozol vele. Valószínűleg - mivel nem mindenkit érint - leszűkíthető egyes alaplap / PS2 billenytűzet együttállásra, illetve talán kijelenthető, hogy gyártó termékétől függő hiba. Távolról erről többet nemigen lehet mondani.

További hibakeresés billentyűzet nélkül mondjuk soros porti konzolon, ssh kapcsolaton keresztül (ha fut az sshd), vagy a hdd filerendszeren található logfile-ok (már ha van rajta OS és be tudsz boot-olni vele) valami módon történő elemzésével lehetséges.

--
trey @ gépház

> más oprendszer alatt a bill. felsimerése korrekt, akkor most linuxban azért lehet hibás?

A kérdésben a válasz. Más oprendszer.

> És, ami a legjobban foglalkoztat: a bill. csatlakozójának ki-be dugdosása miért állít/hat/ja helyre a kapcsolatot?

Azért, mert ilyenkor újra lefut a detektálás, de most a BIOS beállításai nem vevődnek figyelembe.

Az a tippem, hogy a billentyűzet beállításait a BIOS-tól veszi fel a lin, mert az kritikus eszköz, és ha odaért a bootban, kiszedi a korábbi dolgokat, és újradetektálja a bill-t. Hogy eddig miért ment, nem tudom. Talán kernel hiba, az újradetektálás nem fut le korrektül, és a BIOS beállítás marad meg. De ezek csak tippek, nekem a kernel fekete doboz. Vannak itt kernel hackerek, majd ők elmagyarázzák a frankót.

>Azért, mert ilyenkor újra lefut a detektálás, de most a BIOS beállításai nem vevődnek figyelembe.

Akkor ezen a vonalon menve lenne további kérdésem:
1) A BIOS-ban kétféle beállítás lehet a BIOS vagy az oprendszer kezelje a billentyűzetet. Melyiket?

2) A billentyűzet kiosztás modellje normális esetben mi legyen? ACPI vagy, ami a fizikai létéből következik pld. nemzetközi 105 gombos?

>Hogy eddig miért ment, nem tudom.
A UB 6.10-essel gond nélkül ment és upgrade után az se segített, hogy a 7.04-es xorg.conf-ba a 6.10-esnek megfelelő bill. paramétereket írtam

>Talán kernel hiba, az újradetektálás nem fut le korrektül, és a BIOS beállítás marad meg.
Olyat is próbáltam, hogy nem volt a billentyűzet rádugva boot alatt és csak a felállás után lett "megdugva" a gép. Ekkor is azonnal működött a billentyűzet...

Egyébként kösz az agyalást.
_________
warp

"Jobb klikk az "Alkalmazásokon" -> "Edit menus" (magyarul nemtom mi) -> Egyéb-ből pipa kivesz"

Ezt külön köszönöm, amely bonyolult művelet eddig eszembe nem jutott volna... :-( Sorry....
_________
warp

Belefutottam egy probléma Gutsy alatt, talán tudtok segíteni.
Egy Linuxot futtató iPAQ -t szeretnék összekötni az Ubuntus asztali gépemmel, hogy USB -n keresztül hálózatot hozzak össze a két gép között, mivel egyelőre más módon nincs rá lehetőség.
Betöltöttem az "usbnet" modult, később próbaképpen még a "cdc_ether" modult is, de az asztali gépen nem jött létre az "usb0" hálózati interfész.

Ha az iPAQ -ot összekötöm a kábellel az Ubuntuval, a dmesgbe a következő kerül:

usb 1-1: new full speed USB device using uhci_hcd and address 18
usb 1-1: device descriptor read/all, error -110

Az "lsusb" pedig csak ennyit mond az eszközről:
Bus 001 Device 001: ID 0000:0000

Van valakinek valami ötlete, hogy mi lehet a gond? Hiába kerestem a Google -val eddig, nem találtam semmi érdemleges információt.
Köszönöm a segítséget! :)

Ui.: Betöltöttem az "usbnet" modul elött az "ipaq" kernelmodult is, de az sem vezetett eredményre. :(

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Közben kipróbáltam a frissítésből megmaradt Feisty -s kernellel, és azzal is ugyanezt a hibát produkálja... attól tartok, ez így nem fog működni soha, akkor marad a soros-port, ami vagy összejön, vagy nem... a sebessége pedig... :S

-----
"Egy jó kapcsolatban a társunkat az ő dolgában kell támogatni, nem a miénkben."

Nekem nem kelett hack a vmware-hez,a legujabb csomag mar megoldja a problemat (6.0.1 build-55017),es gond nelkul lefordul.Ami nekem problemat okozott hogy az nfs nem ment reboot utan,mondjuk ez benne is van a release notes-ban.
egyebkent +1 a gond nelkuli upgrade-nek

"Nekem nem kelett hack a vmware-hez"

A verziószámát meg tudnád mondani? Nekem azt mondja webes frissítője azt mondja, hogy nincs újabb, ellenben ez meg nem fordul le eredeti állapotban. Nekem 6.0.0 build-45731 van. Igaz, megnézhetném a weben is...

Szerk: tárgytalan, van újabb. 6.0.1 for Linux build 55017

Köszi.

--
trey @ gépház

--- téves beírás ---
(Kár, hogy nincsen egy Törlés lehetőség is...)
_________
warp