[MEGOLDVA] hálózat beállítása(dhcp) (nagyon kezdő!!!)

Sziasztok!

UHU linux 1.2-öm van és sajna valamiért nem tudom belőni a hálózatot, internetet. Már sok disztribúcióval próbálkoztam, de egyikkel sem ment. routerem van ,DHCP-s ip kiosztással. már próbálkoztam az ifconfigos paranccsal meg pár fogással amit fórumokban találtam. A másik gépemen hip-hop megtalál mindent magától, ha ugyanúgy állítom be - persze a címek mások - akkor sem megy.Windows alatt minden jól működött.
A router admin felületét sem érem el és a pingelés sem megy...
Ha beállítom az ifconfig paranccsal: eth0-t létrehozom , amúgy csak lo van, megadom neki a gép ip címét amit elvileg kiosztana neki a router(192.168.0.169), a broadcastot(192.168.0.1, próbáltam már ...255-tel is) és a netmaskot(255.255.255.0), de sajnos nem megy. Újraindításkor meg elfejeti ezeket és mindent kezdhetek előről. :(

Megköszönném, ha valaki leírná nekem lépsről-lépésre, hogy mit kéne tennem...már szívok vele egy-két hete. :(

Köszönöm:Token

Hozzászólások

Szia!
Köszi a segítséget...

ezt adta ki:

eth0 Link encap:Ethernet HWaddr 00:60:97:2D:00:B3
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Base address:0xe400

imq0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-E4-00-00-00-00-00-00-00-00
NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:30
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

imq1 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
NOARP MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:30
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:65 errors:0 dropped:0 overruns:0 frame:0
TX packets:65 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:4666 (4.5 Kb) TX bytes:4666 (4.5 Kb)

sit0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

a down&up után pedig:

Ethernet hálózati csatoló aktiválása: eth0...

nincsen /etc/network-öm sem:((( ezgonolom elég nagy baj...

tOkEN

Nem tudom, hogy az okozza-e; egy UHU használót kellene keríteni, aki meg tudja mondani, hogy hol tárolódnak a hálókártya beállítások. Ha a routeren fix ip-t rendelsz a hálókártyád MAC-jéhez, majd uhu-ban pl. ifconfiggal beállítod ezt az ipcímet a hálókártyának, akkor sem működik? (feltéve ha tudja a router)
Milyen gyártmány/típus is az a router? Hátha...

--
A gyors gondolat többet ér, mint a gyors mozdulat.

Nekem meg DI-624 :) szintén static dhcp. De nálam kap ip-t a hálókártya. Átjáró az a router ip címe (gondolom 192.168.0.1) (ezeket használva a /etc/network/interfaces fájlban mindössze egy "auto eth0" és egy "iface eth0 inet dhcp" sor van a hálókártyámhoz.

--
A gyors gondolat többet ér, mint a gyors mozdulat.

ifconfig eth0 192.168.0.169 netmask 255.255.255.0 broadcast 192.168.0.255
Default gateway-t megadtad?
It doesn't matter if you like my song as long as you can hear me sing

kernel IP routing table

Destination_______Gateway______Genmask________flags_metric_ref_use_iface
192.168.0.0_______*____________255.255.255.0__U_____0______0___0___eth0
127.0.0.0_________*____________255.0.0.0______U_____0______0___0___lo
default___________192.168.0.1__0.0.0.0________UG____0______0___0___eth0

Win alatt válaszol a router a ping -re ?

3com kari ugye ? Azon belül ?

token: [code] [/code] amit keresel, ekkor nem bassza el whitespaceket ( formázást).

lspci -nn
Ide vonatkozó sora lehet érdekes. Bár 3Com gebaszrol nem tudok.

pump/dhclint/dhcpcd vagy mid van.., nem ad IP -t ? (/var/log/messages -ben nyoma van hogy nem kap IP -t, vagy Ctrl+F12 (+alt), remélhetőleg neked is console remélhetőleg dhcp cliens megmozdulási ott látszanak)

Hálókártya lámpái mit jeleznek ? Zöld világít kéréskor/pingeléskor a sárga (amber) villog ?

A másik gép -et sem tudod pingelni és ő sem téged ?
iptraf -od van ?

Az IP cím utolsó szemjegye egyedi ugye minden node-nál (router+gépek)? :)

sudo dhclient eth0
Erre mit mond?

Udv!

lspci -nn |grep Ether kimenete érdekel.

Egy haveromnál (dual-boot) olyan fordul elő, hogy a nootbokján, ha windows hibernálja, és Linuxot bootol akkor ugyan ezt tapasztalja. Ha átlép windowsba ott megy, és ha nem hibernál hanem rendesen leálítja akkor Linux alatt is megy.

mii-tool, ethtool -al talán át lehet billenteni normális állapotba.

1. Kellene egy aktualis kep ezekrol:
ifconfig eth0
mii-tool
ethtool eth0
route vagy netstat -r

2. Ha az mii-tool kezeli a kartyat, es azt mondja, hogy van link es/vagy az ethtool kezeli a kartyat es azt mondja, hogy van link, akkor:
ifconfig eth0 192.168.0.169 netmask 255.255.255.0

3. Ezutan probald megpingelni a routert (192.168.0.1)
Kimenettol fuggetlenul probald megpingelni a masik (mukodo windows-os) gepet.

4. Ha megy a ping, akkor ird be ezt:
route add default gw 192.168.0.1

Kivancsi vagyok a kimenet(ek)re, es hogy melyik pontnal akad el.

Yndy

dmesg, error és eth ami érdekes lehet, megszakitás (IRQ,Interrupt) ütközés ilyesmi.

vortex.txt

Ha kiszeded, a drivert aztán vissza teszed rmmod/modprobe akkor írhat okosságokat, főleg, ha debug paramétert is beírod.

PCIid vendor:model pl. [10ec:8029] ezért lenne fontos, mert kő kockák -e szerint azonosítják a hardvert és googlibe beírva remélhatőleg akad valami okosság róla.

"csak a ping -b 192.168.0.255"
Ez alatt mi ertesz?
Ezt probaltad?
Az arp -a kimenetet meg le tudod irni?

"nem világít, de nem tudom miért nem"
Akkor nincs link, gondolom a kartyan sem vilagit.
Akkor vagy nem kezeli a kartyat rendesen, vagy kicsusszant a kabel, vagy rossz a router port, vagy rossz a kabel, vagy rossz a kartya.
Amig nem latsz vilagito led(ek)et, addig nem lesz "ping"-ed szerintem...

"ifconfig eth0:
link encap:ethernet HWaddr: 00:60:97:2D:00B3
inet addr 192.168.0.169 basct: 192.168.0.255 mask:255.255.255.0
UP BROADCAST RUNNIG MULTICAST "

Ez jonak tunik, de a tobbi reszere is kivancsi lettem volna, plane ha pingeltel (tehat forgalmat toltal a kartyara). Annak latszania kell legalabb a "TX"-en...

Yndy

arp:

? (192.186.0.127) at(incomplet) on eth0
? (192.168.0.1) at(incomplet) on eth0

a pinget próbálgattam és csak ez működik, a broadcast.

TX-en van egy packet, 0 error, 1 overrun, 0 dropped , az RX-en pedig 0 0

szerintem akkor a linkelés lehet probléma, mert modom win-ben működik
a kártya sem világít :$

Token

Mielőtt lelépnék..

Kuvára valószínünke tartom, hogy kártyának van egy olyan regisztere ami disablési a Link -et, az boot time nem áll enablére.
- Windows fenti példám szerint állíthatja ilyen állapotba a kártyát
- Ez egy ismert bug, amit legujabb kernelben javítottak gutsy gibbon distróban van jelenleg legujabb kernel AFIK, try this. vagy forgatás.
- mii-tool must, have hogy regisztert manipuláljunk vagy reseteljuk .. etc.
- manufacturer:model id -t még mindig nem láttuk, ami jó volna.

bye

Es ha disable-zi a linket, akkor nem alszik ki a LED?
Mert elobb minta azt irta volna, hogy most mar vilagit a routeren is es a kartyan is.
Viszont ha vilagit, akkor vagy enable-ben van, vagy a disable-ra nem alszik ki. Mindenesetre kivancsi lennek, hogy azota mi a helyzet. Volt mar ping?

Yndy

Nem lehet, hogy akabellel van valami gond, vagy a ket vegen a csatlakozoknal? Nem tudod kicserelni a kabelt?
Az rmmmod es a modprobe utan - szerintem - ujra kell IP-t adni az interfesznek. Most aktualisan van neki IP-je? Es most per pillanat vilagitanak a LED-ek?

Yndy

A 99% nem eleg egy halozati kabel eseten :)
Persze hogy nem a router-tol veszi az IP-t, ha Te adod meg neki.
Annak a feltetele, hogy a router-tol kapjon, hogy fusson rajta a dhcp KLIENS. Nem tudom, hogy UHU-nal mi a kliens neve, de - amint korabban mar turul irta - lehet pump, dhclient vagy fene tudja. Az a kovetkezo lepes lenne, ha mar megy a ping. De amig a kezzel beallitott dolgokkal nem jon ossze a halozat(ping) addig hagyjuk a dhcp-t es a tobbi "automatikus beallitas" dolgot. Elso korben mukododkepes allapotra kellene hozni, aztan majd utanna beallitod, hogy a gep ujrainditasa utan "belenyulas nelkul" mukodjon a halozat.
Igen, a villogas legtobb esetben a halozati forgalmat jelenti.
A ping-elest azota probaltad?
Gondolom nehet allandoan egyik geprol leolvasni, aztan a masikon begepelni az adatokat, de azert sokat segitene idonkent, ha pl. AKTUALIS ifconfig, arp -a, meg egyeb - turul altal is emlitett - kimeneteket kapnank.
Egyebkent nincs veletlenul skype-od, mert egyszerubb lenne szerintem... Hanem egesz estig irogatunk itt a forumban, es nem biztos, hogy a vegen lesz megoldas... :)
Vagy IRC, vagy barmi interaktivabb...

Ment privi is...

Yndy