melyik gcc-t gentoo amd64 alá?

 ( emberk | 2006. május 31., szerda - 17:09 )

Üdv!

A kérdés egyértelmű nem akorom a lehető leg frissebb csomagokat stb, csak azt szeretném, hogy miden leforduljun a gépemre a jelenlegi 3.4.5-ös egy csomó csomagot nem fordít le emake hibával vagy src_compile error-al kihal egyértelműen gcc hiba van valakinek tapasztalata régebbi vagy újabb C-fordítókkal? Én inkább a 3.3-as irányba hajlok mert a 4.x-esek még nagyon kiforratlanok. Ötletetek van?

Ui:most nézem hogy 3.3-as széria nem is támogartja a 64-bites utasításkészeletet akkor marad tovább a kérdés a 3.3-as nélkül

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

A válasz nagyon egyszerű:

bash# ACCEPT_KEYWORDS="~amd64" emege gcc

és kapsz 4.1.1 -et, minden lefordul, gyors, stabil, kész.

Csak gcc-4.x.x
A 64 bit volt a legfőbb érv a főverzió-ugrásra, ha jól tudom.

Aleph

Tudtommal a gcc4.x lassabb kódot generál amd procis gépekre, mint a gcc3.x.
Jó lenne lemérni vhogy.

Szerintem a gcc4-essel forgatott cuccok gfyorsabbak valmivel de nem mérvadó engem az érdekelt hogy forduljon le egy csomó progi mert a 3.4.5-ös szerintem hibás és leáll a fordítás. 4-5%-ért nem fogok vacakolni a 2-3napig.

Ez a gyorsabb kódos téma néha kikészít. Ha nem fut, és hackelni kell napokig, teszek én a +- 5%-ra.

Én is ezt mondom.

Rémlik, hogy vki kimérte egyszer a 3.4-est és a 4.0-ást, és a quicksort 1,5 szer gyorsabban ment 3.4-essel.
Nekem egyébként 3.4.3-assal megy most a gentoo amd64-en.

És lefordul vele minden?