Érdekes ADSL probléma

 ( Dr_Mac | 2005. augusztus 31., szerda - 13:03 )

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Erdemes meg az MSS-sel (Maximum Segment Size) kiserletezni.

Az MTU azért kisebb, mert a nyers csomagra még rájön a pppoe fejléce is (talán 8 byte).
Amíg a csomagok mérete nem haladja meg az 1492 byte-ot (pl. gépelgetsz ssh-n keresztül), addig nem lesz gond, viszont amikor intenzív átvitelt csinálsz (pl. file-okat mozgatsz, böngészel, stb.), akkor a kliensed 1500-asával próbálja küldeni, de minden visszapattog, mert az adsl csak 1492-esével tud küldeni.
Erre van kitalálva az "mss clamping" nevű dolog, netbsd-n úgy engedélyezheted, hogy a /etc/ipnat.conf-ba beírod, hogy:
[code:1:0531521d9d]
map pppoe0 192.168.0.0/24 -> 0/32 portmap tcp/udp auto mssclamp 1440
map pppoe0 192.168.0.0/24 -> 0/32 mssclamp 1440
[/code:1:0531521d9d]
(Itt a 192.168.0.0/24 a helyi hálóm, az 1440 pedig a beállítandó mtu. Valahol olvastam, hogy érdemes ráhagyni, mert jöhet még rá menet közben pár egyéb fejléc is.)
Linux alatt ugyanez (thx Folti) :
[code:1:0531521d9d]
iptables -A FORWARD -p tcp --tcp-flags SYN,RST SYN -j TCPMSS --clamp-mss-to-pmtu
[/code:1:0531521d9d]
Érdemes guglin utánakeresni az "mss clamping" ill. az "mtu discovery" kifejezéseknek.

Tapasztaltabb kollégák ötleteit, segítségét kérném.

Adott egy Axelero ADSL előfizetés Invitel területen, ami DSL routeren keresztül 3 gépet szolgál ki. Másodszor fordul elő az alábbi probléma:
- gépet bekapcsolom, router ad neki IP-t
- router felépíti a pppoe kapcsolatot
- böngészőbe beírok egy címet, megtörténik a névfeloldás, majd semmi (alul üzenet: adatok fogadása xxxxx felől....)
- elindítom a levelezőt, megtörténik a névfeloldás, bejelentkezik a szerverre, majd semmi (üzenet: levelek letöltése a kiszolgálóról...)
- indítok egy ftp-t, névfeloldás rendben, kapcsolat létrejön, adatmozgás nulla
- viszont a p2p kliens szépen dolgozik (Bittorrent), traceroute jó

Először a routerre gyanakodtam. Ezért az egyik gépet közvetlenül rádugtam a modemre, felraktam egy pppoe klienst, de a jelenség ugyanez. Aztán egyszercsak varázsütésre minden megjavult.

Beszéltem a supporttal, de sajnos az "Indítsa újra a számítógépet" tanácson kívül más segítséget nem kaptam.

Ötlet, tapasztalat?

Mit látsz, ha tcpdump-al nézed a forgalmat?
Fri

Ez még nem jutott eszembe, de legközelebb kipróbálom.

Az a baj, hogy a hiba nagyon esetleges (eddig kétszer fordult elő) és először akkor jött elő, mikor éppen nem voltam a gépek közelében.

valoszinuleg a fajlcserelon is csak a adott szolgalton beluli userektol tudtal tolteni, szoval csak a szolgaltaton belul erted el a dolgokat

lehetseges hogy nem, de valoszinunek tartom :)

tisztára mint a Monornetnél néha... :)

Ugye nem ilyen csoda Huawei adsl modemed van? Azzal napok ota sz*pik a matav :D

[quote:0074a56593="Sea-you"]Ugye nem ilyen csoda Huawei adsl modemed van? Azzal napok ota sz*pik a matav :D[/quote:0074a56593]

Nem. Nekem egy hasonló területről származó ZTE modemem van (Invitel ebből vásárolt be egy nagyobb tételt).

Tedd alacsaonyabbra az MTU-t a routeren a kimno kapcsolat fele. Mar nekem is volt ilyen. Csak bizonyos honlapokat engedett bongeszni. Nalam most 1458-ra van belove, de pl az egyik baratomnak AOL van otthon, neki 1400 a tuti. Kiserletezzel vele, ha szakadozik a vonal akkor is vedd lejjebb.

Udv

Rigidus

[quote:e2b247788a="rigidus"]Tedd alacsaonyabbra az MTU-t a routeren a kimno kapcsolat fele. Mar nekem is volt ilyen. Csak bizonyos honlapokat engedett bongeszni. Nalam most 1458-ra van belove, de pl az egyik baratomnak AOL van otthon, neki 1400 a tuti. Kiserletezzel vele, ha szakadozik a vonal akkor is vedd lejjebb.

Udv

Rigidus[/quote:e2b247788a]

Érdekes ötlet, meglátjuk. Kösz.

Sziasztok,

Nekem is az jutott eszembe, hogy esetleg az MTU lehet a problema (tul nagy csomagok ilyenkor nem jutnak at). Anno nekem is volt ezzel problemam, es az akkori DSL szolgaltatot konkretan meg tudta mondtani, hogy a matav 1452-re allitja ezt az erteket (tehat a standard 1500 nem jo).

Nem tudom mit nyernek ezen, viszont, mi eleg sokat vesztunk rajta ha nem allitjuk utanuk.

Hijaszu

Azért érdekes ez az MTU dolog, mert az ADSL lassan egy éve megy gond nélkül. A leírt hiba először múlt héten jelentkezett, majd másodszor ma reggel. Nem tudom. Mindenesetre megnéztem a router konfigját, itt alapban 1492 van beállítva. Lehet, hogy lejjebb veszem, aztán meglátjuk.