GRUB: "error: symbol 'grub_register_lockdown_command' not found"

Fórumok

Hello,

 

pár hónapos Debian 10, 2 SATA diszk, RAID 1. Sima upgrade után reboot, és a GRUB bootolni próbálna, de a subject-ben látható üzenetet kaptam.

Google - meglepő módon - nem adott találatot.

Ismét restartoltam a gépet, BIOS-ban megváltoztattam a diszkek sorrendjét, most bebootolt. Kipróbálom majd, hogy mit csinál, ha visszaállítom, de nem igazán értem a jelenséget.

 

Van valakinek ötlete, mi lehet ez?

Hozzászólások

Köszi,

 

érdekes, mert a diszkek sorrendjén egyáltalán nem változtattam, mióta átvettük a szolgáltatótól (bérelt vas), és pár reboot volt már.

Amúgy szoktam telepíteni MBR-t mindenhová - lehet, hogy most kihagytam valami oknál fogva, de az akkor sem világos, hogy eddig hogy bootolt be a gép.

És RAID1 alatt hogyan lehet grub reinstallt csinálni live usb-vel (ubuntu vagy debian)? Nekem is sajnos ez a hibám és a HDD sorrend csere sajnos nem segített.

Hello,

 

a kérdésből ítélve még nem csináltál ilyet - annyira nem bonyolult, de nem árt figyelni ("nem egyszerű, de triviális" :)).

  • bebootolsz, indítasz egy shellt
  • ha LVM van, aktíválod a köteteket (vgscan, vgchange -a)
  • szerintem itt már felismeri a rendszer a raid-et, nem kell külön összeállítanod
  • felcsatolod a /-t, pl
    • mkdir /mnt
    • mount /dev/root/eszkozod /mnt
  • ha külön van a /usr, akkor azt is
    • mount /dev/usr/eszkozod /mnt/usr
  • felcsatolod a /proc fs-t
    • mount -t proc proc /mnt/proc
  • felcsatolod a dev-et (ua)
  • lehet, hogy kell a sys is, ezt fejből nem tudom
  • chroot /mnt
  • dpkg-reconfigure grub-pc
  • kilépsz a chroot-ból (CTRL-d, exit...)
  • lecsatolsz mindent (sys, proc, dev), a végén a /-t is
  • reboot

Ha kihagytam valamit, bocs, remélem valaki kijavít :).