[Megoldva] Mikrotik failover script

 ( sfeher | 2018. június 19., kedd - 12:36 )

Hello,

Nem tudok rájönni, hogy miért nem húzza fel a ppp-mobilnet nevű interfészt (ez a 0-ás). No such item van egyfolytában.
Kézzel természetesen simán megcsinálja. Próbáltam az interfész nevével is, de nem segít.


[admin@MikroTik] /interface> pri
Flags: D - dynamic, X - disabled, R - running, S - slave 
 #     NAME                                TYPE       ACTUAL-MTU L2MTU  MAX-L2MTU MAC-ADDRESS      
 0  R  WAN                                 ether            1492  1520       2026 CC:2D:E0:3B:CC:5D
 1  R  WIFI ether5                         ether            1500  1520       2026 CC:2D:E0:3B:CC:61
 2  RS ether2-master-local                 ether            1500  1520       2026 CC:2D:E0:3B:CC:5E
 3   S ether3-slave-local                  ether            1500  1520       2026 CC:2D:E0:3B:CC:5F
 4   S ether4-slave-local                  ether            1500  1520       2026 CC:2D:E0:3B:CC:60
 5  R  LAN-bridge                          bridge           1500  1520            CC:2D:E0:3B:CC:5E
 6  X  ovpn-out1                           ovpn-out                               02:A5:A2:91:24:8E
 7  X  ;;; mobilnet
       ppp-mobilnet                        ppp-out   
 8  R  vlan100                             vlan             1500  1516            CC:2D:E0:3B:CC:61
 9  R  vlan200                             vlan             1500  1516            CC:2D:E0:3B:CC:61


 
:if (([/ping 8.8.8.8 interface=WAN count=5] >0 &&  [/ping 1.1.1.1 interface=WAN count=5] > 0) ) do={
    :if ([/interface  ppp-client get value-name=disabled number=0]=false) do={
        :if ([/ping 8.8.8.8 interface=ppp-mobilnet count=5]  > 0) do={
            :log info "Mobilnet backup link."
         }
    } else={
      /int ppp-client set numbers=0 disabled=no
      /system routerboard usb power-reset duration=3s
 }
} else={
   :if ([/interface  ppp-client get value-name=disabled number=0]=false) do={
        :log info "Primary restored, down mobilnet.."
        /int ppp-client set numbers=0 disabled=yes
    }
}

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Írd ki, hogy /interface, mert a shell ezt kiegészíti, de a script futáskor szerintem nem. :)
--
"Sose a gép a hülye."

Kipróbáltam, jogos. Sajnos így sem működik. Az alábbi egysoros csak második futtatásra kapcsolja be az interfészt.
/interface ppp-client set numbers=0 disabled=no
Felrakom mindjárt az új firmware-t és megnézem azzal is.

biztos, hogy number_s_?

Igen, biztos. Kiderült közben, hogy a Winbox run script nem a barátom. Meg a /system script -be copy/paste-olt script sem :(. Bakker. A run paraccsal azt csinálja amit szeretnék.