FreeBSD 9.1-RELEASE

 ( trey | 2012. december 30., vasárnap - 20:10 )

A FreeBSD Release Engineering Team nevében Ken Smith az imént bejelentette a FreeBSD 9.1-RELEASE elérhetőségét. Főbb újdonságai, jellemzői:

  • New Intel GPU driver with GEM/KMS support
  • netmap(4) fast userspace packet I/O framework
  • ZFS improvements from illumos project
  • CAM Target Layer, a disk and processor device emulation subsystem
  • Optional new C++11 stack including LLVM libc++ and libcxxrt
  • Jail devfs, nullfs, zfs mounting and configuration file support
  • POSIX2008 extended locale support, including compatibility with Darwin extensions
  • oce(4) driver for Emulex OneConnect 10Gbit Ethernet card
  • sfxge(4) driver for 10Gb Ethernet adapters based on Solarflare SFC9000 controller
  • Xen Paravirtualized Backend Ethernet Driver (netback) improvement
  • hpt27xx(4) driver for HighPoint RocketRAID 27xx-based SAS 6Gb/s HBA
  • GEOM multipath class improvement
  • GEOM raid class is enabled by default supporting software RAID by deprecated ataraid(8)
  • kernel support for the AVX FPU extension
  • Numerous improvements in IPv6 hardware offload support

Részletek a bejelentésben.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

osszekaptak magukat a fijugg a vilagvegere

Azt már lekésték. :)
______________________
Normális HUP-ot használok!

masik sw-nel olvastam, hogy ez az utolso release. Azt hittem, hogy tenyleg befejeztek, aztan leesett...
--
zsebHUP-ot használok!

Csak megoldottak, hogy az uj evet frissitessel kezdjem :-)
Hm. Valaki mondjon mar valami hivatalosnak tunot a binaris csomagok hasznalatarol. Se a 9.0, se a 9.1 relnotes-ban nem latom, hogy a pkgng lenne a hivatalos. Ellenben a szokott helyen (ftp://..../ports/packages/packages-9.1-release) nincsenk binaris csomagok. Akkor most mi a jo isten haragja van? (Amugy egy i386 es egy amd64-es gep is latszolag fajdalommentesen update-elodot, eddig jo.)

http://wiki.freebsd.org/pkgng/CharterAndRoadMap

itt ezt írják a táblázatban:

30 Dec 2012 - 9.1-RELEASE - Announce deprecation of pkg_tools in 9.1 release notes, in advance of 9.2 and 10.0 releases. Last ever release with pkg_tools as default

Kösz, bár ezen az oldalon ugyan leírták, ellenben most újra megnéztem, és a kiadási megjegyzésekben változatlanul nem találok semmit a pkg / package keresőkifejezéssel.

Arról már nem is beszélve, hogy nem vagyok képes frissíteni a csomagjaimat. Mivel valahol azt írják, hogy a pkg parancs - ha hiányzik a port-fa -, akkor a távoli repóból dolgozik, az egyszerűség kedvéért letöröltem a teljes /usr/ports-ot. Felraktam a pkg csomagot, volt pkg2ng, pkg update de a pkg upgrade -re már azt mondja, hogy minden up-to-date. Ezt viszont kétlem :-)

akkor lehet fogtal egy upgrade hibat, nezd meg, hogy milyen os tag szerepel az adatbazisban

pkg shell talan a parancs hozza, utana meg standard SQL, es ha a 8-as csomagjaid vannak fent, de 9-es os tag/triplet/vagy mi a neve van, akkor meg kuldj egy e-mailt @bapt freebsd.org-ra
___
info

Ehhez kicsit jobban kene ertenem a pkgng belsejet. :-(
Amugy 9.0R-rol frissitettem 9.1R-re, es vegyesen voltak 9.0R-hez valo csomagok es nehany azota ports-bol forditott masik. Majd meg probalkozok ezzel azzal.

Valószínűleg azért mondja ezt, mert a "távoli repo" (pkgbeta.freebsd.org) üres, mivel a package building cluster effektíve áll, ergo nincsenek sem pkgng, se régi bináris csomagok.

Persze, ha valaki felteszi a poudriere-t egy ZFS-sel futó masinára, akkor tud magának készíteni ilyen repót...

A pudrit mar mondtad parszor, de:
- egyelore nincs ZFS-em
- meg diszkem se a millio gepemben
- azt ugyan olvastam, hogy mar tamogatja (vagy kozel van hozza), hogy ZFS-nelkuli, azaz csak UFS-t hasznalo rendszeren is lehet vegre dolgozni vele, de ott meg az a baj, hogy UFS-snapshot kell neki, az meg osszeveszik a SU+J-vel, nekem meg ez utobbi most kenyelmi okokbol fontos.

Ugyhogy egyelore 9.0-s csomagokkal mennek a gepek.

fixme 9.1-ben mar javitottak a SU+J + snapshotot

csak reszben, ugy nez ki: https://github.com/freebsd/freebsd/commit/759a2eec3c7351c4a99aea2bdeec9b1de1a2a28c
___
info

asszem pont az a baj, hogy valamelyik javitast mar nem tettek bele a release-be (mondjuk azt ne vagyok kepes agyilag felfogni, hogy ha egyszer csuszott ennyit a kiadas, majd eloallitottak valamikor december 1-jen/2-an egy imidzset, amit aztan 28-an hirdettek meg, akkor mi a szarer nem lehetett ezt a javitast is beletenni. No mindegy, igazabol az zavar, hogy gondolom ez RELENG-9_1-be se fog bekerulni, max ha pulikussa valik valami ezt a hibat kemenyen kihasznalo szoftverecske.)

Ha ez vigasztal, akkor elmondom, tegnap mondta nekem Jeff, hogy még jó pár SU+J hibajavítást "elfelejtett" visszamerge-ölni a stable ágba =) (Nekem is voltak gondjaim vele, mert pl. áramkimaradásnál a journal alapján nem javított ki minden hibát, viszont a fájlrendszert cleannek tekintette.)

Azt ígérte, hogy majd küld a freebsd-stable listára egy levelet, amint átrakta a javításokat.

a fent linkelt patch CURRENT-ben van, de meg mindig benne van az ellenorzes a SUJ-ra

SUJ-nal eddig az volt a bevett szokasom - ritkan ha kellett - hogy elso kor fsck -y, utana meg megegyszer fsck es a SUJ-t kihagytam
___
info

Ellenben a szokott helyen (ftp://..../ports/packages/packages-9.1-release) nincsenk binaris csomagok. Akkor most mi a jo isten haragja van?

A bejelentés ezt írja:

"Please note that precompiled third-party packages are not available for 9.1-RELEASE at the time of release. See the Availability section below for further details."

vagyis:

"dvd1

This contains everything necessary to install the base FreeBSD operating system, a collection of pre-built packages aimed at getting a graphical workstation up and running. It also supports booting into a "livefs" based rescue mode. This should be all you need if you can burn and use DVD-sized media."

Sőt:

"Due to the security incident reported here:

http://www.FreeBSD.org/news/2012-compromise.html

only the small third-party package set on the DVD image is available at this time for users who require pre-built packages (just GNOME and KDE windowing systems). The FreeBSD Project's package building infrastructure is undergoing a complete review and redesign. At this time we can not commit to a date the full release package set will become available. A separate announcement will be made when that becomes available. If you wish to install 9.1-RELEASE now you can build your own packages using portsnap(8) to obtain an up to date ports tree and then build the packages. If you require pre-built packages you should wait for the announcement of the full release package set becoming available."

FreeBSD 9.1-RELEASE can also be purchased on CD-ROM or DVD from several vendors. One of the vendors that will be offering FreeBSD 9.1-based products is:

FreeBSD Mall, Inc. http://www.freebsdmall.com/"

Koszi, ma mar a sokadik ujraolvasasnal en is eszrevettem :-(

New Intel GPU driver with GEM/KMS support

Nem tudom emiatt van-e, de egyik gépre próbaképp felraktam és bizonyos esetekben (pl. LXDE-ből való Logout esetén) elsötétetül a képernyő és megfagy, semmire se reagál, távolról se lehet onnantól rájelentkezni, stb.

Szinte biztos, mert valahol olvastam, h a KMS-t hasznalo drivernel ha egyszer atvalt az ember grafikus uzemmodba, akkor vissza karakteresre mar nem megy. (De nekem pl. inteles gepen meg az svga driverrel is ugyanezt hozza)

Fordítottam egy új, saját kernelt a -stable forrásfából és azzal már nem fagy ki. (Átváltás karakteresre viszont még mindig nem megy, gyász.)

ez addig nem is fog valtozni, ameddig valaki le nem kodolja a restore-t, de nagyon nagy az erdekledos a grafikus dolgok irant ;)
___
info

Az ASLR hiánya, a teljes kernelspace írható+futtatható mivolta és a rengeteg infoleak jobban zavar jelenleg... Valaki igazán portolhatná már a PaX/grsec ötleteit FreeBSD-re. :)

...es bar sehol nem szerepel relnotesban, de /dev/log mar kqueue()-zhato 9.1-ben. Ideje volt mar.

--
|8]

Akkor logolunk tovább? :)
--
zsebHUP-ot használok!

Toretlenul! :)

--
|8]