Nem könnyű az AIX-szal, de azért...

... ilyet nem tud:


program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by program)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libcrypto.so.1.1)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libssl.so.1.1)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libdevel_core.so.1)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libdevel_crypto.so.1)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libdevel_ssl.so.1)
program: /lib64/libc.so.6: version `GLIBC_2.14' not found (required by /home/teve/lib64/libisode.so.1)

A forrás-rendszer egy öreg Debian, a célrendszer egy öreg Redhat, csak sajnos nem egyformán öregek...

libc6-2.19-18+deb8u10
glibc-2.12-1.107.el6.x86_64

És a legszomorúbb az egészben, hogy ezt a verziószám-hozzáragasztást (amit nyugodtan nevezhetünk fősodratú idealizmusnak), ezt csak azért csinálják, hogy megoldjanak egy kompatibilitási problémát. És okozzanak egy másikat. Még Nyomasek Bobó sem gondolhat mindenre.

A másik gond, ami csak az én személyes nyomorom, hogy a mégrégebbi gépemet le kellett adnom, mert "nem trendi, hogy a programozóember íróasztala tele van számítógépekkel, kapott korszerű laptopot Win10-zel, az mindenre elég kell legyen."

Hozzászólások

Van ra valami kulonosebb okod, hogy miert nem valami korszerubbet hasznalsz?

When you tear out a man's tongue, you are not proving him a liar, you're only telling the world that you fear what he might say. -George R.R. Martin

Hát éppen az a baj, hogy a régi Debian, amit használok, az is túl korszerű. Az meg nem plauzibilis, hogy beszambázzak az adminhoz azzal, hogy 'nem tudok programot futtatni a C/78-as szerveren, dobj el mindent (főleg a vonatkozó céges protokollt) és telepíts rá valami új rendszert'

Attol meg telepithetsz regi linuxot VM-be.