Telekom LTE kapcsolat hibák - shame on you telekom!

 

  Sziasztok!

Adott egy MikroTik SXT R eszköz, amivel csatlakoztam egy toronyra. A jelszint kiváló, a jel/zaj arány fantasztikus. A sebesség is jó, 70-90 Mbps lefelé, 50 Mbps fölfelé. Az lte modem lock-olva lett a B20 band-re és arra a konkrét toronyra ahonnan a legerősebb jel jön. A kapcsolat soha nem szakad meg, atomstabil.

Most jön az érdekes rész. A TCP kapcsolatok egy részét nem lehet kiépíteni. Először nem igazán értettem hogy mi történik, a böngésző random módon néha kiírta hogy nem lehet kapcsolódni. Ennek hatására gyakorlatilag használhatatlan az egész, sima böngészgetés közben random oldalak, rajtuk levő képek, hangok stb. nem töltődnek be. Próbáltam MTU-t állítani, de az se segített. A problémát sikerült leszűkítenem addig, hogy "no route to host" ICMP üzenet érkezik vissza a kapcsolódási kísérletre.

Ez valahogy így néz ki:

 

[code]

[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

Welcome back!
[adm@router] > /system ssh [/resolve www.google.com] port=80
connectHandler: No route to host

[/code]

 

Ezeket a parancsokat a router-en adtam ki, hogy kizárjam az összes lehetséges hibát ami a helyi hálózat egyéb elemei okozhatnak. Egymás után 3 kísérletből kettő nem sikerül, egy igen. Mindezt 1-2 másodpercen belül.

Ebből még nem látszódik az, hogy honnan jön ez a "no route to host" üzenet, de ezt is sikerült kideríteni. Érdekes hibák jönnek akkor is, ha ping-elek valamit.

Valahogy így néz ez ki:

 

[code]

[gandalf@palfi] /interface lte> /ping google.com
  SEQ HOST                                     SIZE TTL TIME  STATUS                                                                      
    0 10.254.49.226                              56 126 29ms  admin prohibited                                                            
    1 10.254.49.226                              56 126 25ms  admin prohibited                                                            
    2 10.254.49.226                              56 126 25ms  admin prohibited                                                            
    3 10.254.49.226                              56 126 25ms  admin prohibited                                                            
    4 172.217.20.14                              56 116 25ms
    5 172.217.20.14                              56 116 30ms
    6 172.217.20.14                              56 116 35ms
    7 172.217.20.14                              56 116 27ms
    8 172.217.20.14                              56 116 26ms
    9 172.217.20.14                              56 116 25ms
   10 172.217.20.14                              56 116 29ms
   11 172.217.20.14                              56 116 27ms
   12 172.217.20.14                              56 116 29ms
   13 172.217.20.14                              56 116 28ms
   14 172.217.20.14                              56 116 28ms
   15 172.217.20.14                              56 116 29ms
   16 172.217.20.14                              56 116 31ms
   17 172.217.20.14                              56 116 26ms
   18 172.217.20.14                              56 116 27ms
   19 172.217.20.14                              56 116 23ms
    sent=20 received=16 packet-loss=20% min-rtt=23ms avg-rtt=27ms max-rtt=35ms

[/code]

 

Szóval időnként ICMP 10 / 3 vagy 2 ("administratively prohibited") ICMP hibák jönnek vissza egy olyan címről, ami egy privát cím. A hibákat mindig ez a csomópont küldi: 10.254.49.226. A TCP kapcsolódási hibák esetében is ez a node a hiba forrása.

Teljesen mindegy hogy milyen régiót próbálok elérni, a traceroute -ban megnéztem és ez a 10.254 kezdetű cím mindig a route elején van.

A hiba teljesen random. Van amikor egy percig semmi nem működik. Van amikor 10 percig minden működik hiba nélkül. De általában minden percben van legalább néhány kapcsolat, ami sikertelen. Ráadásul ez a "no route to host" olyan, hogy a böngésző meg se próbálja újra a csatlakozást. (Miért tenné, ha egyszer nincs route...)

Fölvettem a kapcsolatot a telekommal. Az ügyintéző nem hagyta hogy elmondjam neki hogy mi a probléma. Fölvett egy hibajegyet. Egy óra múlva kaptam egy SMS-t arról, hogy "kivizsgálták és nem találtak központi problémát". Ekkor újra fölhívtam őket és az ügyintéző (aki nyilvánvalóan nem ért ehhez), azt tanácsolta nekem hogy próbáljam ki másik készülékkel, mert a hiba az én készülékemben van.

A hiba nyilvánvalóan nem az én készülékemben van, ezeket az ICMP hibákat egy olyan csomópont küldi vissza, ami egy másik alhálózaton van. (A modem és a default gateway is más címtartományban van, 100.x.x.x kezdetű.) Ráadásul hol van hiba hol nincs, és közben a modem naplója tök üres, a kapcsolat meg atomstabil.

Ennek ellenére jelenleg az az álláspontjuk, hogy az én készülékem a hibás.

Van valakinek bármilyen ötlete arra, hogy hogyan tudnám tovább vinni ezt az ügyet? Kit keressek meg vele?

Esetleg valami ötlet arra hogy egyáltalán mi okozhat ilyesmit?

Hozzászólások

Szerkesztve: 2021. 01. 21., cs - 18:31

"lte modem lock-olva lett a B20 band-re és arra a konkrét toronyra ahonnan a legerősebb jel" - ezt a szolgáltató javasolta? Nem lehet, hogy a szolgáltatói oldal próbálna téged átrakni másik cellára, de te "nem hagyod" és ez okoz időnként problémát? Mi történik, ha leveszed a lock-ot? Mi történik, ha csak a B20 band-re lockolsz, de a toronyra nem?

Nem lehet. A hiba akkor is megvolt, amikor nem volt lock-olva. (És egyébként akkor is erre a toronyra kapcsolódott.) A lock-olást csak azért próbáltam ki, mert olvastam valahol, hogy néha kapcsolat hibát okozhat az, ha a modem váltogat a tornyok között.

De ez még akkor volt amikor azt hittem, hogy az LTE kapcsolattal van a gond. Most már biztos vagyok benne hogy nem azzal van a gond, konkrétan a kapcsolat a legutóbbi reboot óta nem szakadt meg, ami 1 napja volt.

Ha nincs lock-olva, akkor is ugyan ezek a hibák jönnek. A hiba nem wireless kapcsolat, jel/zaj arány vagy más hasonló dologhoz köthető, hanem egy konkrét IP címhez, ami mindig a route elején van. Valószínűleg egy belső router-jük, vagy ppp kapcsolat egyik végpontja vagy ki tudja.

Egyébként meg egyáltalán nem arról van szó hogy nem válaszol, hiszen a ping nem is neki szólt! Arról van szó, hogy a routing folyamat elakad valahol a nagy telekom testvér birodalmában. De nem mindig, csak ha olyanja van.

Még az se lehetetlen hogy a large scale nat-ot végző gép túl van terhelve? Ezek után bármit el tudok képzelni.

Meg hát érted, egy ilyen "no route to host" nem lehet link hiba. Ha az eszközöm lenne rosszul beállítva, akkor még konzisztensen nem lenne route sehová. Az a 25msec válaszidő is árulkodó, nem a szomszédból jön a hiba.

 

Még különben is, ez egy default config, ami 100 helyből 99 helyen működött, de itt meg "rossz a beállítás"???

Szerkesztve: 2021. 01. 22., p - 01:13

Gondolom lakossági kártya van benne, mert carrier grade NAT-od van(100-as IP) IPv4-en. A Telekom lakossági mobilnetnél DS-Lite-ot ad, tehát a NAT-olt IPv4-hez kaphatsz egy /64 es IPv6 tartományt. Próbáld ki azzal. Mikrotikben IPv6 csomag legyen bekapcsolva. DHCPv6 klienst állítsd be.

 

Szerintem sem a kapcsolattal van gond, de IPv6-tal kitesztelheted.

/ipv6 dhcp-client
add request=prefix pool-name=telekom-ipv6 pool-prefix-length=64 interface=lte1

Eredménye:

Flags: D - dynamic, X - disabled, I - invalid
 0    interface=lte1 status=searching... duid="0x00030001488f5a77a87e" dhcp-server-v6=::
      request=prefix add-default-route=no use-peer-dns=yes pool-name="telekom-ipv6"
      pool-prefix-length=64 prefix-hint=::/0 dhcp-options=""

Sajnos "searching..." státuszban marad örök időkre.

A lényeg az, hogy az IPv6 Neighbor Discovery be legyen kapcsolva és az 547/546-os portok legyenek beengedve kívülről.

Ha a klienseknek szeretnél a delegált tartományból címet adni, akkor kell egy address pool.

Én sem nagyon vágom ezt az IPv6-ot, de addig nyomogattam a mikrotiket, amíg el nem indult.

Az én konfigom így néz ki(ami nagy betűvel van írva, az interfész vagy pool név):

/ipv6 dhcp-server
add address-pool=LANIP6SCOPE interface=LAN name=server1
/ipv6 dhcp-client
add add-default-route=yes interface=LTEWAN pool-name=LANIP6SCOPE request=\
    address,prefix
/ipv6 firewall filter
add action=accept chain=forward dst-port=443 in-interface=LTEWAN protocol=tcp
add action=accept chain=forward dst-port=80 in-interface=LTEWAN protocol=tcp
add action=accept chain=forward connection-state=established,related \
    in-interface=LTEWAN
add action=accept chain=input connection-state=established,related \
    in-interface=LTEWAN
add action=accept chain=output dst-port=547 out-interface=LTEWAN protocol=udp \
    src-port=546
add action=accept chain=input dst-port=546 in-interface=LTEWAN protocol=udp \
    src-port=547
add action=accept chain=forward dst-port=546 in-interface=LTEWAN protocol=udp \
    src-port=547
add action=drop chain=forward in-interface=LTEWAN
add action=drop chain=input in-interface=LTEWAN
/ipv6 nd
set [ find default=yes ] managed-address-configuration=yes \
    other-configuration=yes

Azért nem semmi, hogy Mikrotik nem volt képes még most sem egy normális failsafe módot készíteni. Safe módban, ha elveszted a kapcsolatot, akkor azonnal visszaáll. Ezért egy csomó konfiguráció nem végezhető el és ki kell kapcsolni, így kockázatot vállalni.

Ubi AirOS-ben tesztelheted a konfigurációt egy ideig. Tehát például 2 perc múlva, ha nem nyomsz rá a konfiguráció véglegesítésére, akkor visszaáll, de közben elveszítheted a kapcsolatot. Aztán belépsz újra és rányomsz, hogy rendben van. Ég és föld!

Gondoltam egy közelítő megvalósítást írok RouterOS-ben (nem lehet teljest, mert mi van ha időzítést írod át vagy a scriptet), de olyan gagyi a szkriptelési nyelve, hogy elment tőle a kedvem.

Esetleg tud valaki olyan szolgáltatót, ami olyan valódi korlátlan mobilnetet ad, ami működik is? :-)

az MVNO-k forgalom alapján fizetnek a hálózat használatért - gyakorlatilag 10% tényleg korlátlan massziv user el tudja vinni az egész profitot...
így ahol ipari jellegű felhasználásra van, ott előbb-utóbb megszűnik.
Van 2-3 hasonló flotta, ahol 1TB havi limit van (a Telenornál asszem úgy van megadva, h amelyik nap 30GB-t meghaladod, akkor aznapra büntit fizetsz - az említett flottáknál pedig ~20k HUF a büntetés a hónapra, ha meghaladod az 1TB-t)

Nem feltétlenül MVNO-ra gondoltam.

Ez a konkrét előfizetés amivel most problémám van, állítólag ténylegesen korlátlan. Nem láttam a szerződés szövegét (nem az én előfizetésem), de ha van benne valami korlátozás, akkor annak nem úgy kellene megjelennie az előfizető oldalán, hogy random TCP kapcsolatokat eldobálunk.

Tévednék?

Plusz ha van ilyen limit és valaki elérte, akkor az ügyfélszolgálatos nem mondaná azt, hogy "kivizsgáljuk" meg "nem találtunk problémát" meg "a hiba az ön készülékében van". Mert ez meg már félrevezetés. (???)

Ephone Unlimited

1 TB adatforgalomig 6990 Ft,
1 TB adatforgalom felett 22 500 Ft

Telenor hálózatát használja. Megfelelő APN beállítással publikus IP címet kapsz CGNAT nélkül.

Mi legtöbbször ezt használjuk kamerák elérésére a semmi közepén.

Nekem a korlátlan "giga erős net" tarifám van két multi simmel. A telefonomban van a fő kártya, illetve két LTE modemben van a másik két kártya. Havonta rámegy 4-500 Gb forgalom. Minden megy mint az óra. Párhuzamosan mind a három kártya az elérhető maximum sebességgel is működik, ha úgy adódik. A Telekomtól nem kaptam üzenetet, hogy túlhasználat lenne.

Vodafone-nál a business net csomagok oszthatóak. Ami azt jelenti hogy pl. van 20GB kereted, és kérhetsz hozzá akármennyi SIM-et (havi 600 Ft körüli áron). A keretet közösen használják a SIM-ek. De szerintem Vodánál a korlátlan net csomagok nem oszhatóak.

Azt nem tudom hogy telekomnál és telenornál hogy van.

Még egy dolgot megpróbálok, kiépítek egy IPSEC tunnel-t egy másik router-re és azon keresztül engedem át a forgalmat. Meglátjuk, hogy az segít-e.

Így van! Azt tapasztaltam, hogy a kiépült TCP kapcsolatom működnek, csak az új kapcsolatok nem akarnak menni, néha.

De akkor lehet hogy a sima IKE/IPSEC is problémás lesz, mert az meg datagram esp -t használ, és ha azokat is random úgy fogja eldobálni mint az icmp ping csomagok egy részét, akkor jó eséllyel az enkapszulált tcp syn csomagok egy része is el fog veszni.

Ezt ki kell próbálnom, hogy kiderüljön.

Meguntam. Elmentem, beraktam egy vodafone-os kártyát. Ezen felül csak két dolgot csináltam:

1. átírtam a pin kódot a modem configban
2. átírtam az apn nevét

Azonnal minden elkezdett működni normálisan. Kapcsolódási hibáknak írmagja se maradt.

Bár az igaz hogy most csak 10Mhz sávszéllel csatlakozik, és a max. sebesség lement 20 Mbit-re. De lehet használni.

Mindeközben a posztkommunista liberálbolsevista telekomék az x-edik bejelentésemre újra megküldték az SMS-t, miszerint "nincs központi hiba" és szerintük még mindig én vagyok a hülye, rossz az eszközöm és különben is minek zaklatom őket.

Szerencsétlen előfizető akinek ezt be akartam állítani, kb. 7 nappal ezelőtt aláírta a 2 év hűséget erre a szarra (mert erre már mit lehet mondani)?

Van még itt valaki aki szerint ez nem egy f**#&@"+!% ????

Shame on you telekom!