( pomm | 2021. 03. 05., p – 19:23 )

Szerintem valami olyan gond lesz, hogy az FTP szerver által kezdeményezett kapcsolatok nem az 1.5.6.7 forrás IP címmel indulnak, és a kliens olyan ezzel nem tud mit kezdeni

Ez logikus is lenne, ha egyzserűen nem működne, de mint írtam nem nem megy, hanem akadozik.

A vmbr1-re felvettem az ip-t és a vmbr1-et hozzáadtam a vm-hez (ezt a proxmox fórumon olvastam valahol):

auto vmbr0
iface vmbr0 inet static
    address  192.168.100.1
    netmask  255.255.255.0
    bridge_ports none
    bridge_stp off
    bridge_fd 0

auto vmbr1
iface vmbr1 inet static
        address  1.5.6.7
        netmask  255.255.255.0
        bridge_ports none
        bridge_stp off
        bridge_fd 0
 

Külső gépről tesztelem.

Íme:

 

Állapot:    Cím feloldása a következőhöz: ftpdomain.hu
Állapot:    Csatlakozás a következő kiszolgálóhoz: 1.5.6.7:21...
Állapot:    Az adatkapcsolat létrejött, várakozás az üdvözlő üzenetre...
Állapot:    Belépve
Állapot:    Könyvtár lista lekérdezése...
Állapot:    A kiszolgáló nem lekérdezhető című passzív választ küldött. A szerver címének használata ehelyett.
Állapot:    Könyvtár listázás sikerült: "/"
Állapot:    Könyvtár lista lekérdezése: "/web"...
Állapot:    A kiszolgáló nem lekérdezhető című passzív választ küldött. A szerver címének használata ehelyett.
Állapot:    Könyvtár listázás sikerült: "/web"
Állapot:    Könyvtár lista lekérdezése: "/web/admin"...
Állapot:    A kiszolgáló nem lekérdezhető című passzív választ küldött. A szerver címének használata ehelyett.
Parancs:    MLSD
Hiba:    Az adatkapcsolat nem hozható létre: ECONNREFUSED - Szerver által visszautasított kapcsolat