( lacos | 2020. 05. 31., v - 21:54 )

Tévedtél. CUPS admin ui --> Printers: "HP LaserJet [...], hpcups [...], requires proprietary plugin."

/usr/share/hplip/prnt/plugins/hbpl1-x86_64.so: ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, stripped
/usr/share/hplip/prnt/plugins/hbpl1.so:        symbolic link to `/usr/share/hplip/prnt/plugins/hbpl1-x86_64.so'
/usr/share/hplip/prnt/plugins/lj-x86_64.so:    ELF 64-bit LSB shared object, x86-64, version 1 (SYSV), dynamically linked, not stripped
/usr/share/hplip/prnt/plugins/lj.so:           symbolic link to `/usr/share/hplip/prnt/plugins/lj-x86_64.so'

A "/usr/share/hplip/prnt/plugins/" könyvtár a hplip RPM-ből települ, de a könytárban található fenti file-oknak "nincs gazdája" (nem tartoznak egyetlen RPM-hez sem, a hplip telepíti azokat).

Eddigi tapasztalatok alapján a CUPS ésvagy hplip csomagok frissítése után a blob-okat kézzel újra kell (kellhet) telepíteni (a hplip futtatásával).

További kényelmetlenség, hogy a proprietary plugin-t megosztó HP-s szerver néha nem elérhető, illetve a letöltött blob gpg ellenőrzése néha elpukkan (valami banális hiba miatt a hplip részét képező script-ben, ha jól emlékszem a bug report-ra). Nagyon kiforratlan megoldás.

Ha a fenti file-okra rákeresel a weben, jó pár hibajegyre lelhetsz.