( godot | 2020. 05. 27., sze - 10:06 )

Használom az OpnSense-t. De néha megijedek. perl,php,python,ruby,bash ezek mind kellenek neki. Mintha nem tudták volna eldönteni melyik plugin mit használjon. Másrészt minden root-ként fut! Még az is ami normál esetben általában nem. A lighthttpd,php,radiusd stb. Állítólag ez azért van mert nincs normális privilégium szeparáció a frontend és a backend között. Magyarán a php kénytelen root-ként futni ha bármit kell módosítani interfészt, tűzfalat akármit. Elkezdtek írni valami python backend-et ami pár dolgot már átvett. De ez sincs kész.

https://github.com/opnsense/core/issues/1695

És ez egy security termék.