( persicsb | 2019. 10. 01., k - 09:46 )

Nem érted a dolgot, nem polyfill a probléma.
Hanem az, hogy a Chrome olyan API használatával implementálja a YouTube-ot, ami már deprecated, sosem volt szabvány, emiatt a Firefox nem implementálja (Shadow DOM v0 - https://caniuse.com/#feat=shadowdom).
A Firefox Shadow DOM v1-et támogat.
A Shadow DOM v0-t majd 2020 februárjában veszik ki a Chrome képességei közül:
https://www.chromestatus.com/feature/4507242028072960
Senki más nem is támogatja, de a Google okosan úgy intézte valahogy, hogy a YouTube ezt az API-t használva készüljön el.