( szabi2k | 2013. 07. 02., k - 12:28 )

Nem, a pontos adatokert le kene irni, hogy mit probal csinalni. Mit probal elinditani, es milyen forrasbol szedte azt ossze.

Ha a Nirans viewer-rol van szo, meg kell keresni, hogy melyik a binaris, es arra adni egy ldd BINARISNEV (ahogy fent is irtak)

Mivel ez 3rd party csomag (tar.gz) nem integralodik a mint csomagkezelojehez, ugyhogy kezzel kell oszevadaszni az dependenciakat. Ennek semmi koze a 64 bit-hez, amiket kiir, azok nem dependenciak, hanem (jelenleg rossz) javaslatokat ir ki a wrapper, hogy valoszinuleg hogy lehet nekifogni orvosolni.

Letoltottem, es egesz pontosan ezt irja ki:

./niransviewer
64-bit Linux detected.
Running from /tmp/Niransviewer
- Installing menu entries in /home/szabi/.local/share/applications
bin/do-not-directly-run-niransviewer-bin: error while loading shared libraries: libfreetype.so.6: cannot open shared object file: No such file or directory

#######################
## Viewer crashed! ##
#######################
ERROR: ld.so: object '/tmp/Niransviewer/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/tmp/Niransviewer/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.

ERROR: ld.so: object '/tmp/Niransviewer/lib/libcrypto.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object '/tmp/Niransviewer/lib/libssl.so.1.0.0' from LD_PRELOAD cannot be preloaded: ignored.
You are running Nirans Viewer on a x86_64 platform.

The most common problems when launching the Viewer
(particularly \e[32m'bin/do-not-directly-run-niransviewer-bin: not found'\e[0m and
\e[32m'error while loading shared libraries'\e[0m) may be solved
by installing 32-bit compatibility packages.

For example, on \e[33mUbuntu\e[0m and other \e[31mDebian-based\e[0m Linuxes you might run:
\e[36msudo 'apt-get install ia32-libs ia32-libs-gtk ia32-libs-sdl'\e[0m

Thank you for using Nirans Viewer for Linux.
Please see README-linux.txt before reporting problems.

Vilagosan latszik, hogy ami elso lepesben hianyzik neki az: libfreetype.so.6.
Ubuntu alatt ez apt-get install libfreetype6:i386

Amugy a binaris szerintem ez:
bin/do-not-directly-run-niransviewer-bin

#ldd do-not-directly-run-niransviewer-bin
linux-gate.so.1 => (0xf777a000)
libopenal.so.1 => not found
libalut.so => not found
libpthread.so.0 => /lib/i386-linux-gnu/libpthread.so.0 (0xf7742000)
libcollada14dom.so => not found
libfreetype.so.6 => not found
libllcommon.so => not found
librt.so.1 => /lib/i386-linux-gnu/librt.so.1 (0xf7739000)
libhunspell-1.3.so.0 => not found
libgobject-2.0.so.0 => not found
libglib-2.0.so.0 => not found
libGLU.so.1 => not found
libGL.so.1 => /usr/lib32/nvidia-313-updates/libGL.so.1 (0xf7658000)
libX11.so.6 => not found
libglod.so => not found
libSDL-1.2.so.0 => not found
libgdk-x11-2.0.so.0 => not found
libgthread-2.0.so.0 => not found
libgtk-x11-2.0.so.0 => not found
libexpat.so.1 => not found
libssl.so.1.0.0 => not found
libcrypto.so.1.0.0 => not found
libtcmalloc.so.0 => not found
libfontconfig.so.1 => not found
libaprutil-1.so.0 => not found
libapr-1.so.0 => not found
libopenjpeg.so.1 => not found
libstdc++.so.6 => not found
libm.so.6 => /lib/i386-linux-gnu/libm.so.6 (0xf7611000)
libgomp.so.1 => not found
libgcc_s.so.1 => /lib/i386-linux-gnu/libgcc_s.so.1 (0xf75f4000)
libc.so.6 => /lib/i386-linux-gnu/libc.so.6 (0xf7441000)
/lib/ld-linux.so.2 (0xf777b000)
libnvidia-tls.so.313.30 => /usr/lib32/nvidia-313-updates/tls/libnvidia-tls.so.313.30 (0xf743d000)
libnvidia-glcore.so.313.30 => /usr/lib32/nvidia-313-updates/libnvidia-glcore.so.313.30 (0xf56fa000)
libX11.so.6 => not found
libXext.so.6 => not found
libdl.so.2 => /lib/i386-linux-gnu/libdl.so.2 (0xf56f5000)

A 'not found'-okat kell megkeresni. Az osszest.