( nanto | 2010. 12. 28., k - 23:25 )

"főként a stabil API hiánya, már kernelszinten is."
leginkabb kernelszinten. Pl. ha qt3 fent van, meg most is lefordul a "thereisakprogramforeverything" csalad barmely tagja, es a tobb mint egy eve svn commit szintjen sem modositott Valknut nevu DC kliensem is lefordult gond nelkul a kesobbi qt4-re, meg openssl 1.0.0-ra is meg pont meg volt patchelve, ami akkor meg erosen alpha volt.

ellenben a valtozo API garancia a kod karbantartottsaganak ellenorizhetosegere :P

A GPL pedig nem kerekedelmi liszensz, azoknak valo, akik hasznalni szeretnek a szoftvert, nem ertekesiteni, ellenben bizonyos hardvergyartoknal (pl. Intel) egyaltalan nem csinalnak problemat abbol, hogy belepiszkalgatnak foallasban a GPL-es Linux kernelbe, vagy a masik pelda az nvidia, ami zart forrasu, megis van gcc-t haszalo "modulfordito" resz, ok ketten meg tudtak oldani, innentol kezdve azt kell, hogy mondjam, hogy amelyik hardvergyarto ceg erre nem kepes, annal sulyos rugalmassagi problemak vannak.