[MEGOLDVA] Dell Inspiron 5501-ben SATA SSD bővítés után dual boot hogyan?

Fórumok

Sziasztok!

Van egy Dell Inspiron 15 5501-es laptop (9. generációs Intel proci) Win 10-zel, az NVME SSD-n. Legacy mód nincs a BIOS-ban.

Bővítettem egy SATA SSD-vel a laptopot, és erre telepítettem már Solus-t is Ubuntu 11-et,  illetve  Fedora 34-et (Ventoy-os külső HDD-ről). De a probléma ugyanaz: install után az F12-es boot menüből a Win 10 boot-ol, de egyik Linux sem.

Azt szeretném elérni, hogy indulásnál a Grub menüjét lássam, és utána tudjak választani: Win 10 vagy Linux induljon.

Leírást tudtok hozzá, vagy iránymutatást adni, hogyan tudom megoldani?

Hozzászólások

Az UEFI boot menüjét az efibootmgr nevű Linuxos eszközzel tudod szerkeszteni. (Vedd fel az UEFI boot menüjébe a GRUB-ot.)

Nekem is ez volt korábban  a gondom. Szerkezd meg a windows bootloaderjét, hogy a grub-ot indítsa el, az meg eleve tud multiboot-ot.

A SATA mode mi legyen: RAID vagy AHCI?

Secure boot nincs véletlenül bekapcsolva?

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

Debian 11-et tettem fel, reboot után bekonfigoltam a BIOS-ban a emu sorrendet, kiválasztottam az ESP partícióról az EFI\debian\grubx64.efi fájlt.

Ami még a BIOS-ban ide vonatkozik:

UEFI Booth Path Security: Never

Secure Boot Enable: letiltva

SATA Operation: AHCI

 

Most megjelent a GRUB menüje, de a rendszerindításra azt a hibát dobta, hogy először be kell tölteni a kernelt ("load the kernel first"), meg szektorhibát a hd0-ra, nem találja arendszert.

GRUB paraméterek:

load_video

insmod gzio

insmod part_gpt

insmod btrfs

set root='hd0,gpt2'

...

Ötlet?

Azért kérdeztem, hogy van-e neki Secure Boot bekapcsolva, mert csak akkor kell shim-mel szórakozni.

Nekem egyébként az egész történet fura, mert a Dell laptopoknak jó szokott lenni az UEFI támogatása, általában minden bootolni szokott róluk. A HP szokott lenni az a gyártó, akinek szar BIOS-ai vannak, meg lezárja az UEFI bootot úgy, hogy csak Windows tudjon bootolni.

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

Kiadtam GRUB alatt az ls -lh(hd0,gpt2)/ parancsot, eredménye:

KVT            <<létrehozás dátuma>> @/

Most újra feltettem, a testing ISO-t, először boot-olt, de utána az initramfs betöltésnél leállt.

Azóta a SupportAssist Pre-Boot System Performance Check azt írja, hogy nem talál boot-olható eszközt, ha kiválaztom a Grub-ot tartalmazó indítót a menüből.

Szerkesztve: 2021. 08. 06., p – 14:02

en az uj gepre (lehet hogy ebben sincs legacy mod, legalabbis eddig nem talaltam) feltettem eloszor a windowst, majd a debian11-et, a debian telepito meg sem kerdezte hogy melyik particiora telepitse a grubot, feltetelezem azert mert csak bemasolta az efi particiora, es annyit csinalt meg, hogy a debiant (grubot) tette elso helyre, igy a grub indul el, ott lehet valasztani hogy debiant vagy windows-t akarok inditani, hogy ott melyik az alapertelemzett azt pedig az /etc/default/grub GRUB_DEFAULT= parametere mondja meg.

valoszinuleg az efibootmgr-el meg lehetne csinalni hogy az elso helyen a windows boot manager legyen, es a windows boot managerben beallitani hogy lehessen debiant is kivalasztani, de nekem jo ahogy van.

nalam nem szamit hogy a secure boot milyen allasban van, a debian is tud mar secure bootot

neked aztan fura humorod van...

Küzdök vele azóta is ...

Az NVME SSD (valami ismeretlen márkájú: KIOXIA)-re felmegy akármelyik rendszer, de ha a SATA SSD (Verbatim 480GB)-re is akarok tenni valamit akkor vége ...

Jelenlegi BIOS beállítások, amivel a Win 10 megy:
UEFI Boot Path Security: Always
SATA operation: RAID On
Secure Boot Enable: Enabled
Secure Boot Mode: Deployed Mode
Expert Key Management : Disabled

Partíciók:
SATA SSD: üres

NVME SSD:
100MB EFI rendszerpartíció
467,53GB NTFS (nincs Bitlocker)
506MB Helyreállítási partíció
8,8GB Elsődleges partíció

Dell Free Fall Data Protection kikapcsolva.
A gyors rendszerindítást a Win 10-ben kikapcsoltam, ha mégis lenne kedvem vele szórakozni ...

Olyannal már találkoztam, hogy a Win által létre hozott 100MB EFI partíció nem tetszett egy-két linuxnak, kevésnek találta és nem is ment tovább a telepítő, vagy hasonló bootolási problémát okozott. Megpróbálhatsz a SATA SSD-n is létrehozni egy 250-500 MB-os EFI partíciót a linuxnak. Nálam ilyenkor megoldota a problémát. Még akkor is, ha csak egy SSD-n csináltam második EFI partíciót. Nem tiltja semmi, hogy ne legyen így.

Az Elementary 6-os beta-val pont így jártam, kevés volt neki a 100MB EFI, amit a Win-em csinált.

Ezt nem is értem, hogy a MS miért ragaszkodik a 100 megás EFI-hez. Pont mikor sok gigás meg több terás háttértárak vannak, akkor pont ezen kell spórolni, hogy semmi ne menjen. Én mindig legalább 500 megás EFI partíciót használok, ami eleinte overkillnek tűnhet, de aztán idővel szépen ki tud használódni a hely rajtuk, kernelekkel, initramfs-sel, főleg, ha tényleg több OS is bootol. Ezen nem éri meg spórolni, fél-egy giga elenyésző terület ma már (eltörpül egy installerhez, swaphoz, böngészőcache-hez, stb.-hez képest), annyi senkinek az életéhez nem fog hiányozni, hacsak nem valami apró eMMC, vagy ősi SSD-t használ (32 GB vagy alatta).

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

De várj, arról volt szó, hogy a Secure bootot kikapcsoltad. Most meg kiderül, hogy a Windows azzal van telepítve, gondolom ilyenkor az UEFI BIOS visszakapcsolja egy windowosos boot után.

Én azt javaslom, hogy miután kikapcsoltad a Secure bootot, dúrj le mindent az NVMe-ről is. Először kezdd a Linux telepítésével a SATA SSD-re, majd csak ezután telepítsd Windowst, de azt se a helyreállító partíció gyári szarjával, hanem a MS oldaláról letöltött és kiírt legfrisebb Windows lemezképpel, saját telepítésben.

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

OK, majd írd meg mire jutottál. Még egy tanács előre: ne Ventoy-jal csináld. Rendesen írd ki a lemezképeket egy pendrive-ra. Nem biztosan a Ventoy a baja, de egy jó kizárási pont. Illetve írtad,, hogy nem támogat Legacy boot módot a gép, de azért triplán győződj meg, hogy UEFI módban indult el az aktuális OS telepítője is! Ez nagyon fontos, mert lehet valami előzetes MBR-es gányolás miatt mégis csak legacy módban bootol be, és abban telepíti fel a vonatkozó rendszert, és mikor a Windowst bootolnád be akkor átvált UEFI bootra, de UEFI bootmódban nem találja a legacy bootos telepítéseket.

“I didn’t start using Linux so I could have friends.” (Luke Smith, 2019) 🐧

win 10: az új ssd-t diskpartal -> List disk > select disk # > clean > convert gpt

ha van kedved win 10 et újratelepíteni ott is játszd el usb win 10 boot után

Nyugodtan hagyd bekapcsolva a secure bootot, mert a linux distrók nagyrészt alá vannak írva

https://digx.hu

Végül több disztribúció kipróbálása után (Fedora, Manjaro, Bluestar, Debian 11), amelyek mind elhasaltak, felment az MX Linux 19.4 -es verziója.

Annak a telepítőjében be tudom állítani, hogy az NVME SSD-nek (ami a BIOS-on belül másodlagos meghajtó, az elsődleges a SATA SSD) az ESP partícióját használja, így ha most boot-ol a gép, akkor az ESP-ről betölti a GRUB-ot, az meg megtalálta a Windows betöltőjét.

Eddig a legjobb telepítője szerintem az MX-nek van.

Mindegyik disztró telepítője tudja ezt, csak mindegyikben kicsit más. Advanced mód, telepítés másként, stb... . A lényeg, hogy neked kell manuálisan megadni a boot partíciót. Az MX az tényleg szupi kis disztró, mondjuk pont nem nekik van a leg- "maistream"-ebb telepítőjük. :-)

Debian 11 telepítője nem találta ...  Eredetileg azt szerettem volna. Pendrive-ra kiírva nem talált drivert a telepítőmédiához (DVD változat volt) stb.

A Fedora 34, meg felment, de utána indulásnál hibát dobott ...

Nem akartam sokat vacakolni. Már nagyon szükségem volt rá.

(Említettem már, hogy az (u)efi a legjobb dolog a szeletelt kenyér óta?)