RaspberryPI OS sense-hat: raspberrypi-bootloader error

Fórumok

Hi!

VBox-ban szerettem volna a legfrissebb RPiOS-ben a sense-hat csomagot feltenni, de:

Az alábbi csomagoknak teljesíthetetlen függőségei vannak:

sense-hat: Függ ettől: raspberrypi-bootloader (>=1.20150820-1) de ez nem teljesíthető.

 

(https://downloads.raspberrypi.org/rpd_x86/images/rpd_x86-2021-01-12/202…) Az OS up-to-date!

A neten nem láttam jó megoldást ra, van ötlete valakinek...?

Hozzászólások

A sense_emulator fent van, ami működik.

A desktop VM-ben nyilván nem megy az éles sense-hat.... (?)

Szerkesztve: 2021. 01. 16., szo – 20:24

Egyrészt használhatod nyugodtan a Raspbian nevet, egyelőre többen ismerik így mint a RPi alapítvány legújabb szellemi tulajdon fetisiszta hóbortjának jegyében átnevezett új nevén. :)

Másrészt pedig rendes RPi hardveren semmilyen csomagot nem kellene feltenned mert default benne van minden csomag a Raspbianban, ami SenseHAT használatához kell. PC-n meg persze úgysem működik a SenseHAT szóval:

sudo apt-get remove python-sense-emu python3-sense-emu sense-emu-tools

Ez egyébként Debian-ra vagy Ubuntu-ra is telepíthető. Az x86 Raspbian lényegében a pimpelt Debian.