fura kijelző gond

Sziasztok!

 

Adva van egy ASUS kijelző, ami kiadja magát egy Ancor Communications Inc 19"-os kijelzőnek a panel szernint, amit mellékelek a képen.

Elvileg 1440 x 900-on mennie kellene, ami megy is neki, csak a képen mellékelt módon. A menüjében turkálva nem találtam semmit, amivel ki lehetne hozni a szélére a képet. Van egy olyan menpont hogy képarány, de az inaktív, hiába resetelem a kijelző beállításait a menüből. Akárhogyan állítom, nem aktív a pont, ki van szürkítve.

A VGA kábel vadi új, más kijelzőkkel nincs ilyen gond.

1280 x 1024-ben megy a kijelző, viszont a natív felbontás sokkal jobb lenne. A képarány se igazán jó a 1280x1024-ben.

 

A kép a hibáról:

http://img4.imagetitan.com/img.php?image=23_20201026_205554.jpg

 

[jimmy@dell-jjpc-E6430 ~]$ sudo get-edid | parse-edid
This is read-edid version 3.0.2. Prepare for some fun.
Attempting to use i2c interface
Looks like no busses have an EDID. Sorry!
Attempting to use the classical VBE interface

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f00 bx=0x0 cx=0x0
    Function supported
    Call successful

    VBE version 300
    VBE string at 0x11100 "Intel(R) Sandybridge/Ivybridge Graphics Chipset Accelerated VGA BIOS"

VBE/DDC service about to be called
    Report DDC capabilities

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x0 cx=0x0
    Function supported
    Call successful

    Monitor and video card combination does not support DDC1 transfers
    Monitor and video card combination supports DDC2 transfers
    0 seconds per 128 byte EDID block transfer
    Screen is not blanked during DDC transfer

Reading next EDID block

VBE/DDC service about to be called
    Read EDID

    Performing real mode VBE call
    Interrupt 0x10 ax=0x4f15 bx=0x1 cx=0x0
    Function supported
    Call successful

Looks like VBE was successful. Have a good day.
Checksum Correct

Section "Monitor"
    Identifier ""
    ModelName ""
    VendorName "LGD"
    # Monitor Manufactured week 0 of 2010
    # EDID version 1.4
    # Digital Display
    DisplaySize 310 170
    Gamma 2.20
    Option "DPMS" "false"
    Modeline     "Mode 0" +hsync -vsync 
    Modeline     "Mode 1" +hsync -vsync 
EndSection

 

[jimmy@dell-jjpc-E6430 ~]$ xrandr
Screen 0: minimum 8 x 8, current 2880 x 1033, maximum 32767 x 32767
LVDS1 connected primary 1600x900+0+0 (normal left inverted right x axis y axis) 310mm x 170mm
   1600x900      60.03*+  40.02  
   1400x900      59.88  
   1368x768      60.00    59.88    59.85  
   1280x800      59.81    59.91  
   1280x720      59.86    60.00    59.74  
   1024x768      60.00  
   1024x576      60.00    59.90    59.82  
   960x540       60.00    59.63    59.82  
   800x600       60.32    56.25  
   864x486       60.00    59.92    59.57  
   800x450       60.00  
   640x480       59.94  
   720x405       59.51    60.00    58.99  
   640x360       59.84    59.32    60.00  
DP1 disconnected (normal left inverted right x axis y axis)
DP2 disconnected (normal left inverted right x axis y axis)
DP3 disconnected (normal left inverted right x axis y axis)
HDMI1 disconnected (normal left inverted right x axis y axis)
HDMI2 disconnected (normal left inverted right x axis y axis)
HDMI3 disconnected (normal left inverted right x axis y axis)
VGA1 connected 1280x1024+1600+9 (normal left inverted right x axis y axis) 410mm x 260mm
   1440x900      59.89 +  74.98  
   1280x1024     75.02*   60.02  
   1280x960      60.00  
   1280x800      74.93    59.81  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   832x624       74.55  
   800x600       72.19    75.00    60.32    56.25  
   640x480       75.00    72.81    66.67    59.94  
   720x400       70.08  
VIRTUAL1 disconnected (normal left inverted right x axis y axis)
 

CVt-vel készítettem egyéni felbontásokat amit beállítottam XRAND-rel , de 1440 x 900-as felbontást sehogy se tudom kicsiholni belőle, a mellékelt képen lévő hiba csúszik be akkor is.

Valami tipp?

 

Hozzászólások

A "Frissítési sebesség" állítgatásával sem változik a helyzet? 

Szerkesztve: 2020. 10. 26., h - 22:44

Mivel ez analóg jel így, ezért a monitoron kellene körülnézni. Valószínűleg manuálisan el van állítva a szinkronizáció, tedd automatikusra a monitor beállításainál. Nem a számítógépen, hanem a monitor menüjében.

Az normáliusnak tűnik, hogy némelyik Asus monitor Ancor-nak mondja magát.

De mivel nem derült ki a pontos típusa (monitor hátulján matrica, vagy az osd menüjében), így nem tudom milyen bemenetei vannak. Ha van dvi (VW193TR ?) vagy hdmi, akkor használd azt. Elvileg azon a dell E6430 gépen van hdmi.

http://pdfstream.manualsonline.com/7/7a6941cf-271b-4f73-97c9-2c61515e7b…

A h-position -t próbáltad már?

Második tab alatt van position és az alatt h-position a vízszintes, v-position a függőleges. 0-100 közti értékekkel. Csak vga bemenetnél van ilyen.

Akkor tönkrement az a régi monitor. Talán megsérült az a rész az elektronikájában, ami kezeli a vízszintes szinkront.  

Esetleg nézd meg nincs e sérülés a dsub bemenetén a monitornál.
pin 13 a h-sync https://en.wikipedia.org/wiki/VGA_connector

Hehe, egy másik asussal valaki hasonlóra panaszkodott 7 éve. 
Ott tán 16 vitesre levéve a színmélységet visszamászott ahelyére. Furán hangzik, hisz analóg a jel.... 
https://superuser.com/questions/689951/monitor-image-became-offset-to-t…

Egyébként érdemes megnézni, hogy ha van rajta matrica, tényleg 2010-es gyártású -e vagy esetleg valaki felülírta valamikor az edid adatokat benne egy másik típusra. Úgy látom 5 féle is volt

rákeresve a VW193D -re ACI19D5 -ből 5 féle is van

https://github.com/linuxhw/EDID/blob/master/AnalogDisplay.md
https://github.com/linuxhw/EDID/tree/master/Analog/Ancor%20Communicatio…

Valahogy lehet be lehet állítani, hogy a monitorban lévő helyett használja valamelyik binárisból, win alatt valami registry bejegyzés, linux alatt is biztos lehet valahogy. Lehet simán a hsync + / - módja nem passzol az adott készülkéhez, ha nem hozzá való... Szóval vannak még lehetőségek, ha sok időd van, akkor eljátszhatsz velük. De lehet vissza kell alakítani valami toollal a repóban lévőből. Hexában ott az elején a bináris edid mindnek.

https://unix.stackexchange.com/questions/295784/how-to-tell-intel-graph…

Van, aminek pozitív, van, aminek negatív szinkron jel kell. Esetleg ezt próbáld meg. Nem mellesleg az általam ismert 19"-os monitorok natív felbontása mind 1280x1024 volt. Biztos, hogy nem ebben is ilyen panel van?

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Nem az a kérdés, mennyit tud maximum, hanem a natív felbontás. Egy pixel nem tud az első harmadában rózsaszín, a másik kétharmadában türkiz lenni. Amúgy az intenzív jobbra tolodás lehet a monitor részéről politikai meggyőződés, de sokkal valószínűbb, hogy rossz a szinkronjel polaritása, így a sorszinkron szélessége idejének és az eltérítés sebességének szorzatával megegyező távolsággal jobbra tolódott a kép. A xorg.conf-ban a szinkronjel fázishelyzete - illetve polaritása - is állítható. Már úgy értve, hogy statikus magas szint mellett alacsony szintű impulzus a szinkronjel, vagy a negáltja, statikus alacsony szint mellett magas szintű impulzus.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

+1 a polarizációnak, amit fentebb linkeltem edid gyűjteményt, ott mintha Hpol N és Vpol P lenne talán mindben (6-ból 6 amit megnyitottam)... fenn meg a saját monitora +hsync -vsync , ami ha jól sejtem pont nem az. *

Ha vacak az edid, akkor hosszútávon a jó megkeresése és beírása segíthet. Vagy kézzel felparaméterezni, csak akkor másik rendszerrel megint rossz lesz és be kell állítani.
De legalábbis érdemes olyan kimenetet generálni (edid-decode), hogy össze lehessen hasonlítani.
 

szerk: ja fenn lehet az lcd-jé látszik vagy nem tudom.. nem úgy néz ki, mint az edid gyűjteményben lévő értékek