RAID5 QNAP NAS-ban csökkentett módba került

Sziasztok,

egy 5 lemezes RAID5-öt szerettem volna felbővíteni 8 lemezesre, mindezt egy Qnap TS-809U-ban. El is kezdtem hozzáadni az első lemezt. Gyanús volt, hogy nagyon-nagyon lassan építi újra.

Ekkor ezzel elvileg gyorsítottam rajt:

echo 50000 >/proc/sys/dev/raid/speed_limit_min

A 6-ik lemezt hozzá is adta, majd jött a 7-ik, ami után -a log szerint- csökkentett módba került a RAID5, ezt persze nem vettem észre. A 8-ik lemezt pillanatok alatt hozzáadta a tömbhöz, ez lett a gyanús.

Megnézve a logot, a Drive1 hibás, ez került csökkentett módba. Megvizsgálva az 1-es lemezt, annak smart-állapota azonban jó, tesztre sem ír hibát, fájlszerkezete is rendben van.

Ha minden igaz, az 1-es lemezen vannak az alapvető megosztások, pl Public, QDownload, QMultimedeia, stb. Ezek "eltűntek" a RAIDből, halványan látszódnak a 'Megosztott mappák' beállításainál, nem aktívak. Sikerült azonban a WinSCP programmal ssh-n kapcsolódni, és némi kutatás után meglett a Public könyvtár és annak tartalma. Egy külső hdd-t hozzácsatolva a nas-hoz, most mentem róla, amit tudok.
 

Kérdésem az lenne, hogyan tudnám újraépíteni a tömböt, 8 lemezzel, pontosabban kirángatni a csökkentett módból?

Hozzászólások

Szerkesztve: 2019. 11. 21., cs - 15:22

Hát, ha biztosra akarsz menni, akkor

  • Tuti megoldás
    • backup, RAID újracsinálás, restore
  • Gyorsabb megoldás
    • backup, RAID piszkálás (elbaszódás esetén: RAID újracsinálás, restore)

Ilyen állapotban minden egyéb csak a tűzzel játszás mentés nélkül.

Ez mit mond?

cat /proc/mdstat

trey @ gépház

 458880 blocks [8/8] [UUUUUUUU]
                 bitmap: 0/57 pages [0KB], 4KB chunk

md9 : active raid1 sdb1[0] sda1[7] sdg1[6] sdf1[5] sde1[4] sdd1[3] sdc1[2] sdh1[1]
                 530048 blocks [8/8] [UUUUUUUU]
                 bitmap: 1/65 pages [4KB], 4KB chunk

unused devices: <none>
-sh: [~]: command not found
[~] # Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath]
-sh: Personalities: command not found
[~] # md0 : active raid5 sdb3[0] sdh3[7](S) sdg3[6] sdf3[5] sde3[4] sdd3[3] sdc3[2] sda3[1]
-sh: syntax error near unexpected token `('
[~] #                  11711673600 blocks level 5, 64k chunk, algorithm 2 [7/7] [UUUUUUU]
-sh: 11711673600: command not found
[~] #
[~] # md8 : active raid1 sdh2[8](S) sdg2[7](S) sdf2[6](S) sde2[5](S) sdd2[4](S) sdc2[3](S) sdb2[2] sda2[0]
-sh: syntax error near unexpected token `('
[~] #                  530128 blocks super 1.0 [2/2] [UU]
-sh: 530128: command not found
[~] #
[~] # md13 : active raid1 sdb4[0] sda4[7] sdg4[6] sdf4[5] sde4[4] sdd4[3] sdc4[2] sdh4[1]
-sh: md13: command not found
[~] #                  458880 blocks [8/8] [UUUUUUUU]
-sh: 458880: command not found
[~] #                  bitmap: 0/57 pages [0KB], 4KB chunk
-sh: bitmap:: command not found
[~] #
[~] # md9 : active raid1 sdb1[0] sda1[7] sdg1[6] sdf1[5] sde1[4] sdd1[3] sdc1[2] sdh1[1]
-sh: md9: command not found
[~] #                  530048 blocks [8/8] [UUUUUUUU]
-sh: 530048: command not found
[~] #                  bitmap: 1/65 pages [4KB], 4KB chunk
-sh: bitmap:: command not found
[~] #
[~] # unused devices: <none>
-sh: syntax error near unexpected token `newline'
[~] #
[~] # cat /proc/mdstat
Personalities : [linear] [raid0] [raid1] [raid10] [raid6] [raid5] [raid4] [multipath]
md0 : active raid5 sdb3[0] sdh3[7](S) sdg3[6] sdf3[5] sde3[4] sdd3[3] sdc3[2] sda3[1]
                 11711673600 blocks level 5, 64k chunk, algorithm 2 [7/7] [UUUUUUU]

md8 : active raid1 sdh2[8](S) sdg2[7](S) sdf2[6](S) sde2[5](S) sdd2[4](S) sdc2[3](S) sdb2[2] sda2[0]
                 530128 blocks super 1.0 [2/2] [UU]

md13 : active raid1 sdb4[0] sda4[7] sdg4[6] sdf4[5] sde4[4] sdd4[3] sdc4[2] sdh4[1]
                 458880 blocks [8/8] [UUUUUUUU]
                 bitmap: 0/57 pages [0KB], 4KB chunk

md9 : active raid1 sdb1[0] sda1[7] sdg1[6] sdf1[5] sde1[4] sdd1[3] sdc1[2] sdh1[1]
                 530048 blocks [8/8] [UUUUUUUU]
                 bitmap: 0/65 pages [0KB], 4KB chunk

unused devices: <none>

Ha ez egy ilyen neves cuccnál nem működik, akkor mi indok van ilyen nas vásárlására?

Én személy szerint Synology-t javaslok mindenkinek, ott kitűnően működik (csak itt a hup-on két-három topic is volt ezzel kapcsolatban a közelmúltban).

Az indok a kényelem, a megspórolt idő, mobil app-ok, csend, alacsony fogyasztás, megbízhatóság (igen, szar mindenből van).

"After successfully ignoring Google, FAQ's, the board search and leaving a undecipherable post in the wrong sub-forum don't expect an intelligent reply."

Láttál már olyan számítástechnikai berendezést, szoftvert ami nem szokott elromlani / hibásan működni? Főleg ha mi felhasználók is hozzányúlunk... Na, akkor ezen túl vagyunk.

Az az indok a vásárlásra, hogy az esetek többségében, az idő nagyrészében műkönek mindenféle tákolás nélkül, ezzel szemben van az, hogy nem veszel ilyet hanem összerakod magadnak, az is széteshet, az óradíjad függvényében még többe is kerülhet mint egy nas beüzemelése, és attól függően mennyit spóroltál a vason az üzemeltetése is többe kerülhet. Szinte biztosan rondább, nagyobb, hangosabb lesz a házi megoldás.  

A QNAP support egyébként nagyon klassz, érdemes írni nekik akár az ilyen problémákkal is.

Desktop: Windows10 | Server: CentOS

Már elnézést de ezek ellentmondásosak: "egy 5 lemezes RAID5-öt" vs "Ha minden igaz, az 1-es lemezen vannak az alapvető megosztások,"

Ahogy látom nincs hivatalosa magyar támogatás, csak nagykerben érhető el  termék, így marad a qnap.com: https://www.qnap.com/en-uk/support-ticket/

ESET és Synology hivatalos viszonteladó

Nem first Disk hanem Disk Volume, ami nem ugyanaz. Tehát ha 5 lemez van raidben, és csak 1 Volume van, akkor a raid5-nek megfelelően van a Default shared folder létrehozva. A nem default lehet máshol. Tehát ha lenne 4 lemeze és az 2 db 2 lemezes raid1-et tartalmaza, akkor az első 2 lemez által hordozott raid1-en jönnének létre a Default share folderek.

ESET és Synology hivatalos viszonteladó

megtörtént a RAID újraépítése (miután kiszedtem a 7ik lemezt), és továbbra is csökkentett módban van :-(