Itt a Fedora 31!

Hivatalosan megjelent a Fedora 31. A bejelentés elolvasható itt. Letölthető innen.

Hozzászólások

Szerkesztve: 2019. 10. 29., k - 19:28

Na ki lesz az első bátor? :)

Már tegnap feltettem:) Igaz, egy másik lemezen a béta állapot első napjától nyúztam. Most frissítem a 30-ról. Kicsit tovább tartott mint elsőre gondoltam. De a test adatbázis, php, web szerverek és tulajdonképpen minden más rendben működnek. A kész frissítés után a trim és defrag ajánlott szerintem (még soha nem dolgoztak ennyi ideig). 

Frissítés menetehttps://fedoramagazine.org/upgrading-fedora-30-to-fedora-31/

Letöltési torrentekhttps://torrent.fedoraproject.org/

Releases 31 változtatásokhttps://fedoraproject.org/wiki/Releases/31/ChangeSet

Lehet, megkéstél ezzel a kérdéssel. Logból valahogy biztosan ki tudnám deríteni, de már vagy egy hónapja biztosan használom három gépen megelégedettséggel.

Sőt, egy nem saját gépen még Fedora 28-ról közvetlenül frissítettem Fedora 31-re. Ebben az esetben rescue live boot és chroot után kellett egy grub2-install. Érzésem szerint azért, mert az újabb Grub ismerhet olyasmit, amit a régi nem, de a grub rpm csomagjának telepítésétől az MBR után még nem költözik be az újabb bináris.

Szerk.: szeptember 19-e óta használom.

https://hup.hu/node/165834

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Most nekifutottam és akkor legyen már Waylandre váltás is!

KDE és Wayland.
Szépen megy, de a gyári telepítéshez kell még egy csomag, amivel műköik a Wayland is.
Teamviewerrel nem lehet (még) Waylandbe csatlakozni.

Valaki alternatívát Waylandes becsatlakozásra? Valamelyik VNC esetleg?

Hm, 5.3.7-es kernel van benne, nem merek frissiteni. F30-on 5.3.x-tol kezdve nem mukodik a GPU-m (i630), talan inkabb CentOS 8-ra kene valtanom. :|

5.3.7 már Fedora 30ban is megjelent, szóval az nem annyira Fedora 31 specifikus. Ettől függetlenül tényleg szívás, mert pl nekem se akarja behozni a videó jelet ha erről a kernelről bootolok. Sajna még nem volt időm kidebugolni mit lehet tenni..

Az embert 2 éven át arra tanítják hogyan álljon meg a 2 lábán, és hogyan beszéljen... Aztán azt mondják neki: -"Ülj le és kuss legyen!"..

Na, ma volt kis időm kidebugolni a dolgot, és egy elég érdekes bugba sikerült belefutni.. Jelek szerint ugyanis az 5.3as szériában van egy i915öt érintő bug, ami csak VGA módban jön elő.
Ez külön öröm azoknak akiknek mondjuk LUKS-al titkosított partíciójuk van, mert nomodeset nélkül még be se tudják írni a LUKS feloldáshoz szükséges jelszót :)

A hibára már van patch (jelenleg csak a linux-next fában: https://lkml.org/lkml/2019/10/31/38, commit 59cd826fb5e7 ), de még nincs masterre bemergelve, szóval ideig még várni kell a hivatalos kernelre..
Addig vagy használjatok 5.2es kernelt, vagy ha a monitor támogatja, és van is hozzá HW, akkor álljatok át másik kábelre (HDMI, DisplayPort, USB, vagy ami adott)
 

Az embert 2 éven át arra tanítják hogyan álljon meg a 2 lábán, és hogyan beszéljen... Aztán azt mondják neki: -"Ülj le és kuss legyen!"..

Nem úgy néz ki: 5.3.8 a f64e21df99d279797d8d19bd9d1c0945c0c26fb8-ra épül:
https://koji.fedoraproject.org/koji/buildinfo?buildID=1405711
# Source:     git+https://src.fedoraproject.org/rpms/kernel.git#f64e21df99d279797d8d19bd9…

Abban a commitban viszont semmi i915ös javítást nem látok:
https://src.fedoraproject.org/rpms/kernel/c/f64e21df99d279797d8d19bd9d1…

Szerk: Amúgy amíg át nem kerül linux-next-ről linux masterre addig szerintem nem is lesz javítva.

Az embert 2 éven át arra tanítják hogyan álljon meg a 2 lábán, és hogyan beszéljen... Aztán azt mondják neki: -"Ülj le és kuss legyen!"..

Tegnap frissítettem Fedora 30-ról, kivételesen a GNOME Szoftverekkel. Dögunalmas frissítés volt – szerencsére :)

Nekem ma frissult a Noti 30-rol. Nem volt sok idom meg nezegeti, de az feltunt hogy a GUI piszok furge lett!!! (Gnome/Wayland)

Sziasztok! Én próbáltam már a betát a laptopomra telepíteni,de nem indult: kernel panic.Ha újra megpróbálom a véglegessel, és ismét kernel panic lesz, el tudom valahogy indítani?

A Live vagy a telepített rendszer nem indúl?

Szerintem ha a Live fut akkor a HDD-ről is futnia kéne.

Minimum Hardware for Accelerated Desktops

https://docs.fedoraproject.org/en-US/fedora/rawhide/release-notes/welcome/Hardware_Overview/

 

Jut eszembe az első beta Live nekem sem indúlt!

Látom, közben megoldódott. Én még olyannal nem találkoztam, hogy ne lehetett volna indíthatóvá tenni egy Fedorát. Ha más nem, akkor live rescue boot, ott mount az eredeti filerendszerek, chroot, majd grub2-install.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Munkagépre most ment fel 29-ről egyből 31-re upgrade. Pöcc-röff.

áthelyeztem 4GB aprófilet home alatt, tracker-extract megette az összes ramot. Próbált indexelni a miner-fs, sokaknál előjőtt. Reboot nem segít mert ahogy bejön a desktop indul a tracker és 5mp alatt elfogy a ram. Ticketek vannak, vkinek 64 GB ram is koppra elfogyott.

A 29 az én igényeimhez nagyon gyengére sikerült. Egyetlen gépemen használtam, ott derült ki, hogy máshova nem fogom feltenni. De ez már amúgy is a múlt, hiszen a 29 támogatása hamarosan lejár. Fedora 31 viszont nagyon jó. Conky ugyan bugzik, szerintem valahol long int deklaráció van unsigned long int helyett, mert néha képes negatív memóriahasználatot jelezni. :)

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Ha valaki MATE-val használja: nem elég a mate-* csomagokat telepíteni, hanem kell neki a marco is, és akkor lesz egérkurzor a MATE desktopon... ráment pár órám, mire rájöttem...

Hali.
dnf groupinstall "MATE felület"
vagy angol rendszer esetén
dnf groupinstall "MATE desktop"

Van még egy további "Mate alkalmazások" group is.

Az alábbi parancsal tudod listázni az elérhető groupokat.
dnf grouplist

Sőt mostmár dnf a "module" kapcsolóval akár különböző verziójú csomagokat is tud telepíteni, hasonlóan a flatpakhoz, szeparálva. Érdemes belenézni :)
dnf module list

Fedora 28 óta nem volt működő Wayland kiadás.
Ctrl+Shift+Alt+R és a gnome-shell megzabál 10GB memóriát, utána pedig CPU 80% és visszamegy 1gb-ra. Visszajelzésre nem történik semmi, pedig nem nehéz reprodukálni.
Totemhez ha megnyitnék egy feliratfájlt, azonnal kifagy, bezárni sem lehet: pkill totem, hacsak nem akarod, hogy az egész shell kiakadjon.
Nagy fájlok másolásakor, sőt már néha csak magas IO esetén is érezhetően belassul, beakad a rendszer, bár ez valószínűleg a hdd hibája, erre azt mondták valami gnome virtualfs probléma.

Mindig a lehető leghamarabb frissítek, persze a megfelelő mentések után, eddig sose volt gond. Most sajnos update után a SELinux is megadta magát. Miután egyesével megmondtam a SELinuxnak, hogy állítsa vissza a problémás fájlokra az alapértelmezett házirendet, kaptam egy jobb megoldást:

fixfiles -F onboot && reboot

Viszont a Wayland érezhetően gyorsabb és folyamatosabb, mint az Xorgos munkamenet, ezért is használom azt. Sose lesz egy iOS, de legalább nem window$.
Az app menü (Win+A) hihetetlenül gyors lett, akár csak androidon. Szépen feljavították az alap témát is, sőt még új ikonok is vannak.

A többi disztribúciót biztonsági vagy kényelmi okokból nem használom. A Fedora számomra jelenleg a tökéletes kompromisszum. Egyensúly a stabilitás, frissesség, és biztonság között.

Nálam a Xorg fut. Fogalmam sincs, mitől kellene Waylandnak futnia. Nem mondtam, hogy ne tegye, mégsem teszi. Majd, ha a disztribúció készítői nagyon akarják a Wayland-et, akkor biztos nálam is az fog futni. Nem tettem erőfeszítéseket azért, hogy a Xorg maradjon. Egyszerűen csak maradt.

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Szerkesztve: 2019. 11. 05., k - 18:42

Most ment fel nekem is a laptop-ra, de egyelőre nem nagyon vagyok vele megelégedve.

Gyakorlatilag megállás nélkül jelzi, hogy kernel hiba volt, hol a nouveau driver szált el, hol pedig a Virtualbox.

Van esetleg valakinek hasonló problémája? De még jobb lenne ha megoldása lenne rá :)

Szerk: a laptop egy Dell 5591

Szerkesztve: 2019. 11. 07., cs - 11:42

Egy ideje fent van egy Dell G3 laptopon:

    description: Notebook
    product: G3 3579 (086F)
    vendor: Dell Inc.
    serial: 5438LP2
 

grafkártyák:

00:02.0 VGA compatible controller: Intel Corporation UHD Graphics 630 (Mobile)
01:00.0 3D controller: NVIDIA Corporation GP107M [GeForce GTX 1050 Ti Mobile] (rev a1)

Az nvidiaval most épp copok kicsit.

Az istennek se akarja felismerni a külső monitoromat. (xrandr nem listázza a HDMI-0-t, csak egy HDMI-1-et amit disconnected-nek mond.
Az NVIDIA server settingsben pedig ott van a csatolt monitor, felismerve, mint HDMI-0 és Dell monitor típus okés. Szal lövésem nincs, hogy most ki nem lát kit.)

Másik öröm volt, hogy ugrade után a docker totál szétesett.

Docker-ce repóból volt előtte felrakva. Mint kiderült, ebben a kernelben alapértelmezetten bekapcsolták a CGroupsV2-t, amit a docker-ce (legalábbis ez a telepített változat: Docker version 19.03.4, build 9013bf583a) nem támogat. Ezért kernel paraméterben ki kell kapcsolni ezt.
Ha esetleg valaki belefutna: systemd.unified_cgroup_hierarchy=0 kernelparaméter orvosolja a dolgot.

https://fedoraproject.org/wiki/Changes/CGroupsV2

Valami display guru nincs a közelben, aki szívott esetleg ilyen external display dologgal és sikerült helyrepofoznia a Fedora31-t?

Fedora30-cal minden okés volt eddig, de mostmár az sem megy rendesen ebben a tekintetben, hiába bootolom a régi kernelt.

Elóre is köszi a segítséget

-----------------------------------------------------------------------------
Talisker Single Malt Scotch Whisky aged 10 years - but Yoichi is coming up :)

Most raktam fel egy Acer notebookra. Csak a szokásos, nem szabványos EFI implementációs hülyeség, de már rutinosan teszem magam túl rajta. Telepítés után nem boot-ol. Ilyenkor telepítő pendrive-ról kell indítani, majd rescue módban akár a már meglévő EFI boot bejegyzéseket lehet törölni, majd hozzáadni ugyanazon paraméterekkel egyet, ami Fedora névvel volt bejegyezve, csak most a default Linux névvel tegyük. Hülye Acer ugyanis kétféle label-t ismer: Windows és Linux. Aztán már működik is. :)

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Szerkesztve: 2019. 11. 09., szo - 19:33

Ó, hogy szakadjon rájuk az ég! :) (Na jó, ne.)

Épp telepítek egy gépet, mire kiderült, dobták a system-config-users GUI-t, ami képes volt felhasználókat, csoportokat kezelni. Mindezt a python2 függőség miatt. Helyette persze nincs semmi. Illetve csinálom CLI-n. Nem nagy katasztrófa, csak ezt épp GUI-n szoktam, úgy esett kézre. Most meg mazsolázhatom ki a nekem szükséges commandline paramétereket. Mindegy, ami reményt ad, hogy megrendeltem a pizzámat, talán nem pusztulok éhen telepítés közben. :)

tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE