Trinity Desktop Environment R14.0.1

 ( trey | 2015. szeptember 2., szerda - 12:18 )

Trinity Desktop Environment R14.0.1

A Trinity Desktop Environment projekt célja a KDE 3.5 életben tartása polírozgatás és új funkciók hozzáadása által. A projekt nem hivatalos KDE projekt, hanem egy független fork. A fejlesztői csapat bejelentette a Trinity Desktop Environment R14.0.1-es kiadását. A kiadás egyik érdekessége az kezdeti, alapszintű FreeBSD támogatás megjelenése.

Részletek a bejelentésben.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Fegyverkezzünk, ez itt a zombi apokalipszis!

Á, csak migránsok! :)

Azért ez érdekes, a Gnome2-nek is van forkja, a KDE3.5-nek is, és érdekes módon ezek tetszettek utoljára belőlük.
--
Fight / For The Freedom / Fighting With Steel

Nosztalgia kedvelőknek lehetne Windows 98 fork is! :D
De engem érdekelne egy OS/2 fork is. :-)
--
Tertilla; Tisztelem a botladozó embert és nem rokonszenvezem a tökéletessel! Hagyd már abba!; DropBox

Nekem Win7 fork kellene, amire ráhúzható a fork-olt XP GUI.

dejo írta:
Nosztalgia kedvelőknek lehetne Windows 98 fork is!

IceWM? :D
--
Fight / For The Freedom / Fighting With Steel

akkor már inkább ez - https://en.wikipedia.org/wiki/EDE

----
"Kb. egy hónapja elkezdtem írni egy Coelho-emulátort, ami kattintásra generál random Coelho-kompatibilis tartalmat."
Instant Coelho

Használtam, tetszett is, de valahogy nem tudtam igazán magamévá tenni. Viszont egészen jól hozza a win98-feelinget.:D
--
Fight / For The Freedom / Fighting With Steel

KDE 3.5-öt nagyon szerettem, sokáig nem is álltam át KDE 4-re, de mikor átálltam nem bántam meg. Így utólag már nem mennék vissza a 3.5-höz.
---------------------------
Oszt jónapot!

Én tettem egy próbát tavaly a KDE4-gyel, de valahogy nem az igazi. Nem érzem azt az egységet, amit a 3.5-nél igen. De lehet, teszek egy próbát megint az 5-tel, biztos a páratlanok a szerencsések, mint az Overkillnél. :)
--
Fight / For The Freedom / Fighting With Steel

"mint az Overkillnél" :-) +1

Érthetetlen, a kde4 (5) designosabb, de a lényeg ugyanaz, "start menü", tálca, stb. Kit érdekel a 3.5? Kevesebb erőforrás? Mert a kinézetet tuti, hogy kde4ben is meg lehetne oldani skinnel (lehet, hogy létezik is)

szerk: én kde t használtam 3.5 ig, és utána is, a 4est az elejétől fogva (bétától), és a fejlesztéskor érthető bugokat leszámítva semmi bajom vele.

Kevesebb erőforrás + nem tudsz mindent megoldani.
Pl. Kima, Kweather. Ezekre ha vannak is alternatívák, sokkal bumburnyákabbak a KDE4-ben, mint 3.5-ben.

A dizájn nem érdekes, azt úgyis azonnal átszabja a user. Nekem, mint mondtam, az a bajom vele, hogy teljesen széteső szerkezetű. Ugyanaz a bajom vele, mint ami az XFCE-vel is, csak utóbbinál tervezési sajátosság. De majd nekifutok még egyszer.
--
Fight / For The Freedom / Fighting With Steel

szép dolog fenntartani a régi jó dolgokat, én is szerettem a kde3-at, de miért ilyen csúnya ez vajon?

Mert megragadtak 2003-ban.

Technológiai téren ne teremtsünk (és őrizzünk) már hagyományokat.

Vigyázz, mert a hagyományteremtéstől való ódzkodás is könnyen hagyománnyá válhat.
--
Fight / For The Freedom / Fighting With Steel

Az egy dolog, hogy van akinek a TDE KDE 3.x-es kinézete jobban tetszik, mint a KDE 4.
De azért a Tisztelt Kollégák néha megnézhetnék, mi van a motorháztető alatt.
Erről egy pl. egy (oda-vissza elfogult) csörte:
http://lwn.net/Articles/626562/

csak egy idézet:

> We fully maintain Qt3, including patching security holes.

According to openhub.net TDE maintains a code base of 10 million lines of code with just 14 contributors over the last year (I assume that the project is set up correctly as you are the manager). That makes about 700,000 lines of code per developer. This sounds to me like a too large piece of cake to eat and impossible to provide security updates. In comparison the Qt5 project shows 445 developers on a code base of 6.8 million lines of code.

I'm wondering how you can provide those security fixes? Are you monitoring Qt and KDE security advisories to check whether they still apply to KDE 3.5 and Qt 3 (at least I do not check whether a found vulnerability would apply to KDE 3.5)? Not to mention code which got rewritten during the Qt 4 and Qt 5 transitions and by that just eliminating insecure areas which might never have seen a CVE as nobody looked at the old code. Personally I would be extremely concerned to ship such an outdated KHTML - it just must be full of security issues, similarly the network stack of Qt, etc. etc. ..."

A TDE fejlesztőinek hozzáállását is imádom, amikor Martin Graesslin, a KWin fejlesztője régebben javasolta nekik, hogy használják a KDE4-es KWint, mert szinte semmi nem kell hozzá a KDE4-ből, mégis jobban járnának, akkor olyan gyűlölettel küldték el melegebb éghajlatra, hogy ihaj.

Régi, de jól bemutatja a Trinity fejlesztőinek hozzáállását: http://blog.martin-graesslin.com/blog/2012/02/having-a-look-at-the-oldnew-desktop-environments/

Erről az az (urban legend-gyanús) faszi ju8tott eszembe, aki megvett egy lepukkant gyáregységet, hogy a kedvenc autójához tényleg eredeti alkatrészeket tudjon gyártani, ha szükség lenne rá. Beteges, eléggé rontotta a reputációjukat.
--
Fight / For The Freedom / Fighting With Steel