Frissítettem Utopic Unicorn-ról Vivid Vervet-re

 ( trey | 2015. április 26., vasárnap - 15:32 )

(A Miért váltottam Debian Sarge-ról Ubuntu 5.10-re?, a Frissítettem Ubuntu Breezy-ről Dapper-re, a Frissítettem Ubuntu Dapper-ről Edgy Eft-re, a Frissítettem Ubuntu Edgy Eft-ről Feisty Fawn-re, a Frissítettem Ubuntu Feisty Fawn-ről Gutsy Gibbon-ra, a Frissítettem Gutsy Gibbon-ról Hardy Heron-ra, a Frissítettem Hardy Heron-ról Intrepid Ibex-re, a Frissítettem Intrepid Ibex-ről Jaunty Jackalope-ra - ... - a Frissítettem Karmic Koala-ról Lucid Lynx-re, a Frissítettem Lucid Lynx-ről Maverick Meerkat-ra, a Frissítettem Maverick Meerkat-ról Natty Narwhal-ra, a Frissítettem Natty Narwhal-ról Oneiric Ocelot-ra, a Frissítettem Oneiric Ocelot-ról Precise Pangolin-re, a Frissítettem Precise Pangolin-ről Quantal Quetzal-ra, a Frissítettem Quantal Quetzal-ról Raring Ringtail-re, a Frissítettem Raring Ringtail-ről Saucy Salamander-re, a Frissítettem Saucy Salamander-ről Trusty Tahr-re, a Frissítettem Trusty Tahr-ról Utopic Unicorn-ra, [ 32 bitről 64 bitre váltás miatt újratelepítés ] - avagy lehet 10 év alatt egy újratelepítéssel is élni - kaland folytatódik...)

Április 23-án megjelent az Ubuntu 15.04-es kiadása. Mivel az emberek szinte követelték a frissítős kaland folytatását, szombaton nekiálltam és megfrissítettem a 14.10-es rendszeremet.

Elkészítettem az éles rendszer klónját, majd kipróbáltam, hogy működik-e. Miután megbizonyosodtam róla, hogy minden indulásra kész, rendeltem egy pizzát, bontottam egy üveg vörösbort és nekiláttam.

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #1
21:06-kor elindítottam a folyamatot

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #2
Ugyan a futó 14.10-es rendszer naprakész volt, a Software Updater jelezte, hogy már a 15.04 is elérhető.

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #3
A megfelelő authentikáció után kezdődhetett a móka...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #4
Ezúttal nem bétára, hanem végleges kiadásra frissítettem

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #5
...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #6
...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #7
1333 csomag frissült

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #8
Elindult a csomagok letöltése

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #10
Majd azok telepítése

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #11
Amíg a rendszer molyolt, addig megírtam egy cikket...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #13
Kitettem egy szavazást...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #14
Közben válaszoltam néhány kérdésre...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #15
...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #16
Elvégeztettem a takarítást...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #17
Nyomtam egy újraindítást...

Frissítettem Utopic Unicorn-ról Vivid Vervet-re #18
és 22:18-kor már a friss, ropogós rendszert használtam. Az egész folyamat letöltéssel együtt lezajlott 1 óra 12 perc alatt.

Ugyan sok időt még nem töltöttem el a Vivid Vervet-tel, de eddig rendben teszi a dolgát. A 3.19-es kernelt használva a VMware Workstation 11.1-nek szüksége van egy kis simogatásra, de ettől eltekintve az összes, napi munkához szükséges dolog működik.

Problémamentes frissítést! Ősszel folytatjuk!

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Szép munka! Kösz a vmware-es hasznos tippet is! :)

Lassan unalmassá válik Ubuntut használni, olyan hibamentesen fut le a frissítés is. :)

A frissítések valóban egyre szebben futnak le, ráadásul egyre kevesebbet kérdezősködik is, de a frissítés után azért vannak bajok.

a KeePassX-bol a 0.4.x-est vagy a 2-es alphat hasznalod?

Ami benne van a Vivid-ben:

ii  keepassx      0.4.3+dfsg-0.1ubuntu1      amd64      Cross Platform Password Manager

--
trey @ gépház

Mind a kettő benne van egyébként. Én is a 0.4-est használom, egyrészről az még nem .Net-es, másrészről a 2-es nem kompatibilis az Android-os verzióval. (Legalábbis kezdetben még nem volt, nem tudom változott-e a helyzet)

Amit te irsz a .Net-es az KeePass2. Van a KeePassX-nek 2-es verzioja (alpha) az nem .net-es simma qt

Igazad van, készül egy 2-es KeePassX is, de az is a KeePass2 fájlformátumot használja, nem az egyesét.
Bár már van KeePass2Droid is, így (majd) lehet váltani, ha be tudja importálni a 2-es az 1-es exportját.

Betudja.

A legizgslmasabb kérdésre nem jött válasz. Milyen volt a pizza?

Ilyen kérdés nem volt, de Erdélyi típusú, fokhagymás tejfölös alappal. Méretét tekintve "családi". :)

--
trey @ gépház

Sőt, azt sem tudtuk meg, hogy a pizza mennyi idő alatt érkezett meg, illetve a pizza és a vörösbor mennyi idő alatt fogyott el. A vörösbor egyéb adataira (version, distributor,…) már rá se merek kérdezni. :-)

-----
(&%;_98\<|{3W10Tut,P0/on&Jkj"Fg}|B/!~}|{z(8qv55sr1C/n--k**;gfe$$5a!BB]\.-

Múltkor 3 pohár után nem lett tökéletes a szavazás.
Bubi telepítő úgy látszik kevesebb pátyolgatást igényel.
(Vagy vizezett volt most a bor.)
;D

Ez ugyanaz a bor volt, ahogy említettem, a szavazást ezen dist-upgrade futása alatt tettem ki ;)

--
trey @ gépház

Arch Linux-szal keresem a betevőt, minden reggel, az éles munkagépen mindent frissítek a kávé mellett. (rolling release).

--
arch,debian,openelec,android

Hamarosan jönnek a görög, aztán pedig a héber nevek? Esetleg cirill?


tr '[:lower:]' '[:upper:]' <<<locsemege
LOCSEMEGE

Ignorant Igor... kíváncsi lennék :D

--
Where do you want to go today?
[nobody@salcay:~]$_

Népi megfigyelés:

Baromi gyors a boot és a leállítás.

--
trey @ gépház

Ha ebben a release-ben mutatkozott be a systemd akkor gondolom azért.

--
arch,debian,openelec,android

Igen, egyértelműen a systemd miatt. Boot-olásnál kiválasztható, hogy upstart-tal induljon és olyankor lassabb az indulás, a leállítás meg sokkal lassabb.

Hogyan választható?

A boot menünél a második menüpontot választod ("Advenced options for Ubuntu"), majd az új menünél is a 2.-at, aminek a végén "upstart" van.

Kössz!

Egy notebookon próbálgatom néha a 15.10-et és az is rettentő gyors, boot 20 mp a leállítás 5 mp ... ha még ennél is gyorsabb az már nagyon nagyon gyors.

systemd-analyze plot > bootchart.svg

Tudnál egy eredményt mondani? kernel + userspace

--
trey @ gépház

Bizonyara azert, mert a systemd es az upstart most egymas mellett fut ;) j/k ... vagyis annyira megsem hulyeskedek, valoban mulatsagos, hogy nem eliminaltak teljesen az upstart maradvanyokat. Persze, nem is az alpha meg a beta release kozott kellene kicserelni az init rendszert, mert igy nezve ertelmetlen a fix kiadasi ciklus ...

Gondolom nem véletlenül maradt benn, ezt mutatja, hogy a boot menüben is választható, hanem azért, hogy ha valakinek nem menne a systemd, tudja használni a rendszert upstart-tal. (Ez utóbbira akadnak is példák)
Majd, ha teljesen kiforrott lesz a systemd, gondolom akkor fogják az upstartot szanálni.

Az rendben is van, hogy bootoláskor választható, csak az néz ki furán, hogy a systemd használata mellett, még mindig ott skubiznak upstart processzek a háttérben ;)

Milyen érzés Breezy Badger helyett Vivid Vervetet használni? :)
--
https://www.digitalocean.com/?refcode=7504fb2af065

Na ez érdekes, nálam teljes katasztrófa volt a release-upgrade.
14.04-ről még úgy-ahogy felment 14.10-re, de a grafikus felület már iszonyúan szaggatott.
A 15.04-es upgrade pedig olyan szinten tönkrevágta a rendszert, hogy lehetett formázni az SSD-t és tiszta telepítéssel kellett visszaállnom a 14.04-re.
Egyszerűen az X indulásakor becsíkozott a monitor és merevre fagyott az egész, de előtte legalább 5 percig bootolt. (SSD!!!)
És ez nálam - viccesen hangzik, de nem az - minden dist-upgrade-nél törvényszerűen megtörténik, a tegnapinak is úgy álltam neki, hogy frissítek, de utána úgyse dolgozok semmit se, mert majd egy friss rendszert kell beállítanom... :)

Jaigen, próbáltam tiszta 15.04-et is, de semmilyen (nekem alapnak) számító csomag nem volt hajlandó feltelepülni triviális függőségi hibák miatt. Majd egy év múlva talán használható lesz, de a következő LTS kiadása után is legalább 6 hónap türelmi időt kell adni. Röhej.

Egy év múlva már pont nem lesz használható, ugyanis 9 hónapig támogatják a köztes kiadásokat. :)

A tiszta telepítésnél milyen csomagokat nem tudtál feltelepíteni?

pl. rdesktop, mc, fglrx. Az fglrx a 14.04 LTS alatt most is függőségi hibákkal visít és nem települ fel.
A proprietary sem.

root@alderaan:/home/trey# apt-get install --reinstall mc
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/464 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 187637 files and directories currently installed.)
Preparing to unpack .../mc_3%3a4.8.13-3_amd64.deb ...
Unpacking mc (3:4.8.13-3) over (3:4.8.13-3) ...
Processing triggers for gnome-menus (3.10.1-0ubuntu5) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu3) ...
Processing triggers for bamfdaemon (0.5.1+15.04.20150202-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for mime-support (3.58ubuntu1) ...
Processing triggers for menu (2.1.47ubuntu1) ...
Setting up mc (3:4.8.13-3) ...
Processing triggers for menu (2.1.47ubuntu1) ...
root@alderaan:/home/trey# apt-get install --reinstall rdesktop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 0 B/154 kB of archives.
After this operation, 0 B of additional disk space will be used.
(Reading database ... 187637 files and directories currently installed.)
Preparing to unpack .../rdesktop_1.8.3-1_amd64.deb ...
Unpacking rdesktop (1.8.3-1) over (1.8.3-1) ...
Processing triggers for man-db (2.7.0.2-5) ...
Setting up rdesktop (1.8.3-1) ...
root@alderaan:/home/trey#

--
trey @ gépház

Szuper, ezt sikerült tegnapra megoldani :)
Azért látszik, hogy legalább dolgoznak és próbálnak valami használhatót tákolgatni.

Nem tudom, hogy mire gondolsz, de egy hete csináltam dist-upgrade-et és akkor is nyilvánvalóan települnie kellett ezeknek a csomagoknak. Nem volt semmiféle probléma.

--
trey @ gépház

Lehet, hogy néhány egyedi repo-t ki kéne tiltani?
--
PtY - www.onlinedemo.hu, www.westeros.hu

Fuggosegi hibak? Lehetne kicsit konkretabban? Nekem ez ugy hangzik, hogy eros felhasznaloi segedlettel el lett keffentve az ubuntud, es ennek ellenere panaszkodsz. Milyen vasrol van szo egyebkent?

+1

--
trey @ gépház

+1

Bár én a szerver változatot használom, de nálam sem volt gond. Pedig egy rakás plusz csomagot fel kellett raknom, hogy rendes desktopként tudjam használni. Egyedüli gond, hogy az imagemagickkal „vízjelezve” egy képet, a görög betű helyett kérdőjel jelenik meg. Ezen még dolgoznom kell egy kicsit.

-----
(&%;_98\<|{3W10Tut,P0/on&Jkj"Fg}|B/!~}|{z(8qv55sr1C/n--k**;gfe$$5a!BB]\.-

Lehet elkeffentésnek is hívni, ha megpróbálom egy kicsit is eltérően használni az oprendszert az ubuntut fejelesztők
agyament elképzelései ellenében?
Máglyára velem, ha nem akarom használni a network-manager-t? Előtte pluszban kínzás, ha interfaces filet merek használni vlan-okkal? Egy évig nem tudott rendesen bebootolni az a szar, csak 5-6 perc után, mert vlan-okkal használom a hálózatot és mindig gondolkodott x-szer 30 másodpercig, hogy nincs network connectivity? Ha meg access-be állítottam a switchet, akkor 30 sec volt az egész boot?
A hivatalos oldalukon a bugjelentésekre meg az volt a válasz, hogy ne használd. (????)
Mondjuk a 14.04 friss telepítésénél erre már nem panaszkodik, szóval valamit helyrehozhattak, amit eddig el se ismertek, vicc.
Jaigen, egy kernelfrissítésnél pár hónapja meg megállt működni a GRE tunnel, a bugbejelentésekre nulla reakció, azóta csak mode ipip. Sorolhatnám még, de nem akarom ezen felidegesíteni magam :)

Komoly fenntartasokkal kezelem, amit irsz. Reszben azert, mert ez a "szar" nalunk igen massziv meretekben is mukodik, masreszt mert zoldsegeket irsz itt-ott. Ennek ellenere erdekelnek a bugreportok. Az teny, hogy link nelkul nem akarodzik tovabbmennie a bootnak, ha van halozati fuggoseg - de ezt en annyira nem tartom megleponek. Ha valaki STP es hasonlokkal szivatja magat, ami lecsapja a linket, amig a switch tokoreszik, az szerintem egyeni szoc problema.

Zöldségeket te beszélsz, a spanning-tree triviális dolog, link volt, ezt is sokan bugreportolták és erre is ugyanaz volt a reakció: vlanok? ne használd.

Egy szavadat sem hiszem. Mutass vegre egy bugreportot!

keress ha akarsz b+
gre, vagy vlan bugokra, fogsz találni egy rakást.

Én LTS-t csak LTS-re frissítek. Nem is látom, hogy van új rilíz :)
Kb. ugyanennyi idő alatt frissül, és tisztább, szárazabb érzés.
Azt sem árt tudni, hogy Ha LTS-ed van, akkor nem kiadáskor frissül.

12.04 esetén akkor jelent meg a frissítési lehetőség, amikor kiadták a 14.04.1-est.
--
PtY - www.onlinedemo.hu, www.westeros.hu

Ja, az lesz, az összes többit kerülni fogom.
De az a rohadt fglrx még mindig nem akar települni...

# apt-get install fglrx
Csomaglisták olvasása... Kész
Függőségi fa építése
Állapotinformációk olvasása... Kész
Néhány csomagot nem lehetett telepíteni. Ez azt jelentheti, hogy
egy lehetetlen állapotot kért, vagy ha az unstable disztribúciót
használja, akkor néhány igényelt csomag még nem készült el vagy ki
lett mozdítva az Incoming-ból.
Az alábbi információk segíthetnek megoldani a problémát:

Az alábbi csomagoknak teljesítetlen függőségei vannak:
fglrx : Függ ettől: xorg-video-abi-11 de az nem telepíthető vagy
xorg-video-abi-12 de az nem telepíthető vagy
xorg-video-abi-13 de az nem telepíthető vagy
xorg-video-abi-14 de az nem telepíthető vagy
xorg-video-abi-15
E: A problémák nem javíthatók, sérült csomagokat fogott vissza.

apt-get install fglrx=2:15.200-0ubuntu4