3.16-os kernellel érkezhet a Debian Jessie

 ( trey | 2014. július 28., hétfő - 9:48 )

A Debian fejlesztők azon vacilláltak, hogy melyik kernellel szállítsák majd a Debian következő nagyobb kiadását, a Jessie kódnév alatt futó Debian 8-at. A Greg Kroah-Hartman által támogatott, hosszú (longterm) karbantartású 3.14 és az Ubuntu kernel csapat által 15-18 hónapon keresztül támogatott 3.16-os kernel közt hezitáltak. A fejlesztők visszajelzése alapján a debian-kernel listán Ben Hutchings azt a következtetést vonta le, hogy a győztes a 3.16-os kernel, így nagy esély van arra, hogy a Jessie ezzel a Linux kernelverzióval érkezik majd.

A levél itt olvasható.

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Fejlesztői oldalról van némi indoka a dolognak, de végfelhasználói oldalról van jelentősége a döntésnek?

Én annak idején többek között a kernel miatt váltottam Debianra az Ubunturól..

Miért? Driver? Kompatibilitás?

Ugyanazon a vason a Debianos kernel valamelyest (10% nagyjából) fürgébbnek mutatkozott. Azon kívül, hogy nem kis munka volt kitakarítani az Ubuntuból a fölös szolgáltatásokat. Az utolsó Ubuntum még a Lucid volt.

Ubuntu-menekülteknek tudom javasolni az Arch -ot..

--
arch,xubuntu,debian,windows,android

dev: http://goo.gl/7Us0GN
BCI news: http://goo.gl/fvFM9C

+1

Én meg a jessie miatt váltottam debianról ubuntura. :) Az tette be a kaput, mikor eltűnt az x, meg a hang egy frissítés után. Tudom, sid, de ez akkor nem esett jól.

Gondolom csak véletlen a Sid és Jessie következetlen használata. :) Én még a Squeeze-zel kezdtem a Debiant.

Gyermek... Nekem 2008-ban etc volt az első debian rendszerem. Igazából az első linux rendszerem is. Azóta is töretlen a "szerelem". Persze kipróbáltam más disztrókat is, és a forkokat is(a Mint pl. a legígéretesebb, sokkal jobban bejövős, mint az Ubuntu) de munkára csakis Debian-t használok. Nem is érzelmi okokból elsősorban. Ezt ismerem a legjobban, ehhez kell a legkevesebbet utánaolvasnom. Szóval a lustaság a fő motiváló erő!

Az a hiba nálam is jelentkezett Jessie alatt, de 5 perc alatt ki lehetett javítani azt.
Én anno egyébként a folyamatos Ubuntu frissítési problémák miatt váltottam Debian-ra. (Debian-ból indult az Ubuntu, de iszonyatosan elvesztette a stabilitását a rendszer)

A driver mindenképp az újabb mellett szól.

Nem lenne egy rossz döntés, mert: van egy gépem, z97 alaplappal, gtx 750 ti videókártyával és ez a kombó jelenleg nem jön be se a wheezynek se a jessienek... ráadásul jessienél még a nouveau driver sem ismeri fel a kártyát (mondjuk wheezy el sem indul vele, a kernel és a videókártya driver miatt), így gyönyörűen dolgozom 1280x1024 felbontással... Elvileg azt írták az x.org váltás miatt van a probléma (az 1.16 (vagy vmi hasonlóra váltanak) még nem támogatott nvidia oldalról). Még türelmes vagyok, de per pill nagyon szopó ágon vagyok debian alatt... Tudom használjak másik repót vagy dobjam ki a csába a videókártyát, de nem igazán szeretnék ez miatt váltani, várok még egy kicsit, vannak biztató jelek levelező listákon, majd kiderül, remélem hamar.

Igen. Masik repot.
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=755020
http://hackedbellini.org/linux/downgrade-and-force-some-packages-on-debian-to-a-previous-version/
Avagy:
deb http://snapshot.debian.org/archive/debian/20140715T222335Z/ testing main contrib non-free

/etc/apt/preferences
Package: xserver-*
Pin: origin "snapshot.debian.org"
Pin-Priority: 1001

Elotte ket nappal szivtam azzal, hogy restart utan a systemd miatt a network nemhoyg nem allt fel, de a ctrl-c-re sem regaalt.
Mire ezt athidaltam egy system rescue cd-vel (/etc/init.d/network elejere egy "exit 0") jott a kovetkezo szopas:
nvidia driver annyira inkompatibilis lett, hogy el is tunt a testing repobol. A fenti megoldotta.

Mindenesetre most anyam gepere Ubuntut raktam. Arra a gepre, amit eddig en hasznaltam. Es boot utan szepen le is fagy.... Valami vagy az X tajan van, vagy az alaplapi videokartya makkant meg. Meg nem tudom, de a heten rajovok.

--
http://www.micros~1

Ez a megoldás megoldotta a problémád? Az az igazság, azért nem akarok még repót váltani, mert elvileg a levelező listán urgency=high volt, hogy sidbe bemozgasság az nvidia legújabb driverét, ez volt 07.21., 07.23 már elvileg bent volt (mondjuk ettől függetlenül kipróbáltam a legújabb nvidia béta drivert, de a lényeg az volt a telepítő hibaüzeneteinek: nekem ez szar ügy). Mondjuk azt, hogy ez az x kompabilitást hogy oldja meg passz, de gondolom a fiúk dolgoznak a problémán, mert szerintem ez a helyzet elég súlyos. És mindez akkor bukik ki, amikor gépet fejlesztek... Tudom, az én hibám, minek ilyen drága dolgokba feccölni a core2duommal ilyen gond nem lenne, de ez van... :)
Mondjuk ez miatt a probléma miatt nem váltanék disztrót, nekem bejött ez a systemd debian a korábbi gépem, tetszik a gyorsabb indulás, leállítás és az egyéb hozadékok. Tudom van más systemd-es disztró is, de igazából ez az én hülyeségem, kitartok.
A lényeg: azért nem akarok downgradeölni, mert később ki is mehet az okos fejemből a dolog, a világ meg husss- elszalad mellettem, és akkor megint törhetem az okos fejem a megoldáson. Pár hetet ki tudok bírni így, kicsit zavaró a dolog, de bízom a fiúkban/lányokban.

Egyébként a felfele váltás azért volt szükséges, mert a z97 alaplap + gt630 vga kombót nem kezelte le rendesen a wheezy. Aztán a z97 alaplapot a jessie jól fogadta, viszont a gt630 még mindig nem ment (mondjuk win7 sem látta pontosan mi van a pcie slotba, csak az, van valami nvidia), na ekkor váltottam felfele vga-ban is, amit a wheezy esélytelennek mondott a jessie látja, de ott meg az x mizéria miatt szar ügy van.

Este, ha hazamegyek megnézem a sid-ben mi a pálya, hátha ott már javult a helyzet, azt behúzom onnan a szükséges dolgokat.

Persze, mukodik. Minthogy a csomagoknak egy nappal regebbi allapota volt, nem nagyon zavart. xorg meg nvidia driver ment vissza regebbire (vagyis csak az xorg, minthogy nvidia diverbol nem is volt mar akkor....). Egy nappal regebbi, azt elviselem.

bug reportra (asszem) feliratkoztam, meg neha meg ius nezem, ujra bekerult-e, de igazan annyira nem akarom frissiteni. Most eppen mukodik....

systemd-vel nem is lenne baj, ha mukodne. Minthoyg megakasztja a bootot, hat nem szeretem. Ha nyomok egy ctrl-c-t es nem all fel bootkor a network, de tovabbmegy, leszarom, csak sajna nem ez volt a helyzet. Mindegy, majd egyszer megjavul.

--
http://www.micros~1

nos nálam a sid-be menekülés nem jött be, uolyan szar, mint eddig. :) szóval akkor várok türelemmel, nem downgradelek még egyenlőre.

Na eddig kellett várnom, tegnap jött egy frissítés, ami hatására a sid-ből behúzott nvidia driver végre megfelelően működik, végre minden oké. Türelem rózsát termett ebben az esetben. :)

En megvarom, mig a testingbe bekerul. Semmi kedvem a SID-del szivatni magam.

--
http://www.micros~1

nekem teljesen oké, egy apró hiba van a testingben is: beírok valamit fstab-ba (2 ntfs particiót csatoltatnék automatikusan) és rendszerindításkor lehal a rendszer (system checknél) hiába komentelem ki a beírt sorokat, amíg nem törlőm őket, addig nem indul el a rendszer. reoveryben sem. Azt rinyálja, ha beléptem futassam a journalctl -xb -t vagy mit.... na ez egy szép bug. meg ha be vagyok jelentkezve konzolon is, nem mindig kapcsol ki a gép, mikor azt mondom neki: kikapcs. Lejelentettem mindkettőt bugra, még eddig semmi.

Hasznaltam en vagy ot evig SID-et, de meguntam. Visszaalltam testingre. Aztan amikor ujrahuztam 64 bitesre, vegleg testing maradt es a sajat forditasokat is kerulom. Igy se oke a steam (sot meg a skypeot is elcseszi), semmi kedvem ujabb bonyodalmakat magamra venni.

--
http://www.micros~1

No, akkor amint lecsorog a testingbe, fel is lehet tenni a már meglévő Wheezy userlandhez.

------------------------------------------------------------------------------
www.woodmann.com/searchlores/welcome.htm

A wifi támogatása javulni fog?

......................
Egymás segítésére még: http://pc-kozosseg.com

A wifi támogatás midig is hibátlan volt.
Nekem.
Én mindig olyan hardware-t vásárolok, amit támogat kedvenc (debian)
rendszerem.

Nekem 10 éves laptopom van és valahogy a letöltött firemware-t sem ismeri fel a telepítő. Ezért gondoltam, hogy az újjabb kernelbe hátha beépítettek valamit, ami már felismeri.

......................
Egymás segítésére még: http://pc-kozosseg.com

Nekem egy 8 eves laptopon az Intel PRO/Wireless 2200 WIFI kartyat minden gond nelkul felismerte. Milyen kartya van a laposban?

--
Debian GNU/Linux

Network Card SiS 900 integrated fast ethernet
Atheros AR5BMB5 Wireless LAN *
A manjaro automatikusan felismeri.
......................
Egymás segítésére még: http://pc-kozosseg.com