OpenWrt nem ad ip-t a guest wifi-nek

 ( pch | 2016. november 16., szerda - 8:04 )

Üdv!

Lett egy guset interfaces készítve a sima lan interfaces lemásolásával guest néven.
Itt general settingsbe:
Static address
192.168.2.10 /255.255.255.0
Firewall fülön pedig egy új GUEST zónához lett kapcsolva.
DHCP szervernél:
100/150/12h
Advancednél pedig Dynamic DHCP

Firewall GUEST:
rej/ac/rej
network: guest
Dest zone: wan

Trafic rulesnél:
Guest DNS
Any TCP, UDP
From any host in GUEST
To any router IP at port 53 on this device

Guest DHCP
Any UDP
From any host in GUEST
To any router IP at ports 67-68 on this device

A telefonok/laptopok látják elkezdenek csatlakozni de várnak ip-re.
Mit rontottam el?

pch

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Namégegyszer (rejtett up)

pch
--
http://www.buster.hu "A" számlázó
--

Vettél fel neki külön DHCP-tartományt.? És amúgy miért a LAN-interfészt másoltad, miért nem a Wifi-t.? Mert kéne ugyebár még egy device az /etc/config/wireless fájlba..
--
God bless you, Captain Hindsight..

Bocs a wifi-t másoltam term.
Ezt hogy?:
Vettél fel neki külön DHCP-tartományt.?

pch
--
http://www.buster.hu "A" számlázó
--

Az /etc/config/dhcp fájlba kellene valami hasonló :

config dhcp 'guest'
option interface 'guest'
option start '50'
option limit '200'
option leasetime '1h'

Innen van : https://wiki.openwrt.org/doc/recipes/guest-wlan

--
God bless you, Captain Hindsight..

Igen.
DHCP szervernél:
100/150/12h
Advancednél pedig Dynamic DHCP

De holnap bekapcsolom a force-t is rá

pch
--
http://www.buster.hu "A" számlázó
--

Értem, de kettő vagy több ilyen szekció kell ám, az megvan.?
Egy config dhcp 'lan' és utána meg a config dhcp 'guest' a vendéghálónak..
Vagy a LAN vagy WAN oldalon nem használsz.?
--
God bless you, Captain Hindsight..

Újracsatlakoztattam a guest interface-t és most jó is lett egyből...

pch
--
http://www.buster.hu "A" számlázó
--

"..még jó, hogy bele nem lépett."
Hajrá..
--
God bless you, Captain Hindsight..

Nos tovább bonyolódik a helyzet...
A guest wifi már megkapja a dhcp-től az ip-t.
Ki is lát a net fele, de nincs ami feloldja a dns-kéréseket.

A hálózat > interface -nél hiába állítottam be, hogy egyedi dns szervert használok és oda megadtam a 8.8.8.8 -at nem használja.
A dns-nél meg a local háló miatt az van beállítva, hogy helyi tartomány és helyi kiszolgáló van.

Így ami nem a guest-en van azt szépen feloldja a dns de ami a guesten van azt meg nem.
Arra meg nem láttam beállítást, hogy máshol hol kellene megadni a dns szervereket.

Erre ötlet esetleg?

pch
--
http://www.buster.hu "A" számlázó
--

""Trafic rulesnél:
Guest DNS
Any TCP, UDP
From any host in GUEST
To any router IP at port 53 on this device

Ha így van még beállítva, akkor a 8.8.8.8 eleve felejtős, nem.?

--
God bless you, Captain Hindsight..

Akkor vegyem ki ezt a rules-t?

pch
--
http://www.buster.hu "A" számlázó
--

Akkor végképp nem lesz dns-ed. Azt állítsd be, hogy a router ip-je legyen a dns első körben.
Kifelé ugye engedsz mindent a guest-ből.?
--
God bless you, Captain Hindsight..

Nem ilyen egyszerű.
A lan és a sima wifinek a dns-e az a gép ahol a windows autentikál.
De zgye oda nem engedhetem a guest-et.
Holnap csinálok screenshotot.
Szal a sima hálónál a dns egy helyi gép és nem a router.
Ezért írt be a guestnél a 8.8.8.8-at dns-nek csak nem használja.

pch
--
http://www.buster.hu "A" számlázó
--

Itt a config:
http://pastebin.com/EB7Uy09D

pch
--
http://www.buster.hu "A" számlázó
--

.

Éppen a hányás-hasmenéssel küzdök..
Szóval miért lett így megcsinálva a dns.? Akkor a router-é nem is megy egyáltalán.?
Én vagy azt csinálnám, hogy a router DNS-ét beizzítanám és azon beállítanám a gyökér dns-t a pc-s dns-hez
Vagy akkor portforward-al a guest hálóból a dns-kéréseket továbbítsd a google dns-ekhez..
--
God bless you, Captain Hindsight..

Üdv!

Ez utóbbit hogy?
Most ugye ez van:
config rule
option target 'ACCEPT'
option proto 'tcp udp'
option dest_port '53'
option name 'Allow DNS Queries'
option src 'GUEST'

u.i.: jobbulást!

pch
--
http://www.buster.hu "A" számlázó
--

Juteszembe, ez miért így van.?

config zone
option name 'GUEST'
option network 'GUEST'
option output 'ACCEPT'
option forward 'REJECT'
option input 'REJECT' <<---------------||
--
God bless you, Captain Hindsight..

Így írta a dokumentum.
De a guest inputról nem el kell dobni mindent?

pch
--
http://www.buster.hu "A" számlázó
--