apt-get -f install gond

 ( jusztin | 2016. október 11., kedd - 22:22 )

Tulajdonkeppen ez a gondom megvan amiota frisitettem a regi debianom a legujabbra de most mar zavaro lett ... Annyit rajottem hogy regebbi a grafikus kartyam es ott van valami utkozes de nem tudtam akkor sem megoldani.

Amikor frissitettem, akkor is nagyon sokat kinlodtam hogy mukodjon a grafikus felulet eppen az okbol kifolyolag csak ovatosan mertem kiserletezni vele ...

A grafikus kartya egy nVidia Quadro FX 1400

Mi a folosleg mit kell eltavolitanom? Minden segitseget elore is koszonok.

a hibat amit kapok bemasolom ide ...

Reading package lists...
Building dependency tree...
Reading state information...
Correcting dependencies... Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
12 not fully installed or removed.
Need to get 0 B/9,432 B of archives.
After this operation, 0 B of additional disk space will be used.
dpkg: error processing package glx-diversions (--configure):
package glx-diversions is not ready for configuration
cannot configure (current status `half-installed')
dpkg: dependency problems prevent configuration of glx-alternative-mesa:
glx-alternative-mesa depends on glx-diversions (= 0.5.1); however:
Package glx-diversions is not installed.

dpkg: error processing package glx-alternative-mesa (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of glx-alternative-nvidia:
glx-alternative-nvidia depends on glx-diversions (= 0.5.1); however:
Package glx-diversions is not installed.
glx-alternative-nvidia depends on glx-alternative-mesa; however:
Package glx-alternative-mesa is not configured yet.

dpkg: error processing package glx-alternative-nvidia (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-legacy-304xx-alternative:
nvidia-legacy-304xx-alternative depends on glx-alternative-nvidia (>= 0.4); however:
Package glx-alternative-nvidia is not configured yet.

dpkg: error processing package nvidia-legacy-304xx-alternative (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-nvidia-legacy-304xx-glx:amd64:
libgl1-nvidia-legacy-304xx-glx:amd64 depends on nvidia-legacy-304xx-alternative (= 304.131-1); however:
Package nvidia-legacy-304xx-alternative is not configured yet.

dpkg: error processing package libgl1-nvidia-legacy-304xx-glx:amd64 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-nvidia-legacy-304xx-glx:i386:
libgl1-nvidia-legacy-304xx-glx:i386 depends on nvidia-legacy-304xx-alternative (= 304.131-1); however:
Package nvidia-legacy-304xx-alternative is not configured yet.

dpkg: error processing package libgl1-nvidia-legacy-304xx-glx:i386 (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of xserver-xorg-video-nvidia-legacy-304xx:
xserver-xorg-video-nvidia-legacy-304xx depends on libgl1-nvidia-legacy-304xx-glx (= 304.131-1); however:
Package libgl1-nvidia-legacy-304xx-glx:amd64 is not configured yet.
xserver-xorg-video-nvidia-legacy-304xx depends on nvidia-legacy-304xx-alternative (= 304.131-1); however:
Package nvidia-legacy-304xx-alternative is not configured yet.

dpkg: error processing package xserver-xorg-video-nvidia-legacy-304xx (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-kernel-common:
nvidia-kernel-common depends on glx-alternative-nvidia (>= 0.3); however:
Package glx-alternative-nvidia is not configured yet.

dpkg: error processing package nvidia-kernel-common (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-legacy-304xx-kernel-dkms:
nvidia-legacy-304xx-kernel-dkms depends on nvidia-kernel-common (>= 20110213); however:
Package nvidia-kernel-common is not configured yet.
nvidia-legacy-304xx-kernel-dkms depends on nvidia-legacy-304xx-alternative--kmod-alias; however:
Package nvidia-legacy-304xx-alternative--kmod-alias is not installed.
Package nvidia-legacy-304xx-alternative which provides nvidia-legacy-304xx-alternative--kmod-alias is not configured yet.

dpkg: error processing package nvidia-legacy-304xx-kernel-dkms (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-legacy-304xx-driver:
nvidia-legacy-304xx-driver depends on libgl1-nvidia-legacy-304xx-glx (= 304.131-1); however:
Package libgl1-nvidia-legacy-304xx-glx:amd64 is not configured yet.
nvidia-legacy-304xx-driver depends on xserver-xorg-video-nvidia-legacy-304xx (= 304.131-1); however:
Package xserver-xorg-video-nvidia-legacy-304xx is not configured yet.
nvidia-legacy-304xx-driver depends on nvidia-legacy-304xx-alternative (= 304.131-1); however:
Package nvidia-legacy-304xx-alternative is not configured yet.
nvidia-legacy-304xx-driver depends on nvidia-legacy-304xx-kernel-dkms (= 304.131-1) | nvidia-legacy-304xx-kernel-304.131; however:
Package nvidia-legacy-304xx-kernel-dkms is not configured yet.
Package nvidia-legacy-304xx-kernel-304.131 is not installed.
Package nvidia-legacy-304xx-kernel-dkms which provides nvidia-legacy-304xx-kernel-304.131 is not configured yet.

dpkg: error processing package nvidia-legacy-304xx-driver (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of nvidia-settings-legacy-304xx:
nvidia-settings-legacy-304xx depends on nvidia-legacy-304xx-alternative; however:
Package nvidia-legacy-304xx-alternative is not configured yet.

dpkg: error processing package nvidia-settings-legacy-304xx (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libgl1-nvidia-legacy-304xx-glx-i386:
libgl1-nvidia-legacy-304xx-glx-i386 depends on libgl1-nvidia-legacy-304xx-glx; however:
Package libgl1-nvidia-legacy-304xx-glx:i386 is not configured yet.

dpkg: error processing package libgl1-nvidia-legacy-304xx-glx-i386 (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
glx-diversions
glx-alternative-mesa
glx-alternative-nvidia
nvidia-legacy-304xx-alternative
libgl1-nvidia-legacy-304xx-glx:amd64
libgl1-nvidia-legacy-304xx-glx:i386
xserver-xorg-video-nvidia-legacy-304xx
nvidia-kernel-common
nvidia-legacy-304xx-kernel-dkms
nvidia-legacy-304xx-driver
nvidia-settings-legacy-304xx
libgl1-nvidia-legacy-304xx-glx-i386

Hozzászólás megjelenítési lehetőségek

A választott hozzászólás megjelenítési mód a „Beállítás” gombbal rögzíthető.

Szerintem csak simán csomag hiba van, vagy neked kell kézzel kiválasztani (még valamit). DE fontos neked az openszósz? Mert ha nem, akkor tedd fel az nvidiás drivert. Először is letöltöd az nvidiától a neked kellő verziót (ne a /tmp-be tedd :) ), kimész valós konzolra (Alt+F2), majd ott leszeded ezeket a problémás csomagokat, aztán elindítod az nvidiás .run-t. Végén biztos ami biztos, nyomsz egy update-initramfs -u -k all-t.
Elvileg.

---------------------------------------------------------------
Ritkán szólok hozzá dolgokhoz. Így ne várj tőlem interakciót.

Nem tudom de elmeletileg az nVidiatol letoltott driver van fent, vagyis le toltottem vegig is csinaltam amit irtal meg akkor regen hogy eletet leheljek a grafikus feluletbe hacsak azota valami frissitessel nem irtam felul azt a drivert ...

Odaig jutottam hogy megoldottam a fuggosegeket mostmar az apt-get nem jelez hibat. De most meg a Gnome nem indul el. Ha root -kent birom a startx -et akkor ugy mukodik de csak mint root felhasznalo. Kozonseges userkent viszont nem indul el. Annyit talaltam a neten hogy talan valami bug van ha jol ertettem angolul. Amiket a googleban talaltam vegigprobalgattam de tovabbra sem indul el ...Odaig eljutok hogy bejelentkezek elindul grafikus modban majd kiirja hogy Oh no! Something has gone wrong. ...

Ha root-ként elindul, akkor jogosultság hiba van. Ez akkor szokott lenni, a szerverre húznak grafikus rendszert. Ez csak hozzáértőnek javasolt.
Szerintem mentsd ki a /home-ot, és telepíts egy grafikus debiant.
Abban gyárilag jók a csomagok is, és a felhasználók jogai is.
Egyébként a logokban minden (/var/log/) benne van. Azok alapján is nyomozhatsz.
Sok sikert.

---------------------------------------------------------------
Ritkán szólok hozzá dolgokhoz. Így ne várj tőlem interakciót.

Sudo-val nem indítottál grafikus programot? Mondjuk szövegszerkesztőt?

Nem inditottam seemit olyasmit, viszont root -kent probalgattam kitrorlni azokat a fuggosegeket ... Azota mar a /home/user konyvtarabman is lefutattam egy chown user:user -R * parancsot igy ott mindent fajl az enyem biztosan ...

Azt hittem, gondot installálsz.

Fuszenecker Róbert

/o\ teljesen jogos :D
------------------------
{0} ok boto
boto ?

Próbálj meg egy weekly build-et is, azok elég frissek:
http://cdimage.debian.org/cdimage/weekly-builds/amd64/iso-cd/

____________________________________
Ha vita van, számoljanak órajelciklusokat. Egyesével.

Első körben jó lenne, ha fel lenne rakva nálad az aptitude csomag.
Pár órás ismerkedés után sokkal jobban tudnád kezelni a függőségeket és a felesleges csomagokat is simán el tudnád távolítani vele.
Ajánlom, hogy frissítsd a repókat:
apt-get update -o Acquire::Pdiffs=false

Továbbá próbálhatnád ezeket a parancsokat:

dpkg --configure -a
Ez konfigurálja azokat a programokat, amik még nem lettek beállítva.

find /var/cache/apt/archives/ -name '*.deb' -exec dpkg -i {} \;
Ez a korábban letöltött csomagokat telepíti egyesével. Ezt akár többször is futtathatod.

dpkg -i /var/cache/apt/archives/*.deb
Ez az előző egy alternatívája, de itt minden a könyvtárban lévő csomagot egyszerre próbál telepíteni és itt nem valószínű, hogy függőségi hibákat kapsz, mint az előznél.

Ha még ezeknek a parancsoknak az ismételgetése után is hibákat kapsz, akkor kiadhatod a legdurvább telepítő parancsot is:
dpkg --force-all -i csomag.deb
VIGYÁZZ!!! Ezzel ki is nyírhatod a telepítésed!!! :)

--
Debian Linux rulez... :D
RIP Ian Murdock